Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2240490 - Using shift lock on character with accent produces lower case character with accent
Summary: Using shift lock on character with accent produces lower case character with ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mutter
Version: 39
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Florian Müllner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: F39FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2023-09-24 19:59 UTC by Couret Charles-Antoine
Modified: 2023-10-06 08:02 UTC (History)
18 users (show)

Fixed In Version: mutter-45.0-7.fc40 mutter-45.0-5.fc39
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-10-05 21:15:46 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
GNOME Gitlab GNOME mutter issues 3058 0 None opened CapsLock does not work for French accent characters in Wayland 2023-09-27 09:56:31 UTC
GNOME Gitlab GNOME mutter merge_requests 3306 0 None merged backends/native: Translate keycodes with xkb_key_state_get_one_sym() 2023-10-04 08:40:56 UTC

Description Couret Charles-Antoine 2023-09-24 19:59:33 UTC
Using Fedora 39 with GNOME environment and AZERTY (French) layout.

The purpose is to get upper case character with accent. Shift lock + é = É. It's the behaviour until Fedora 38. Since Fedora 39, Shift lock + é = é. Obviously for characters without accents, the character is upper case.

This issue happens for other characters like èàçù...

Not totally sure if ibus is responsible of this issue.

Reproducible: Always

Actual Results:  
Shift lock + é = é

Expected Results:  
Shift lock + é = É

Comment 1 fujiwara 2023-09-25 06:59:38 UTC
I see your problem in GNOME Wayland but not GNOME Xorg and it might be a Wayland relative issue.

Comment 2 Couret Charles-Antoine 2023-09-26 18:25:22 UTC
I confirm, switching to GNOME with Xorg fixes the issue.

Comment 3 Alessio 2023-09-27 09:23:09 UTC
Same issue here (Italian keyboard).
In a Wayland session, on some applications (i.e. Chrome flatpak, Telegram flatpak) the keys combination (caps lock+àèìòù) works.

Comment 4 fujiwara 2023-09-27 09:31:18 UTC
Seems gnome-text-editor(GTK4) works but gedit(GTK3) does not work in Wayland.

Comment 5 fujiwara 2023-09-27 09:48:21 UTC
(In reply to fujiwara from comment #4)
> Seems gnome-text-editor(GTK4) works but gedit(GTK3) does not work in Wayland.

Sorry this cases was applied GTK_IM_MODULE=ibus

Both gnome-text-edit and gedit does not work in Wayland in case of GTK_IM_MODULE=wayland

Comment 6 Kamil Páral 2023-09-27 11:43:28 UTC
I can confirm this with a Czech keymap. In all wayland-native apps I've tested, CapsLock doesn't work as expected with accented letters (e.g. ěščřžýáíé). With XWayland apps, it works OK (displays an uppercase accented letter).

CapsLock functionality is quite a fundamental part of the desktop. Proposing for a blocker discussion.

Comment 7 Aoife Moloney 2023-10-02 17:29:59 UTC
Discussed during the 2023-10-02 blocker review meeting: [1]

The decision to classify this bug as an AcceptedFreezeException (Final): was made:


"After mulling it over, we find that the severity of this bug is low enough to not warrant blocking the release on it. We grant it FE status."


[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2023-10-02/f39-blocker-review.2023-10-02-16.01.log.txt

Comment 8 Kamil Páral 2023-10-04 08:40:56 UTC
This seems to be fixed in:
https://gitlab.gnome.org/GNOME/mutter/-/merge_requests/3306

Can somebody prepare an update for Fedora? Thanks!

Comment 9 Kalev Lember 2023-10-04 13:33:45 UTC
Sure, I went ahead and backported the patch in https://src.fedoraproject.org/rpms/mutter/c/848607c3b1cc3b87051141b24dce54cca5687941?branch=rawhide and kicked off the builds for F39 and rawhide.

Comment 10 Fedora Update System 2023-10-04 13:55:53 UTC
FEDORA-2023-725a18d9f1 has been submitted as an update to Fedora 39. https://bodhi.fedoraproject.org/updates/FEDORA-2023-725a18d9f1

Comment 11 Fedora Update System 2023-10-05 01:49:30 UTC
FEDORA-2023-725a18d9f1 has been pushed to the Fedora 39 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-725a18d9f1`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-725a18d9f1

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 12 Kamil Páral 2023-10-05 07:30:06 UTC
Works as expected with a Czech keymap, thanks!

Comment 13 Fedora Update System 2023-10-05 21:15:46 UTC
FEDORA-2023-725a18d9f1 has been pushed to the Fedora 39 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.