Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2242061 - Removing scale-monitor-framebuffer distorts the image, if not reset to 100% scale beforehand
Summary: Removing scale-monitor-framebuffer distorts the image, if not reset to 100% s...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mutter
Version: 39
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Florian Müllner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: F39FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2023-10-04 07:29 UTC by Kamil Páral
Modified: 2023-10-05 21:15 UTC (History)
7 users (show)

Fixed In Version: mutter-45.0-5.fc39
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-10-05 21:15:50 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
GNOME Gitlab GNOME mutter issues 3057 0 None opened Removing scale-monitor-framebuffer distorts the image, if not reset to 100% scale beforehand 2023-10-04 07:29:31 UTC
GNOME Gitlab GNOME mutter merge_requests 3299 0 None opened Draft: monitor-config-store: Discard config with fractional scale when unusable 2023-10-04 07:29:57 UTC

Description Kamil Páral 2023-10-04 07:29:32 UTC
The issue is described in upstream here:
https://gitlab.gnome.org/GNOME/mutter/-/issues/3057

I'd like to request a freeze exception to pull in the mutter patch. The reason is that we've had the fractional scaling enabled during F39 development, and if people enabled it, let's say to 125%, and later it got disabled again, those people now have distorted text. The text is just slightly off, but off enough to make your feel "there's something not right, this is harder to read for some reason". I believe it's fair to fix their text rendering asap, and not in some distant future, when a new mutter version is released (and hopefully updated in F39).

Comment 1 Kamil Páral 2023-10-04 07:29:58 UTC
The working fix is here:
https://gitlab.gnome.org/GNOME/mutter/-/merge_requests/3299

Comment 2 Fedora Update System 2023-10-04 10:43:23 UTC
FEDORA-2023-725a18d9f1 has been submitted as an update to Fedora 39. https://bodhi.fedoraproject.org/updates/FEDORA-2023-725a18d9f1

Comment 3 Adam Williamson 2023-10-04 16:56:26 UTC
+3 in https://pagure.io/fedora-qa/blocker-review/issue/1372 , marking accepted.

Comment 4 Fedora Update System 2023-10-05 01:49:34 UTC
FEDORA-2023-725a18d9f1 has been pushed to the Fedora 39 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-725a18d9f1`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-725a18d9f1

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 5 Kamil Páral 2023-10-05 07:30:23 UTC
The update fixes the problem, thanks

Comment 6 Fedora Update System 2023-10-05 21:15:50 UTC
FEDORA-2023-725a18d9f1 has been pushed to the Fedora 39 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.