Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2247292 - modulemd-tools fails to build in Fedora 39 and 40: test_run_modifyrepo fails with no *-modules.yaml.gz
Summary: modulemd-tools fails to build in Fedora 39 and 40: test_run_modifyrepo fails ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: modulemd-tools
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jakub Kadlčík
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F39FTBFS F40FTBFS PYTHON3.13
TreeView+ depends on / blocked
 
Reported: 2023-10-31 18:15 UTC by Miro Hrončok
Modified: 2023-11-10 01:44 UTC (History)
3 users (show)

Fixed In Version: modulemd-tools-0.16-4.fc40 modulemd-tools-0.16-4.fc39
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-11-10 01:44:05 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Miro Hrončok 2023-10-31 18:15:09 UTC
modulemd-tools fails to build in Fedora 39 and 40.

https://koschei.fedoraproject.org/package/modulemd-tools

=================================== FAILURES ===================================
_____________________________ test_run_modifyrepo ______________________________
test_output_dir = local('/tmp/pytest-of-mockbuild/pytest-0/output0')
    def test_run_modifyrepo(test_output_dir):
        if not os.path.isfile(os.path.join(test_output_dir, "modules.yaml")):
            logger.info("Seems like test_dump_modules_yaml was skipped. "
                        "Creating modules.yaml from dummy.yaml.")
            shutil.copy(os.path.join(test_module_yamls_dir, "dummy.yaml"),
                        os.path.join(test_output_dir, "modules.yaml"))
    
        assert os.path.isfile(os.path.join(test_output_dir, "modules.yaml"))
        retval = run_modifyrepo(test_output_dir)
>       assert glob.glob(os.path.join(test_output_dir, "repodata", "*-modules.yaml.gz"))
E       AssertionError: assert []
E        +  where [] = <function glob at 0x7fca8812e3e0>('/tmp/pytest-of-mockbuild/pytest-0/output0/repodata/*-modules.yaml.gz')
E        +    where <function glob at 0x7fca8812e3e0> = glob.glob
E        +    and   '/tmp/pytest-of-mockbuild/pytest-0/output0/repodata/*-modules.yaml.gz' = <function join at 0x7fca88d98900>(local('/tmp/pytest-of-mockbuild/pytest-0/output0'), 'repodata', '*-modules.yaml.gz')
E        +      where <function join at 0x7fca88d98900> = <module 'posixpath' (frozen)>.join
E        +        where <module 'posixpath' (frozen)> = os.path
tests/test_createrepo_mod/test_createrepo_mod.py:52: AssertionError
------------------------------ Captured log call -------------------------------
INFO     test_createrepo_mod:test_createrepo_mod.py:45 Seems like test_dump_modules_yaml was skipped. Creating modules.yaml from dummy.yaml.
=========================== short test summary info ============================
FAILED tests/test_createrepo_mod/test_createrepo_mod.py::test_run_modifyrepo
============= 1 failed, 83 passed, 8 skipped, 6 warnings in 1.86s ==============


https://koschei.fedoraproject.org/build/16087868 indicates this might be caused by createrepo_c update to 1.0.0.


This is blocking our attempts to test the package with Python 3.13.

Comment 1 Fedora Update System 2023-11-01 09:55:08 UTC
FEDORA-2023-c6f0266a91 has been submitted as an update to Fedora 39. https://bodhi.fedoraproject.org/updates/FEDORA-2023-c6f0266a91

Comment 2 Fedora Update System 2023-11-02 01:47:43 UTC
FEDORA-2023-c6f0266a91 has been pushed to the Fedora 39 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-c6f0266a91`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-c6f0266a91

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 3 Fedora Update System 2023-11-10 01:44:05 UTC
FEDORA-2023-c6f0266a91 has been pushed to the Fedora 39 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.