Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2249037 - Version 2.4.3-3.fc39 of gnupg2 seems to be a development build
Summary: Version 2.4.3-3.fc39 of gnupg2 seems to be a development build
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnupg2
Version: 39
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Jakub Jelen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 2249129 2249853 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2023-11-10 10:15 UTC by mark
Modified: 2023-11-15 16:18 UTC (History)
7 users (show)

Fixed In Version: gnupg2-2.4.3-4.fc39
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-11-12 01:32:42 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker FC-1030 0 None None None 2023-11-10 10:16:05 UTC

Description mark 2023-11-10 10:15:03 UTC
After installing the update to version 2.4.3-3.fc39 from 2.4.3-2.fc39 any gnupg2 command shows a warning about being a development version:

gpg2 --version
gpg (GnuPG) 2.4.3-unknown
libgcrypt 1.10.2-unknown
NOTE: THIS IS A DEVELOPMENT VERSION!
It is only intended for test purposes and should NOT be
used in a production environment or with production keys!
Copyright (C) 2023 g10 Code GmbH
License GNU GPL-3.0-or-later <https://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

Rolling back to 2.4.3-2.fc39 seems to fix the error, looking at both packages in dnfdragora shows a significant increase in size from 2699.4K to 9528.5K which makes me believe (maybe incorrectly) the packaged version is a debug/development build

Reproducible: Always

Steps to Reproduce:
1.Install version 2.4.3-3.fc39 of gnupg package
2.Run gpg2 --version (or any gpg command)

Actual Results:  
Command runs but displays a warning:
NOTE: THIS IS A DEVELOPMENT VERSION!
It is only intended for test purposes and should NOT be
used in a production environment or with production keys!

Expected Results:  
Command runs with no warning

Comment 1 Jakub Jelen 2023-11-10 14:59:33 UTC
Thanks for the report! This happened because of bug #2158627, where I restored systemd units and tried to reconfigure instead of patching Makefile.in but it looks like it has side effects so I will go back and push update soon.

Comment 2 Fedora Update System 2023-11-10 16:21:20 UTC
FEDORA-2023-20cac31c57 has been submitted as an update to Fedora 39. https://bodhi.fedoraproject.org/updates/FEDORA-2023-20cac31c57

Comment 3 Richard Connon 2023-11-10 20:49:51 UTC
*** Bug 2249129 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Update System 2023-11-11 02:30:57 UTC
FEDORA-2023-20cac31c57 has been pushed to the Fedora 39 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-20cac31c57`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-20cac31c57

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 5 Fedora Update System 2023-11-12 01:32:42 UTC
FEDORA-2023-20cac31c57 has been pushed to the Fedora 39 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 6 Clemens Lang 2023-11-15 16:18:57 UTC
*** Bug 2249853 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.