Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2259392 - Intel AX211 Wi-Fi 6E adapter fails to initialize
Summary: Intel AX211 Wi-Fi 6E adapter fails to initialize
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: linux-firmware
Version: 39
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: David Woodhouse
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2024-01-21 04:29 UTC by Scott
Modified: 2024-04-24 01:36 UTC (History)
6 users (show)

Fixed In Version: linux-firmware-20240410-1.fc39 linux-firmware-20240410-1.fc40 linux-firmware-20240410-1.fc38
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2024-04-14 01:36:11 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
dmesg output (deleted)
2024-01-21 04:30 UTC, Scott
no flags Details
dmesg output wiht debug flag (deleted)
2024-01-23 05:17 UTC, Scott
no flags Details

Description Scott 2024-01-21 04:29:04 UTC
The Wi-Fi component of the AX211 Wi-Fi/Bluetooth adapter that came with my laptop (Alienware x14) fails to initialize due to a Microcode SW Error. When this occurs, I have no Wi-Fi functionality, but Bluetooth functions properly. This is an intermittent issue that seems to self-correct occasionally and for up to a few days at a time before occurring again.

Reproducible: Couldn't Reproduce

Steps to Reproduce:
I cannot find a way to manually induce this error. It is an intermittent and seemingly random problem.
Actual Results:  
Wi-Fi adapter does not function.

Expected Results:  
Provided Wi-Fi functionality.

[  146.117891] iwlwifi 0000:00:14.3: Microcode SW error detected. Restarting 0x0.
[  146.118013] iwlwifi 0000:00:14.3: Start IWL Error Log Dump:
[  146.118014] iwlwifi 0000:00:14.3: Transport status: 0x0000004A, valid: 6
[  146.118017] iwlwifi 0000:00:14.3: Loaded firmware version: 83.e8f84e98.0 so-a0-gf-a0-83.ucode

Full dmesg will be attached, and I can try to provide any more information that might be helpful.

Comment 1 Scott 2024-01-21 04:30:14 UTC
Created attachment 2009526 [details]
dmesg output

Comment 2 Peter Robinson 2024-01-21 17:32:12 UTC
Please report versions of linux-firmware and kernel at the very minimum.

Comment 3 Scott 2024-01-21 18:16:43 UTC
Currently on 6.6.11-200.fc39.x86_64, however this has been present since at 38 for me. I've enabled debugging logs of iwlwifi, but currently the card is functioning properly. I'll attach those when it fails again.

Comment 4 Peter Robinson 2024-01-21 18:20:57 UTC
> currently the card is functioning properly. I'll attach those when it fails again.

So when exactly does it fail then?

Comment 5 Scott 2024-01-23 05:16:22 UTC
(In reply to Peter Robinson from comment #4)
> > currently the card is functioning properly. I'll attach those when it fails again.
> 
> So when exactly does it fail then?

I can't really establish any pattern to when it does. Occasionally it will function properly for a few days and then fail for a few, sometimes a restart will fix it.

Comment 6 Scott 2024-01-23 05:17:04 UTC
Created attachment 2009840 [details]
dmesg output wiht debug flag

Comment 7 Fedora Update System 2024-04-11 13:26:49 UTC
FEDORA-2024-5829ba652c (linux-firmware-20240410-1.fc38) has been submitted as an update to Fedora 38.
https://bodhi.fedoraproject.org/updates/FEDORA-2024-5829ba652c

Comment 8 Fedora Update System 2024-04-11 13:27:01 UTC
FEDORA-2024-8390e97bf1 (linux-firmware-20240410-1.fc39) has been submitted as an update to Fedora 39.
https://bodhi.fedoraproject.org/updates/FEDORA-2024-8390e97bf1

Comment 9 Fedora Update System 2024-04-11 13:27:10 UTC
FEDORA-2024-3cb8093bdf (linux-firmware-20240410-1.fc40) has been submitted as an update to Fedora 40.
https://bodhi.fedoraproject.org/updates/FEDORA-2024-3cb8093bdf

Comment 10 Fedora Update System 2024-04-12 02:05:11 UTC
FEDORA-2024-3cb8093bdf has been pushed to the Fedora 40 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2024-3cb8093bdf`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2024-3cb8093bdf

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 11 Fedora Update System 2024-04-12 02:33:59 UTC
FEDORA-2024-8390e97bf1 has been pushed to the Fedora 39 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2024-8390e97bf1`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2024-8390e97bf1

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 12 Fedora Update System 2024-04-12 02:41:38 UTC
FEDORA-2024-5829ba652c has been pushed to the Fedora 38 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2024-5829ba652c`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2024-5829ba652c

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 13 Fedora Update System 2024-04-14 01:36:11 UTC
FEDORA-2024-8390e97bf1 (linux-firmware-20240410-1.fc39) has been pushed to the Fedora 39 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 14 Fedora Update System 2024-04-19 21:35:07 UTC
FEDORA-2024-3cb8093bdf (linux-firmware-20240410-1.fc40) has been pushed to the Fedora 40 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 15 Fedora Update System 2024-04-24 01:36:30 UTC
FEDORA-2024-5829ba652c (linux-firmware-20240410-1.fc38) has been pushed to the Fedora 38 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.