Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2260895 - samba-4.20.0rc1 is available
Summary: samba-4.20.0rc1 is available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: samba
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Guenther Deschner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2024-01-29 17:28 UTC by Upstream Release Monitoring
Modified: 2024-02-01 01:10 UTC (History)
8 users (show)

Fixed In Version: samba-4.20.0-0.1.rc1.fc40
Doc Type: ---
Doc Text:
Clone Of:
Environment:
Last Closed: 2024-02-01 01:10:26 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
Update to 4.20.0rc1 (#2260895) (deleted)
2024-01-29 17:28 UTC, Upstream Release Monitoring
no flags Details | Diff
Update to 4.20.0rc1 (#2260895) (deleted)
2024-01-31 21:11 UTC, Upstream Release Monitoring
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker SSSD-7088 0 None None None 2024-01-29 17:29:41 UTC

Description Upstream Release Monitoring 2024-01-29 17:28:06 UTC
Releases retrieved: 4.20.0rc1
Upstream release that is considered latest: 4.20.0rc1
Current version/release in rawhide: 4.19.4-3.fc40
URL: https://www.samba.org/

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/4758/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/samba

Comment 1 Upstream Release Monitoring 2024-01-29 17:28:13 UTC
Scratch build failed. Details below:

BuilderException: Build failed:
Command '['rpmbuild', '-D', '_sourcedir .', '-D', '_topdir .', '-bs', '/var/tmp/thn-fi0qckgb/samba.spec']' returned non-zero exit status 1.

StdOut:
setting SOURCE_DATE_EPOCH=1706486400
error: Bad file: ./samba-4.20.0rc1.tar.asc: No such file or directory
error: Bad file: ./samba-4.20.0rc1.tar.xz: No such file or directory

RPM build errors:
    Bad file: ./samba-4.20.0rc1.tar.asc: No such file or directory
    Bad file: ./samba-4.20.0rc1.tar.xz: No such file or directory


Traceback:
  File "/usr/local/lib/python3.11/site-packages/hotness/use_cases/package_scratch_build_use_case.py", line 56, in build
    result = self.builder.build(request.package, request.opts)
             ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/local/lib/python3.11/site-packages/hotness/builders/koji.py", line 229, in build
    raise BuilderException(

If you think this issue is caused by some bug in the-new-hotness, please report it on the-new-hotness issue tracker: https://github.com/fedora-infra/the-new-hotness/issues

Comment 2 Upstream Release Monitoring 2024-01-29 17:28:15 UTC
Created attachment 2011392 [details]
Update to 4.20.0rc1 (#2260895)

Comment 3 Fedora Update System 2024-01-31 20:17:02 UTC
FEDORA-2024-e3626586f3 has been submitted as an update to Fedora 40. https://bodhi.fedoraproject.org/updates/FEDORA-2024-e3626586f3

Comment 4 Upstream Release Monitoring 2024-01-31 21:11:46 UTC
Scratch build failed. Details below:

BuilderException: Build failed:
Command '['rpmbuild', '-D', '_sourcedir .', '-D', '_topdir .', '-bs', '/var/tmp/thn-ea7rw3jz/samba.spec']' returned non-zero exit status 1.

StdOut:
setting SOURCE_DATE_EPOCH=1706659200
error: Bad file: ./samba-4.20.0rc1rc1.tar.asc: No such file or directory
error: Bad file: ./samba-4.20.0rc1rc1.tar.xz: No such file or directory

RPM build errors:
    Bad file: ./samba-4.20.0rc1rc1.tar.asc: No such file or directory
    Bad file: ./samba-4.20.0rc1rc1.tar.xz: No such file or directory


Traceback:
  File "/usr/local/lib/python3.11/site-packages/hotness/use_cases/package_scratch_build_use_case.py", line 56, in build
    result = self.builder.build(request.package, request.opts)
             ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/local/lib/python3.11/site-packages/hotness/builders/koji.py", line 229, in build
    raise BuilderException(

If you think this issue is caused by some bug in the-new-hotness, please report it on the-new-hotness issue tracker: https://github.com/fedora-infra/the-new-hotness/issues

Comment 5 Upstream Release Monitoring 2024-01-31 21:11:48 UTC
Created attachment 2014258 [details]
Update to 4.20.0rc1 (#2260895)

Comment 6 Fedora Update System 2024-02-01 01:10:26 UTC
FEDORA-2024-e3626586f3 has been pushed to the Fedora 40 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.