Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2271924 - wireshark-4.2.4 is available
Summary: wireshark-4.2.4 is available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: wireshark
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Michal Ruprich
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2024-03-27 18:44 UTC by Upstream Release Monitoring
Modified: 2024-04-19 21:32 UTC (History)
6 users (show)

Fixed In Version: wireshark-4.0.14-1.fc39 wireshark-4.2.4-1.fc40
Doc Type: ---
Doc Text:
Clone Of:
Environment:
Last Closed: 2024-04-17 02:18:31 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
Update to 4.2.4 (#2271924) (deleted)
2024-03-27 18:44 UTC, Upstream Release Monitoring
no flags Details | Diff

Description Upstream Release Monitoring 2024-03-27 18:44:23 UTC
Releases retrieved: 3.6.22, 3.6.22, 4.0.14, 4.0.14, 4.2.4, 4.2.4
Upstream release that is considered latest: 4.2.4
Current version/release in rawhide: 4.2.2-3.fc41
URL: https://www.wireshark.org

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/5137/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/wireshark

Comment 1 Upstream Release Monitoring 2024-03-27 18:44:29 UTC
Scratch build failed. Details below:

BuilderException: Build failed:
Command '['rpmbuild', '-D', '_sourcedir .', '-D', '_topdir .', '-bs', '/var/tmp/thn-b1cwyezz/wireshark.spec']' returned non-zero exit status 1.

StdOut:
error: %changelog not in descending chronological order
setting SOURCE_DATE_EPOCH=1711497600
error: Bad file: ./SIGNATURES-4.2.4.txt: No such file or directory
error: Bad file: ./wireshark-4.2.4.tar.xz: No such file or directory

RPM build errors:
    %changelog not in descending chronological order
    Bad file: ./SIGNATURES-4.2.4.txt: No such file or directory
    Bad file: ./wireshark-4.2.4.tar.xz: No such file or directory


Traceback:
  File "/usr/local/lib/python3.11/site-packages/hotness/use_cases/package_scratch_build_use_case.py", line 56, in build
    result = self.builder.build(request.package, request.opts)
             ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/local/lib/python3.11/site-packages/hotness/builders/koji.py", line 229, in build
    raise BuilderException(

If you think this issue is caused by some bug in the-new-hotness, please report it on the-new-hotness issue tracker: https://github.com/fedora-infra/the-new-hotness/issues

Comment 2 Upstream Release Monitoring 2024-03-27 18:44:30 UTC
Created attachment 2023886 [details]
Update to 4.2.4 (#2271924)

Comment 3 Fedora Update System 2024-04-08 13:25:53 UTC
FEDORA-2024-f644a5709c (wireshark-4.0.14-1.fc39) has been submitted as an update to Fedora 39.
https://bodhi.fedoraproject.org/updates/FEDORA-2024-f644a5709c

Comment 4 Fedora Update System 2024-04-08 13:25:54 UTC
FEDORA-2024-b96e2c3cc2 (wireshark-4.2.4-1.fc40) has been submitted as an update to Fedora 40.
https://bodhi.fedoraproject.org/updates/FEDORA-2024-b96e2c3cc2

Comment 5 Fedora Update System 2024-04-09 01:07:50 UTC
FEDORA-2024-f644a5709c has been pushed to the Fedora 39 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2024-f644a5709c`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2024-f644a5709c

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 6 Fedora Update System 2024-04-09 01:12:34 UTC
FEDORA-2024-b96e2c3cc2 has been pushed to the Fedora 40 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2024-b96e2c3cc2`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2024-b96e2c3cc2

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 Fedora Update System 2024-04-17 02:18:31 UTC
FEDORA-2024-f644a5709c (wireshark-4.0.14-1.fc39) has been pushed to the Fedora 39 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 8 Fedora Update System 2024-04-19 21:32:12 UTC
FEDORA-2024-b96e2c3cc2 (wireshark-4.2.4-1.fc40) has been pushed to the Fedora 40 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.