Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2274069 - AMD-PMF driver fails to load on kernel- 6.8.4-300.fc40.x86_64. Resulting in GPU failing to use full gpu available watts.
Summary: AMD-PMF driver fails to load on kernel- 6.8.4-300.fc40.x86_64. Resulting in G...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 40
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: F40FinalFreezeException, FinalFreezeException Framework
TreeView+ depends on / blocked
 
Reported: 2024-04-09 00:16 UTC by knipp30
Modified: 2024-04-14 03:08 UTC (History)
22 users (show)

Fixed In Version: kernel-6.8.5-201.fc39 kernel-6.8.5-301.fc40 kernel-6.8.5-101.fc38
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2024-04-13 03:41:15 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
dmesg logs (deleted)
2024-04-09 00:18 UTC, knipp30
no flags Details

Description knipp30 2024-04-09 00:16:49 UTC
1. Please describe the problem:

Running Fedora 40 with kernel 6.8.4-300.fc40.x86_64
Using nvtop to measure GPU wattage, the GPU only uses about 50% of available wattage (ex. 100w GPU only pulls 50w).

2. What is the Version-Release number of the kernel:
kernel-core-6.8.4-300.fc40.x86_64

3. Did it work previously in Fedora? If so, what kernel version did the issue
   *first* appear?  Old kernels are available for download at
   https://koji.fedoraproject.org/koji/packageinfo?packageID=8 
:
First noticed on kernel-6.8.4-300.fc40.x86_64. However, I can also replicate the issue on kernel-6.8.4.200.fc39

Does not affect F39 kernel versions below kernel-6.8.4.200.fc39


4. Can you reproduce this issue? If so, please provide the steps to reproduce
   the issue below:
Step 1. Boot Fedora 40 into kernel-6.8.4-300.fc40.x86_64
Step 2. verify that amd-pmf driver did not load (I used journalctl to verify)
Step 3. Load a GPU intensive task (such as a video game)
Step 4. Using nvtop, or a similar program, note that the GPU is pulling ~50% of available wattage (on the other kernel, it pulls 95/100w).

Upon system boot, can also verify the kernel module with:
~~~
$ modinfo amd-pmf
modinfo: ERROR: Module amd-pmf not found.
~~~

The two kconfig options needed are
~~~
CONFIG_AMDTEE
CONFIG_AMD_PMF
~~~

5. Does this problem occur with the latest Rawhide kernel? To install the
   Rawhide kernel, run ``sudo dnf install fedora-repos-rawhide`` followed by
   ``sudo dnf update --enablerepo=rawhide kernel``:
Will confirm and update case.

6. Are you running any modules that not shipped with directly Fedora's kernel?:
No


   

Reproducible: Always

Comment 1 knipp30 2024-04-09 00:17:45 UTC
Update to section 5:
Booting into the Rawhide kernel resulted in a constant screen flicker and the laptop was unusable.

Comment 2 knipp30 2024-04-09 00:18:23 UTC
Created attachment 2025881 [details]
dmesg logs

Comment 3 Mario Limonciello 2024-04-09 00:46:34 UTC
This is a regression from Fedora 6.7 kernels.

Comment 4 knipp30 2024-04-09 00:56:24 UTC
On kernel-6.7.11-200, amd-pmf loads as expected:
~~~
$ modinfo amd-pmf
filename:       /lib/modules/6.7.11-200.fc39.x86_64/kernel/drivers/platform/x86/amd/pmf/amd-pmf.ko.xz
description:    AMD Platform Management Framework Driver
license:        GPL
rhelversion:    9.99
alias:          acpi*:AMDI0103:*
alias:          acpi*:AMDI0102:*
alias:          acpi*:AMDI0100:*
depends:        platform_profile
retpoline:      Y
intree:         Y
name:           amd_pmf
vermagic:       6.7.11-200.fc39.x86_64 SMP preempt mod_unload 
sig_id:         PKCS#7
signer:         Fedora kernel signing key
sig_key:        79:D4:29:87:9B:00:70:13:79:74:B5:9D:D8:DC:A5:34:C9:5F:5D:77
sig_hashalgo:   sha256
signature:      08:2B:E6:02:B0:E7:33:A2:AF:FE:37:E2:08:85:05:89:99:EC:38:99:
		59:E6:0D:FC:DB:60:D5:43:36:91:28:DE:4A:53:C9:2D:7F:9B:74:8C:
		26:91:27:AF:1B:67:1A:D9:18:5C:ED:24:1C:08:16:21:4A:D8:CF:2F:
		2D:F5:40:50:22:5D:B1:02:7E:02:E9:FB:86:30:97:F3:07:74:E3:AD:
		FC:EF:8D:2B:F0:04:EA:ED:39:94:83:E9:61:D4:7D:07:CF:5C:DF:E3:
		2D:FF:B9:DA:61:F1:07:DF:A2:24:4A:51:B9:B6:ED:6D:0F:17:15:66:
		E4:75:62:C6:38:46:54:25:38:B2:A4:1C:EE:73:AA:9E:5D:AE:FC:6D:
		78:A4:7A:4F:01:43:98:5E:D7:3D:D8:A7:99:86:48:F1:F1:92:BE:FF:
		7A:5C:B6:F2:87:BC:46:71:73:8D:FD:15:CB:F9:2C:A9:8B:9B:96:8B:
		4C:EB:1A:32:95:95:45:A9:C9:34:F4:9C:C8:9D:6C:EB:73:7A:F3:62:
		6A:1B:3D:BA:AB:E0:B1:3D:9F:92:97:89:C9:83:34:DB:43:3A:49:55:
		59:EB:27:B2:C0:D2:41:34:EB:9A:C6:AC:F8:17:8A:57:F4:07:3A:B8:
		A4:7F:81:37:EF:EF:F5:80:A0:DF:EB:AE:C6:62:46:6F:80:05:27:BE:
		41:8D:35:4A:FE:10:EF:13:91:F0:CB:66:32:19:61:67:64:F7:D6:E9:
		AB:EB:AB:C3:E6:65:F7:39:63:57:BC:40:D0:89:71:44:70:B7:DA:3D:
		7E:B8:E8:1A:58:38:C2:A8:B6:92:5B:8F:67:D2:3C:88:D8:A4:01:76:
		3F:02:BC:7F:17:B5:53:8D:A3:73:1C:2D:F2:49:5C:A2:8D:49:80:96:
		D8:D7:B6:CC:57:20:F6:35:46:8D:A8:A4:14:86:8B:FC:DE:95:83:91:
		01:21:C9:BA:C1:89:77:61:E3:48:5E:20:1A:BB:97:7C:8B:91:9F:C7:
		E8:39:74:16:BF:D9:7E:01:BE:5F:8F:68:5E:EA:16:E1:46:09:80:38:
		77:4A:E4:BD:4C:17:E5:94:B8:56:E7:5B:14:59:25:73:AA:4A:A9:D1:
		3B:E0:21:C3:D9:EF:18:4A:A1:A1:6F:99:98:FA:6D:43:0D:79:6F:69:
		C7:FA:5B:66:09:AB:A7:10:3E:A0:D4:77:7C:FA:A4:94:3F:77:E3:D1:
		15:17:D3:72:AD:C2:3E:83:5B:B2:47:0D:A5:6D:55:7B:89:C6:87:43:
		4D:82:DE:5E:AF:0F:FE:CD:BF:DB:7F:38:32:12:17:17:DD:2C:8E:68:
		EC:10:5D:BB:61:7E:17:10:FF:CD:2F:83
parm:           metrics_table_loop_ms:Metrics Table sample size time (default = 1000ms) (int)
parm:           force_load:Force load this driver on supported older platforms (experimental) (bool)
~~~

Comment 5 Arthur Bols 2024-04-09 09:57:03 UTC
I can confirm amd-pmf loads on the rawhide kernel.

I tested the following kernels:

  6.9.0-0.rc2.20240405git8cb4a9a82b21.27.fc41.x86_64 # OK
  6.8.4-200.fc39.x86_64                              # Not found
  6.7.9-200.fc39.x86_64                              # OK
  6.7.7-200.fc39.x86_64                              # OK

```
$ modinfo amd-pmf
filename:       /lib/modules/6.9.0-0.rc2.20240405git8cb4a9a82b21.27.fc41.x86_64/kernel/drivers/platform/x86/amd/pmf/amd-pmf.ko.xz
softdep:        pre: amdtee
description:    AMD Platform Management Framework Driver
license:        GPL
rhelversion:    9.99
alias:          acpi*:AMDI0103:*
alias:          acpi*:AMDI0102:*
alias:          acpi*:AMDI0100:*
depends:        tee,amd_sfh,platform_profile
retpoline:      Y
intree:         Y
name:           amd_pmf
vermagic:       6.9.0-0.rc2.20240405git8cb4a9a82b21.27.fc41.x86_64 SMP preempt mod_unload 
sig_id:         PKCS#7
signer:         Fedora kernel signing key
sig_key:        04:8A:02:54:AE:B2:9D:87:97:C0:71:58:F3:E1:9E:7D:A4:ED:EB:27
sig_hashalgo:   sha256
signature:      41:CF:25:78:22:CA:C4:38:E8:3B:D2:09:F6:74:ED:CD:B5:9F:23:33:
                02:67:0F:E7:B3:38:90:E7:2B:1E:53:71:83:1D:3E:4F:15:0E:5B:DB:
                C3:71:64:FF:0C:8B:B2:03:0E:6E:E3:CD:71:4C:88:37:F7:E7:D5:C3:
                C2:53:FD:35:D7:1F:2C:7B:80:0A:2D:BA:CD:A9:75:7B:CE:AE:C8:E2:
                7C:0C:37:60:CF:E1:5B:54:A1:B6:B7:EE:9F:36:EB:7E:8F:97:D9:B2:
                54:2F:96:DA:28:5F:19:23:AD:B5:5B:41:70:4E:BB:FE:C1:54:C4:2D:
                FD:61:63:BD:10:8E:D6:CB:EA:C5:CF:A2:0E:19:86:4F:7A:4D:7D:0D:
                75:04:CF:0B:97:ED:51:85:D8:35:26:A8:B6:B3:2F:93:15:F2:47:D5:
                CA:6E:BE:36:1B:B6:A7:F7:80:C0:09:C3:83:48:B5:56:84:C3:18:6D:
                55:60:20:4D:47:88:11:0E:32:CA:E2:72:C1:3C:11:17:3C:E2:4A:D9:
                03:38:4F:F1:F7:31:64:0E:2E:3E:DD:4D:7B:80:6B:0E:86:F8:CB:B1:
                F2:7C:AB:59:C9:37:E8:CD:C3:8E:3E:9F:AB:90:FB:6A:B7:84:38:4C:
                0D:61:6F:63:C6:88:47:0E:73:B0:0B:D7:C4:8B:E4:9B:84:98:D7:47:
                74:85:BC:AB:03:C5:91:D0:91:A7:76:46:C5:6E:43:74:8B:2B:05:F9:
                85:9B:D9:74:D6:D7:0C:38:38:84:0D:57:DF:EC:9D:21:E8:68:51:A9:
                54:88:DA:C4:BA:91:61:7B:BA:16:60:50:10:0B:89:1F:D5:1C:95:AB:
                56:7A:71:18:37:9C:20:AE:DA:8B:C0:53:0F:61:84:37:92:E9:ED:DD:
                A4:3E:6F:43:10:92:C6:73:A5:DB:9D:BF:8F:38:2B:34:4E:13:9E:BA:
                48:F3:2B:D0:D2:A3:52:63:4F:9C:B3:3B:F5:22:A1:C1:D0:7C:B9:3D:
                B0:EB:65:0F:4D:02:CE:35:35:C2:EF:DF:30:28:40:2A:34:2D:70:31:
                DE:AC:8C:C1:55:80:F0:4C:4A:F7:0C:58:35:AE:6B:C9:DE:57:DB:20:
                1D:57:C8:06:CD:E4:07:D4:EE:A1:A6:B9:D1:7E:00:40:26:A1:4B:2F:
                94:F9:7F:97:9E:68:06:9A:34:A4:88:8B:9F:55:28:BF:1A:35:4A:98:
                C2:76:00:D9:4F:BC:B8:2D:AB:20:52:03:CE:C2:78:D0:A7:3A:16:1B:
                23:E3:A7:EA:F8:16:12:B8:76:99:F7:CC:15:90:F6:8A:CC:41:C2:AE:
                FC:EB:B8:9F:A9:D3:90:29:B7:9B:CE:5F
parm:           metrics_table_loop_ms:Metrics Table sample size time (default = 1000ms) (int)
parm:           force_load:Force load this driver on supported older platforms (experimental) (bool)
```

Comment 6 Adam Williamson 2024-04-09 15:28:25 UTC
It looks like CONFIG_AMDTEE is set on rawhide branch but not on f40 branch.

Comment 7 Adam Williamson 2024-04-09 15:29:28 UTC
It was enabled in https://src.fedoraproject.org/rpms/kernel/c/e86fc419b651121dabfe9314baa68f8a11e6def4?branch=rawhide on Rawhide.

Comment 8 Mario Limonciello 2024-04-09 19:06:07 UTC
There's reports on both 40 and 39, so I think the same fix needs to port to all of them.

Comment 9 Justin M. Forbes 2024-04-09 20:47:55 UTC
Yes, 6.8 brought in a dep on AMDTEE with commit 7c45534afa4435c9fceeeb8ca33c0fdc269c2240, so suddenly things stopped building without telling us.  I have a fix queued for 6.8.5 for all versions of Fedora.

Comment 10 Adam Williamson 2024-04-09 21:17:52 UTC
Proposing as a Final FE - obviously we can fix this with an update after install, but I am a bit worried about people booting a fresh Workstation live, installing, and running into performance or other issues on AMD before they update.

Comment 11 jwp@redhat.com 2024-04-10 00:54:44 UTC
As an anecdote the rawhide kernel from 09/04/2024 breaks suspend and resume, but fixes the pmf bug originally referenced on phoenix (7xxx series) - namely fw13. I believe this is workqueue related changes.

Comment 12 Mario Limonciello 2024-04-10 14:41:38 UTC
This is the fix for suspend resume issues in 6.9:
https://lore.kernel.org/linux-pm/20240405083410.4896-1-anna-maria@linutronix.de/

Comment 13 Fedora Update System 2024-04-10 18:13:23 UTC
FEDORA-2024-6d35739db7 (kernel-6.8.5-300.fc40) has been submitted as an update to Fedora 40.
https://bodhi.fedoraproject.org/updates/FEDORA-2024-6d35739db7

Comment 14 Fedora Update System 2024-04-10 18:13:28 UTC
FEDORA-2024-33a9ea72d1 (kernel-6.8.5-200.fc39) has been submitted as an update to Fedora 39.
https://bodhi.fedoraproject.org/updates/FEDORA-2024-33a9ea72d1

Comment 15 Fedora Update System 2024-04-10 18:13:32 UTC
FEDORA-2024-a56a47ef1b (kernel-6.8.5-100.fc38) has been submitted as an update to Fedora 38.
https://bodhi.fedoraproject.org/updates/FEDORA-2024-a56a47ef1b

Comment 16 jwp@redhat.com 2024-04-10 23:05:54 UTC
Unfortunately suspend.c fixup is still not in current os-build tree ( commit 54b9831a523a12bb6a4d5293b8b8e721a93d5182  )

Has the patch been accepted upstream?

Comment 17 Adam Williamson 2024-04-10 23:52:04 UTC
None of the updates has gone stable yet, so it wouldn't be included in any stable composes. I don't know what "os-build tree" you're talking about exactly? That could mean a lot of things.

Comment 18 Fedora Update System 2024-04-11 00:56:10 UTC
FEDORA-2024-6d35739db7 has been pushed to the Fedora 40 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2024-6d35739db7`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2024-6d35739db7

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 19 Fedora Update System 2024-04-11 01:11:00 UTC
FEDORA-2024-a56a47ef1b has been pushed to the Fedora 38 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2024-a56a47ef1b`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2024-a56a47ef1b

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 20 Fedora Update System 2024-04-11 01:40:20 UTC
FEDORA-2024-33a9ea72d1 has been pushed to the Fedora 39 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2024-33a9ea72d1`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2024-33a9ea72d1

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 21 jwp@redhat.com 2024-04-11 02:05:36 UTC
kernel-ark os-build tag.

Comment 22 Adam Williamson 2024-04-11 19:18:44 UTC
+4 in https://pagure.io/fedora-qa/blocker-review/issue/1582 , marking accepted FE.

Comment 23 Fedora Update System 2024-04-12 02:04:36 UTC
FEDORA-2024-6d35739db7 has been pushed to the Fedora 40 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2024-6d35739db7`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2024-6d35739db7

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 24 Fedora Update System 2024-04-12 02:33:37 UTC
FEDORA-2024-33a9ea72d1 has been pushed to the Fedora 39 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2024-33a9ea72d1`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2024-33a9ea72d1

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 25 Fedora Update System 2024-04-12 02:41:31 UTC
FEDORA-2024-a56a47ef1b has been pushed to the Fedora 38 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2024-a56a47ef1b`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2024-a56a47ef1b

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 26 Fedora Update System 2024-04-13 01:14:06 UTC
FEDORA-2024-33a9ea72d1 (kernel-6.8.5-201.fc39) has been pushed to the Fedora 39 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 27 Fedora Update System 2024-04-13 03:41:15 UTC
FEDORA-2024-6d35739db7 (kernel-6.8.5-301.fc40) has been pushed to the Fedora 40 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 28 Fedora Update System 2024-04-14 03:08:23 UTC
FEDORA-2024-a56a47ef1b (kernel-6.8.5-101.fc38) has been pushed to the Fedora 38 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.