Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2276620 - perl-Curses fails to build on i686 architecture
Summary: perl-Curses fails to build on i686 architecture
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-Curses
Version: rawhide
Hardware: i686
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Steve Traylen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: FE-ExcludeArch-x86, F-ExcludeArch-x86 2261448
TreeView+ depends on / blocked
 
Reported: 2024-04-23 10:45 UTC by Steve Traylen
Modified: 2024-04-25 09:54 UTC (History)
3 users (show)

Fixed In Version: perl-Curses-1.44-7.fc41
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2024-04-25 09:54:23 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
Patch to fix compilation (deleted)
2024-04-24 11:41 UTC, Paul Howarth
no flags Details | Diff

Description Steve Traylen 2024-04-23 10:45:05 UTC
perl-Curses-1.44-5.fc41  fails to build in Rawhide but only on i686.

Error is:

CursesFunWide.c: In function ‘XS_CURSES_addstring’:
CursesFunWide.c:117:26: error: passing argument 2 of ‘waddnwstr’ from incompatible pointer type [-Wincompatible-pointer-types]
  117 |     ret = waddnwstr(win, wstr, len);
      |                          ^~~~
      |                          |
      |                          wint_t * {aka unsigned int *}
In file included from c-config.h:7,
                 from Curses.c:18:


https://koji.fedoraproject.org/koji/taskinfo?taskID=116767277

Reproducible: Always

Steps to Reproduce:
1. Build package on i686 in a scratch build
2.
3.
Actual Results:  
Does not compile

Expected Results:  
Should compile

Comment 1 Paul Howarth 2024-04-24 11:41:22 UTC
Created attachment 2028811 [details]
Patch to fix compilation

Attached patch fixes the compiler errors and a scratch build succeeded on all architectures but since the test suite isn't very extensive, it's hard to say if it's correct.

Comment 2 Fedora Update System 2024-04-25 09:51:47 UTC
FEDORA-2024-1e7e19e4d4 (perl-Curses-1.44-7.fc41) has been submitted as an update to Fedora 41.
https://bodhi.fedoraproject.org/updates/FEDORA-2024-1e7e19e4d4

Comment 3 Fedora Update System 2024-04-25 09:54:23 UTC
FEDORA-2024-1e7e19e4d4 (perl-Curses-1.44-7.fc41) has been pushed to the Fedora 41 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.