Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at
Bug 800235 - FTBFS: parted's test that worked last month now fails
Summary: FTBFS: parted's test that worked last month no...
Alias: None
Product: Fedora
Classification: Fedora
Component: parted
Version: 17
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: Brian Lane
QA Contact: Fedora Extras Quality Assurance
Depends On:
Blocks: ARMTracker
TreeView+ depends on / blocked
Reported: 2012-03-06 04:47 UTC by Brendan Conoboy
Modified: 2012-04-12 03:37 UTC (History)
1 user (show)

Fixed In Version: parted-3.0-9.fc17
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2012-04-12 03:37:10 UTC
Type: ---

Attachments (Terms of Use)

Description Brendan Conoboy 2012-03-06 04:47:45 UTC
Description of problem:

Something has happened in the last month that prevents parted-3.0-7.fc17.src.rpm from building successfully any longer.  It was initially noticed on ARM, but also FTBFS on x86_64.

From mock's build.log:

+ parted -s f mklabel pc98
Backtrace has 8 calls on stack:
  8: /builddir/build/BUILD/parted-3.0/libparted/.libs/ [0x7f949e8ea1de]
  7: /builddir/build/BUILD/parted-3.0/libparted/.libs/ [0x7f949e905d1a]
  6: /builddir/build/BUILD/parted-3.0/libparted/.libs/ [0x7f949e8ef748]
  5: /builddir/build/BUILD/parted-3.0/parted/.libs/lt-parted() [0x40811f]
  4: /builddir/build/BUILD/parted-3.0/parted/.libs/lt-parted(non_interactive_mode+0x8a) [0x40c25a]
  3: /builddir/build/BUILD/parted-3.0/parted/.libs/lt-parted(main+0xf25) [0x405cc5]
  2: /lib64/ [0x7f949e0db745]
  1: /builddir/build/BUILD/parted-3.0/parted/.libs/lt-parted() [0x405d89]
./ line 42: 10617 Aborted                 (core dumped) parted -s f mklabel $j
+ fail=1

Version-Release number of selected component (if applicable):

Happens on Fedora 17 buildroots on x86_64, armv5tel, and armv7hl.  Since the exact same test worked a month ago it is presumably some other component to blame.  Perhaps /usr move?  Reason is unclear.

Steps to Reproduce:
1. /usr/bin/mock -r fedora-17-x86_64 parted-3.0-7.fc17.src.rpm 
2. Observe the failure in build.log.

Comment 1 Brian Lane 2012-03-14 18:38:09 UTC
This is due to a change in mkswap, it no longer removes the bootloader part of the disk. This helps reveal another assert problem in the partition reading code, this time in mac.c -- we really shouldn't traceback on a bad partition table, especially when doing a mklabel.

reproduce it with:

PARTED_SECTOR_SIZE=1024 parted -s f mklabel mac
mkswap f
PARTED_SECTOR_SIZE=1024 parted -s f p

Comment 2 Fedora Update System 2012-03-14 19:16:44 UTC
parted-3.0-8.fc17 has been submitted as an update for Fedora 17.

Comment 3 Fedora Update System 2012-03-16 02:42:19 UTC
Package parted-3.0-8.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing parted-3.0-8.fc17'
as soon as you are able to.
Please go to the following url:
then log in and leave karma (feedback).

Comment 4 Brendan Conoboy 2012-03-16 02:49:28 UTC
I can confirm that parted-3.0.8.fc17 built successfully.  Assuming this is also in rawhide, we're all done.  Thanks!

Comment 5 Fedora Update System 2012-03-21 18:15:55 UTC
parted-3.0-9.fc17 has been submitted as an update for Fedora 17.

Comment 6 Fedora Update System 2012-04-12 03:37:10 UTC
parted-3.0-9.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.