Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at
Bug 874855 - xmonad does not follow ICCCM and ignores WM_TAKE_FOCUS protocol
Summary: xmonad does not follow ICCCM and ignores WM_TAKE_FOCUS protocol
Alias: None
Product: Fedora
Classification: Fedora
Component: xmonad
Version: 17
Hardware: Unspecified
OS: Unspecified
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: Fedora Extras Quality Assurance
Depends On:
TreeView+ depends on / blocked
Reported: 2012-11-08 23:08 UTC by Jon VanAlten
Modified: 2015-07-13 04:43 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2012-12-10 07:11:28 UTC
Type: Bug

Attachments (Terms of Use)

Description Jon VanAlten 2012-11-08 23:08:54 UTC
Description of problem:
I experience symptoms of this problem primarily when using java programs (but not all java programs).  Where there is a GUI component that should allow text entry, it is not possible to place the cursor in that component and allow typed text to appear there.

Version-Release number of selected component (if applicable):
Currently seeing this in 0.10-11 but has been observed since I started using xmonad some months ago.

How reproducible:

One known example of java app affected by this bug is thermostat.
# yum install thermostat
$ thermostat service --start
(this^ will block terminal)
$ thermostat gui

In left-most panel of gui, near upper edge, is a search box.  Try as I might, I cannot place the cursor in this search box.  Works when using other WM.

Additional info:

This is a long-standing bug in upstream.

comment 33 at above link has patch that allegedly fixed things, which is supposed to be upstream for some time now, but others find that they still have this issue (and myself apparently).  comment 107 may have useful info for how to build/install xmonad in rpm package such that java7 users (ie all of f17 users) are also not affected anymore.  I haven't tested it, not really interested in installing wm separate from fedora repos, but I would be happy to test any rpm builds that may sometime be available!

Comment 1 Solitary 2012-11-12 00:04:19 UTC
Same problem as mine although I use Bluetile, which utilizes Xmonad anyway. I would be really happy if someone tried to apply the patch and made a package, Xmonad does seem to take it bit slow, so waiting for upstream could take long. At least some test package would be great, if patching it official would be a problem. The whole Haskell patching and compiling thing is unfortunatelly over my head, otherwise I would try it myself.

Comment 2 Jens Petersen 2012-11-13 14:10:36 UTC
Thanks for the reports - will try to get back to you soon.

Comment 3 Ricky Zhou 2012-11-15 07:28:29 UTC
I ran into this issue as well, and extracted the relevant patches out of the xmonad and XMonadContrib darcs repos (which have just recently incorporated the patches from the bug).

Here are the patches (track-currently-processing-event.patch is for xmonad, icccmfocus.patch is for XMonadContrib), as well as some quickly modified spec files:

Comment 4 Jens Petersen 2012-11-17 03:37:49 UTC
*** Bug 837388 has been marked as a duplicate of this bug. ***

Comment 5 Jens Petersen 2012-11-17 03:59:36 UTC
Thanks guys.

I committed track-currently-processing-event.patch to xmonad master:

Comment 6 Jens Petersen 2012-11-17 04:10:01 UTC
Scratch builds



Please test :)

Will update xmonad-contrib and bluetile soon.

Comment 7 Jens Petersen 2012-11-17 04:44:30 UTC
I committed icccmfocus.patch to fedora xmonad-contrib:master.

Comment 8 Jens Petersen 2012-11-17 05:03:19 UTC
Here is an untested srpm which should build against the above patched xmonad:

Comment 9 Jens Petersen 2012-11-17 05:32:47 UTC
Ok, xmonad and ghc-xmonad-contrib also built for F19 Rawhide: (xmonad) (xmonad-contrib)

These builds should work also on F18 (since rawhide is still on ghc-7.4.1)
but not for F17 or earlier.

Comment 10 Fedora Update System 2012-11-30 04:14:55 UTC
xmonad-0.10-15.fc18,ghc-xmonad-contrib-0.10-7.fc18,bluetile-0.6-10.fc18 has been submitted as an update for Fedora 18.,ghc-xmonad-contrib-0.10-7.fc18,bluetile-0.6-10.fc18

Comment 11 Fedora Update System 2012-11-30 07:57:35 UTC
xmonad-0.10-15.fc17,ghc-xmonad-contrib-0.10-7.fc17,bluetile-0.6-10.fc17 has been submitted as an update for Fedora 17.,ghc-xmonad-contrib-0.10-7.fc17,bluetile-0.6-10.fc17

Comment 12 Jens Petersen 2012-11-30 08:00:11 UTC
If people could test either of these that would be most helpful.

Once we are sure they are good - it can also be backported to f16
if there is demand I guess.

Comment 13 Solitary 2012-11-30 15:12:35 UTC
Just updated my bluetile, ghc-xmonad and ghc-xmonad-contrib and did quick test and Netbeans IDE with OpenJDK 1.7 works as supposed to, earlier mentioned test case too. Awesome! :)

Comment 14 Jon VanAlten 2012-11-30 16:05:28 UTC
I've updated *xmonad* packages from the update (not bluetile, I don't use it) and all is well.  Added karma.  Thanks a lot for getting this out, Jens!

Comment 15 Fedora Update System 2012-11-30 20:29:26 UTC
Package xmonad-0.10-15.fc18, ghc-xmonad-contrib-0.10-7.fc18, bluetile-0.6-10.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xmonad-0.10-15.fc18 ghc-xmonad-contrib-0.10-7.fc18 bluetile-0.6-10.fc18'
as soon as you are able to.
Please go to the following url:,ghc-xmonad-contrib-0.10-7.fc18,bluetile-0.6-10.fc18
then log in and leave karma (feedback).

Comment 16 Jens Petersen 2012-12-07 02:47:20 UTC
Looks good to me on F18 and F17.

So I will also backport to F16 and EPEL6

Comment 17 Fedora Update System 2012-12-07 05:23:51 UTC
xmonad-0.10-3.8.fc16 has been submitted as an update for Fedora 16.

Comment 19 Fedora Update System 2012-12-10 07:11:31 UTC
xmonad-0.10-15.fc18, ghc-xmonad-contrib-0.10-7.fc18, bluetile-0.6-10.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 20 Fedora Update System 2012-12-11 01:31:37 UTC
xmonad-0.10-15.fc17, ghc-xmonad-contrib-0.10-7.fc17, bluetile-0.6-10.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 21 Fedora Update System 2013-01-20 03:09:33 UTC
xmonad-0.10-3.8.fc16, ghc-xmonad-contrib-0.10-7.fc16, bluetile-0.6-10.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 22 Fedora Update System 2013-01-22 10:14:17 UTC
xmonad-0.10-3.4.2.el6,ghc-xmonad-contrib-0.10-7.el6 has been submitted as an update for Fedora EPEL 6.,ghc-xmonad-contrib-0.10-7.el6

Comment 23 Fedora Update System 2013-02-15 18:38:07 UTC
xmonad-0.10-3.4.2.el6, ghc-xmonad-contrib-0.10-7.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.