Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Bug 894063 - [RFE] IPA install does not bind services to an particular IP/interface
Summary: [RFE] IPA install does not bind services to an particular IP/interface
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Martin Kosek
QA Contact: Namita Soman
URL:
Whiteboard:
: 894388 (view as bug list)
Depends On:
Blocks: 894388
TreeView+ depends on / blocked
 
Reported: 2013-01-10 16:03 UTC by Steeve Goveas
Modified: 2015-01-21 15:06 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
: 894388 (view as bug list)
Environment:
Last Closed: 2015-01-21 15:06:22 UTC
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)

Description Steeve Goveas 2013-01-10 16:03:22 UTC
Description of problem:
In a multi interfaces machine, IPA and dns services listens on all interfaces by default. It is not bound to a particular IP or an interface that was chosen with --ip-address or --hostname

Version-Release number of selected component (if applicable):
ipa-server-3.0.0-19.el6.x86_64

How reproducible:
Always


Steps to Reproduce:
1. Install IPA with dns on a multi interface machine
2. Run
# netstat -ntulp
3.
  
Actual results:
IPA and DNS services are listening on all interfaces


Expected results:
IPA and DNS services should only listen on a chosen interface


Additional info:

Comment 2 Rob Crittenden 2013-01-10 20:16:11 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/3338

Comment 3 Martin Kosek 2013-03-01 14:50:09 UTC
*** Bug 894388 has been marked as a duplicate of this bug. ***

Comment 4 Martin Kosek 2015-01-21 15:06:22 UTC
Thank you taking your time and submitting this request for Red Hat Enterprise Linux. Unfortunately, this bug was not given a priority and was deferred both in the upstream project and in Red Hat Enterprise Linux.

Given that we are unable to fulfill this request in following Red Hat Enterprise Linux releases, I am closing the Bugzilla as DEFERRED. To request that Red Hat re-considers the decision, please re-open the Bugzilla via appropriate support channels and provide additional business and/or technical details about its importance to you.

Note that you can still track this request or even contribute patches in the referred upstream Trac ticket.


Note You need to log in before you can comment on or make changes to this bug.