Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 913319 - Regression: Variable "not definable inside loop" error while building cp2k
Summary: Regression: Variable "not definable inside loop" error while building cp2k
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc
Version: rawhide
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 913927 914617
TreeView+ depends on / blocked
 
Reported: 2013-02-21 00:02 UTC by Dominik 'Rathann' Mierzejewski
Modified: 2013-02-22 16:39 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-22 15:54:00 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
GNU Compiler Collection 55593 0 None None None Never

Description Dominik 'Rathann' Mierzejewski 2013-02-21 00:02:18 UTC
Description of problem:
Latest cp2k build fails with this error:
Error: Variable 'row' at (1) not definable inside loop beginning at (2) as INTENT(INOUT) argument to subroutine 'dbcsr_get_stored_coordinates'

Version-Release number of selected component (if applicable):
gcc-gfortran-4.8.0-0.13.fc19

How reproducible:
Always

Steps to Reproduce:
1. try building cp2k-2.4-0.1.20130220.fc19 from git master
2. build fails
  
Actual results:
mpif90 -c -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4  -m64 -mtune=generic -L/usr/lib64/atlas -ffree-form -ffree-line-length-none -D__GFORTRAN -D__FFTSG -D__FFTW3 -D__parallel -D__BLACS -D__SCALAPACK -D__LIBINT -D__LIBINT_MAX_AM=8 -D__LIBDERIV_MAX_AM1=6 -D__LIBXC -D__COMPILE_ARCH="\"Linux-gfortran-openmpi\"" -D__COMPILE_DATE="\"Wed Feb 20 23:46:27 UTC 2013\"" -D__COMPILE_HOST="\"buildvm-04.phx2.fedoraproject.org\"" -D__COMPILE_REVISION="\"12494\"" -D__SHORT_FILE__="\"dbcsr_example_2.F\"" /builddir/build/BUILD/cp2k-2.4/makefiles/../src/dbcsr_lib/dbcsr_example_2.F
/builddir/build/BUILD/cp2k-2.4/makefiles/../src/dbcsr_lib/dbcsr_example_2.F:151.53:
        CALL dbcsr_get_stored_coordinates (matrix_a, row, col, tr, node_holds_b
                                                     1
/builddir/build/BUILD/cp2k-2.4/makefiles/../src/dbcsr_lib/dbcsr_example_2.F:146.45:
  DO row = 1, dbcsr_nblkrows_total (matrix_a)
                                             2
Error: Variable 'row' at (1) not definable inside loop beginning at (2) as INTENT(INOUT) argument to subroutine 'dbcsr_get_stored_coordinates'
/builddir/build/BUILD/cp2k-2.4/makefiles/../src/dbcsr_lib/dbcsr_example_2.F:151.58:
        CALL dbcsr_get_stored_coordinates (matrix_a, row, col, tr, node_holds_b
                                                          1
/builddir/build/BUILD/cp2k-2.4/makefiles/../src/dbcsr_lib/dbcsr_example_2.F:147.69:
     DO col = MAX(row-1,1),MIN(row+1,dbcsr_nblkcols_total (matrix_a))
                                                                     2
Error: Variable 'col' at (1) not definable inside loop beginning at (2) as INTENT(INOUT) argument to subroutine 'dbcsr_get_stored_coordinates'
make[1]: *** [dbcsr_example_2.o] Error 1

Expected results:
Successful build.

Additional info:
cp2k builds fine with F18's gcc-gfortran-4.7.2-8.fc18.

It looks like it's fixed upstream already: http://gcc.gnu.org/bugzilla/show_bug.cgi?id=55593

Comment 1 Jakub Jelinek 2013-02-22 15:54:00 UTC
No, this is a cp2k bug.  The error is correct.

Comment 2 Jakub Jelinek 2013-02-22 16:39:15 UTC
To expand of this, if you read my analysis of the F19 mass rebuild failures, cp2k has been listed there:
https://lists.fedoraproject.org/pipermail/devel/2013-January/175876.html


Note You need to log in before you can comment on or make changes to this bug.