Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 914544 - thermostat: FTBFS in rawhide
Summary: thermostat: FTBFS in rawhide
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: thermostat
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jon VanAlten
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 911559
Blocks: F19FTBFS
TreeView+ depends on / blocked
 
Reported: 2013-02-22 10:29 UTC by Dennis Gilmore
Modified: 2015-07-13 04:43 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-03-12 08:51:06 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Dennis Gilmore 2013-02-22 10:29:08 UTC
Your package thermostat failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=4982025

Build logs:
root.log: http://kojipkgs.fedoraproject.org/work/tasks/2025/4982025/root.log
build.log: http://kojipkgs.fedoraproject.org/work/tasks/2025/4982025/build.log
state.log: http://kojipkgs.fedoraproject.org/work/tasks/2025/4982025/state.log
NOTE: build logs are cleaned up after 1 week

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild

Comment 1 Jon VanAlten 2013-02-28 07:42:48 UTC
This appears to be caused by issue(s) in jline2, I've set relevant bug to depends.  There are a number of other warnings in the build, but they happen to be quite harmless (although I've submitted patches upstream for most of them at [1][2]).

[1] http://icedtea.classpath.org/pipermail/thermostat/2013-February/005928.html
[2] http://icedtea.classpath.org/pipermail/thermostat/2013-February/005929.html

Comment 2 Severin Gehwolf 2013-03-12 08:51:06 UTC
Built in rawhide:
http://koji.fedoraproject.org/koji/taskinfo?taskID=5108370


Note You need to log in before you can comment on or make changes to this bug.