Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 949617 - [RFE] Client tools should pass up CPU Socket information
Summary: [RFE] Client tools should pass up CPU Socket information
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rhn-client-tools
Version: 5.10
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Stephen Herr
QA Contact: Martin Korbel
URL:
Whiteboard:
: 949619 (view as bug list)
Depends On: 596917 948326 948335 949619 949620 949622 949623 949637 949638 949639 949640 993073
Blocks: sat560-splice 948337 949615 990664
TreeView+ depends on / blocked
 
Reported: 2013-04-08 15:48 UTC by Stephen Herr
Modified: 2019-07-11 07:40 UTC (History)
20 users (show)

Fixed In Version: rhn-client-tools-0.4.20.1-5
Doc Type: Enhancement
Doc Text:
* While Satellite 5.3.0 now has the ability to get the number of CPUs via an API call, there was no function to obtain the number of sockets from the registered systems. This update adds a function to get the number of physical CPU sockets in a managed system from Satellite via an API call.
Clone Of: 948326
Environment:
Last Closed: 2013-09-30 22:27:50 UTC
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1328 0 normal SHIPPED_LIVE rhn-client-tools bug fix and enhancement update 2013-09-30 22:49:30 UTC

Description Stephen Herr 2013-04-08 15:48:53 UTC
+++ This bug was initially created as a clone of Bug #948326 +++

+++ This bug was initially created as a clone of Bug #596917 +++

Bug 596917 describes the desire to have CPU Socket information available from Satellite. This requires two different logical steps.

1) The RHEL client tools must be updated to pass socket information to Satellite
2) Satellite must be updated to store / display socket information

This bug will track the development and release of #1, the client tools portion. Bug 596917 will track the development and release of #2, the Satellite portion. Both will be necessary for this functionality to work.

Comment 1 Stephen Herr 2013-04-29 12:51:04 UTC
*** Bug 949619 has been marked as a duplicate of this bug. ***

Comment 5 Martin Korbel 2013-06-13 11:44:18 UTC
VERIFIED on Satellite-5.6.0-RHEL6-re20130607.1
Satellite:
 - spacewalk-java-1.9.83-42.el6sat
 - spacewalk-schema-1.9.38-17.el6sat
 - spacewalk-backend-1.9.46-18.el6sat

Client:
 - rhn-setup-0.4.20.1-3.el5 or older (empty field)
 - rhn-setup-0.4.20.1-4.el5 or newer (it shows correct number of socket)

Comment 7 errata-xmlrpc 2013-09-30 22:27:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1328.html


Note You need to log in before you can comment on or make changes to this bug.