Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at
Bug 969524 - qml-based systray plasma widgets unclickable on arm
Summary: qml-based systray plasma widgets unclickable on arm
Alias: None
Product: Fedora
Classification: Fedora
Component: kdelibs
Version: 20
Hardware: arm
OS: Unspecified
Target Milestone: ---
Assignee: Than Ngo
QA Contact: Fedora Extras Quality Assurance
Whiteboard: AcceptedBlocker
: 928049 (view as bug list)
Depends On:
Blocks: ARMTracker F20FinalBlocker
TreeView+ depends on / blocked
Reported: 2013-05-31 17:06 UTC by Dennis Gilmore
Modified: 2014-07-10 19:12 UTC (History)
15 users (show)

Fixed In Version: kdelibs-4.11.3-9.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2013-12-10 06:57:49 UTC
Type: Bug

Attachments (Terms of Use)

System ID Private Priority Status Summary Last Updated
KDE Software Compilation 282975 0 None None None Never
KDE Software Compilation 312578 0 None None None Never

Description Dennis Gilmore 2013-05-31 17:06:06 UTC
Description of problem:
running fedora 19 on arm i am unable to click on any plasma widgets, normal kde widgets are fine, most noticeable when getting notifications of package updates, you cant click on install, unable to remove notifications of people coming online in kopete

Version-Release number of selected component (if applicable):
i saw this with both qt-4.8.4-17.fc19 and qt-4.8.4-18.fc19

How reproducible:

Steps to Reproduce:

Actual results:

Expected results:

Additional info:

Comment 1 Rex Dieter 2013-10-09 16:30:09 UTC
Is this still valid? Especially on f20?  If so, should probably consider it a blocker, and dedicate some more resources/manpower into it.

Comment 2 Rex Dieter 2013-11-21 17:56:24 UTC
Confirmed on irc for f20. :(

Comment 3 Paul Whalen 2013-11-21 18:05:35 UTC
Proposed Blocker for F20 - Default panel functionality

"All elements of the default panel (or equivalent) configuration in all release-blocking desktops must function correctly in typical use. "

Comment 4 Rex Dieter 2013-11-21 19:05:14 UTC
Possible upstream match for this,

Comment 5 Rex Dieter 2013-11-21 19:10:16 UTC
ah, and this older one,

Comment 6 Than Ngo 2013-11-25 12:56:19 UTC
it seems a bug in plasma, but not in qt. reassign to correct component

Comment 7 Jan Grulich 2013-11-26 08:36:33 UTC
It doesn't work probably only for applets in panel and written in QML (device notifier, NM applet etc.). I tried to put device notifier to desktop and here it works correctly. Tested on my Nexus 7 with Plasma active (KDE 4.10.x).

Comment 8 Adam Williamson 2013-11-27 17:19:18 UTC
Discussed at 2013-11-27 blocker review meeting: . Accepted as a blocker per criterion cited in c#3 (or several others, really - makes KDE basically unusable on ARM).

Comment 9 Rex Dieter 2013-11-27 17:46:21 UTC
updating summary, per irc debugging yesterday determined this only seems to affect qml-based plasma widgets embedded in the systray

Comment 10 Than Ngo 2013-11-29 16:24:30 UTC
i have build qt/kdelibs/kde-workspace with -O0, jcapik tested qt build and still see the issue. He or pwhalen will test kdelibs/kde-workspace build today. I will post results here when the test is done.

Comment 11 Jaromír Cápík 2013-11-29 18:15:29 UTC
kdelibs/kde-workspace tested -> didn't help

Comment 12 Jaroslav Reznik 2013-12-02 09:53:36 UTC
As a workaround - could we put important Plasma widgets out of the panel to the desktop - for ARM images only? It's less than nice but could unblock us in case we would not be able to find the root for this issues as it seems upstream is fighting it too for some time.

Comment 13 Than Ngo 2013-12-02 11:26:02 UTC
since we don't know the root for this issue and i don't think we have time to resolve this issue till 2013-12-10 for f20 release.

I full agree with jaroslav's suggestion that we should make such workaround.

Comment 14 Jaroslav Reznik 2013-12-02 12:25:45 UTC
(In reply to Ngo Than from comment #13)
> since we don't know the root for this issue and i don't think we have time
> to resolve this issue till 2013-12-10 for f20 release.
> I full agree with jaroslav's suggestion that we should make such workaround.

We discussed it with Kevin on #fedora-kde - he suggested possible solution, if you could try it, it would be great. On the other hand, I still believe we can find a proper solution for this one.

Comment 15 Rex Dieter 2013-12-02 12:50:16 UTC
1.  Do we have confirmation that putting these applets outside of the systray works?  If so, what's an exhaustive list of applets that require moving?  So far, I think this includes:
* network management
* battery monitor

any others?

2.  Currently, kde-settings is a noarch package shared among all archs, we'd likely have to re-engineer the packaging to put in arch-specific changes (unless plasma scripting can somehow handle that part for us).   Any other implementation suggestions?

Comment 16 Rex Dieter 2013-12-02 13:01:51 UTC
Per original submission, add to the existing list of affected applets:
* notifications

Comment 17 Jan Grulich 2013-12-02 13:04:12 UTC
I can confirm that they work on desktop (at least on Nexus 7 with Plasma Active). The list of applets should include also device notifier applet.

Comment 18 Jaroslav Reznik 2013-12-02 13:13:15 UTC
(In reply to Rex Dieter from comment #15)
For 1 - as far as I know, we have and see comment #17

For 2 - from Kevin from this morning: "Tweaking the Plasma configuration for ARM only isn't so straightforward, but I guess %ifarch in kde-settings, dropping a Plasma init script there, could work…"

Comment 19 Jan Grulich 2013-12-02 13:37:58 UTC
I'm not sure whether it will work for networkmanagement applet and battery monitor, because when you put them on desktop, they are still collapsed to the icon (only device notifier is not and I was able to try only this one on my Nexus 7). So it's still basically popup applet.

Comment 20 Jan Grulich 2013-12-02 15:21:29 UTC
Bad news!! I've just tried to put battery monitor to desktop (on ARM machine with F20) and there is the same regression so putting all widgets to desktop as a workaround won't help. It looks like there is a bug somewhere in Plasma popup applet.

Comment 21 Jan Grulich 2013-12-02 15:29:28 UTC
It looks like upstream has a fix for that, see:

Comment 22 Rex Dieter 2013-12-02 16:11:40 UTC
trying out hackish workaround used on mer,

Comment 23 Than Ngo 2013-12-02 16:38:21 UTC
the kdelibs with the upstream workaround is in the build.

Comment 24 Fedora Update System 2013-12-03 02:16:26 UTC
kdelibs-4.11.3-3.fc20 has been submitted as an update for Fedora 20.

Comment 25 Jan Grulich 2013-12-03 13:23:39 UTC
Confirming that the new build works, I've just tested it on jcapik's Pandora ARM machine.

Comment 26 Fedora Update System 2013-12-03 18:23:00 UTC
Package kdelibs-4.11.3-3.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kdelibs-4.11.3-3.fc20'
as soon as you are able to.
Please go to the following url:
then log in and leave karma (feedback).

Comment 27 Paul Whalen 2013-12-03 18:46:09 UTC
Confirmed working in F20-TC4 on the Trimslice.

Comment 28 Fedora Update System 2013-12-09 21:44:23 UTC
kdelibs-4.11.3-9.fc19 has been submitted as an update for Fedora 19.

Comment 29 Fedora Update System 2013-12-10 06:57:49 UTC
kdelibs-4.11.3-9.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 30 Fedora Update System 2013-12-12 02:52:41 UTC
kdelibs-4.11.3-9.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 31 Jan Grulich 2013-12-13 14:44:10 UTC
*** Bug 928049 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.