Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1021558 - Spacewalk fails to generate DEB repository error on "setBuildTime"
Summary: Spacewalk fails to generate DEB repository error on "setBuildTime"
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Spacewalk
Classification: Community
Component: Server
Version: 2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Michael Mráka
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: space22
TreeView+ depends on / blocked
 
Reported: 2013-10-21 14:00 UTC by Martin Juhl
Modified: 2014-07-17 08:40 UTC (History)
2 users (show)

Fixed In Version: spacewalk-java-2.2.12-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-17 08:40:45 UTC
Embargoed:


Attachments (Terms of Use)
rhn_taskomatic_daemon.log (deleted)
2013-10-21 14:00 UTC, Martin Juhl
no flags Details
Solves problem, but maybe not the right way?? (deleted)
2013-12-02 14:31 UTC, Martin Juhl
no flags Details | Diff

Description Martin Juhl 2013-10-21 14:00:11 UTC
Created attachment 814615 [details]
rhn_taskomatic_daemon.log

Description of problem:

After pushing a debian package:
http://nl.archive.ubuntu.com/ubuntu/pool/universe/j/joe/joe_3.7-2.3_amd64.deb

Spacewalk fails to generate repository metadata and fails with error: 

com.redhat.rhn.frontend.dto.PackageDto.setBuildTime(PackageDto.java:279)

I have tried with several different packages, all with the same result..

I have seen this working in the previous version (1.9)...

How reproducible:
Everytime

Steps to Reproduce:
1. Create channel, debian based (IA32 Debian or AMD64 Debian)
2. Push package to created channel..

Actual results:
Error appears in /var/log/rhn/rhn_taskomatic_daemon.log

Expected results:
Channel Metadate should be created...

Additional info:
/var/log/rhn/rhn_taskomatic_daemon.log is attached...

Comment 1 Martin Juhl 2013-12-02 14:31:19 UTC
Created attachment 831605 [details]
Solves problem, but maybe not the right way??

I have discovered that the reason for the failure is that the setBuildTime() function is called with an argument "buildTimeIn=NULL".. 

The attached patch handles this exception, even though I'm not sure that's the right way to fix the problem..

Comment 2 Martin Juhl 2014-01-27 12:31:35 UTC
Any comments on this patch???

Is it something we can get implemented???

Comment 3 Dirk Götz 2014-02-21 15:12:04 UTC
I am running in the same problem. 

I have created a rhn.jar with the patch applied and it works, but there is no date for last repo build and no information on repo cache status shown.

Perhaps this is the result from building the jar by unpacking, compiling the class file and repacking. But I have not got a good setup working.

Comment 4 Michael Mráka 2014-03-07 13:05:48 UTC
Fixed in spacewalk master by
commit 47e451d0c39986766b63e29e56236df27aeb4b41
    1021558 - if buildTime is null don't parse it

Comment 5 Milan Zázrivec 2014-07-17 08:40:45 UTC
Spacewalk 2.2 has been released:

    https://fedorahosted.org/spacewalk/wiki/ReleaseNotes22


Note You need to log in before you can comment on or make changes to this bug.