Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1073543 - [RFE] Make spacewalk-clone-by-date able to specify channel name, summary, and description
Summary: [RFE] Make spacewalk-clone-by-date able to specify channel name, summary, and...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Spacewalk
Classification: Community
Component: Server
Version: 2.2
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
Assignee: Stephen Herr
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
: 1082055 (view as bug list)
Depends On: 830609
Blocks: spacewalk-rfe space22
TreeView+ depends on / blocked
 
Reported: 2014-03-06 16:32 UTC by Stephen Herr
Modified: 2014-07-17 08:40 UTC (History)
7 users (show)

Fixed In Version: spacewalk-utils-2.2.12-1
Doc Type: Enhancement
Doc Text:
Clone Of: 830609
Environment:
Last Closed: 2014-07-17 08:40:53 UTC
Embargoed:


Attachments (Terms of Use)

Description Stephen Herr 2014-03-06 16:32:15 UTC
+++ This bug was initially created as a clone of Bug #830609 +++

Description of problem:
When I used spacewalk-create-channel, I was able to assign a human-readable name to cloned channels using e.g., --name "My cloned channel name"

I'd like to be able to do something like that with spacewalk-clone-by-date. Right now, you can only clone to a label, and that label becomes the channel name. It would be cool if we could add a third field to the -l argument, something like:

-l source_channel_label destination_channel_label "Friendly Name"

Version-Release number of selected component (if applicable):
It's not there in spacewalk-utils-1.2.1-16.el6sat.noarch

How reproducible:
See above

Steps to Reproduce:
See above
  
Actual results:
limited channel name options

Expected results:
Human readable channel names

Additional info:

Comment 1 Stephen Herr 2014-03-06 21:32:30 UTC
Committing to Spacewalk master:
d35de0612086f12a40af0551dce4850e14fad3f8

Comment 2 Stephen Herr 2014-03-21 19:00:50 UTC
Also adding the ability to specify description:
ce76fa02001bb185e3a1878bb5717e5ba7014cba

Comment 3 Stephen Herr 2014-04-03 18:27:33 UTC
One more commit required.

dyordano found a problem where if you were using an '=' in the new channels argument it would throw an error due to a bug in optparse:

spacewalk-clone-by-date --channel=test_ch  clone-test_ch   --username ${RHN_USER} --password ${RHN_PASS}
Usage: spacewalk-clone-by-date [options]
     
spacewalk-clone-by-date: error: --channels option does not take a value

Optparse is apparently not smart enough to handle explicit value setting for callback options. This commit works around the problem by transforming '--channel=test_ch' into '--channel test_ch'.

5b8eb30d77b7e8a61e031556da24bec8a833e718

Comment 4 Dimitar Yordanov 2014-04-08 12:10:02 UTC
*** Bug 1082055 has been marked as a duplicate of this bug. ***

Comment 5 Stephen Herr 2014-04-14 12:35:38 UTC
Another commit to make --validate work properly with changes:
f1bb1481ab1412795ceb98d7764f7523b581a475

Comment 6 Stephen Herr 2014-04-14 12:59:33 UTC
Checkstyle fix:
7bac66955ce2b03115327c8df3f5268d57c75d20

Comment 7 Milan Zázrivec 2014-07-17 08:40:53 UTC
Spacewalk 2.2 has been released:

    https://fedorahosted.org/spacewalk/wiki/ReleaseNotes22


Note You need to log in before you can comment on or make changes to this bug.