Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at
Bug 1093991 - Beginning with 3.14.2-200.fc20.x86_64 screen brightness dim
Summary: Beginning with 3.14.2-200.fc20.x86_64 screen brightness dim
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 20
Hardware: x86_64
OS: Linux
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
Depends On:
TreeView+ depends on / blocked
Reported: 2014-05-04 07:02 UTC by Patrick
Modified: 2015-01-09 13:25 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2014-06-16 12:51:26 UTC
Type: Bug

Attachments (Terms of Use)

Description Patrick 2014-05-04 07:02:14 UTC
Description of problem:
After update to kernel 3.14.2-200.fc20.x86_64 the brightness of the screen is very dim.  Using hardware keys to adjust covers the range from 0 to 100 with a perceptible but minimal change.  When booting using grub to instead choose the last kernel, 3.13.10-200.fc20.x86_64 restores the normal functionality

Version-Release number of selected component (if applicable):

How reproducible:
Turn the computer on.

Steps to Reproduce:
1. Install kernel 3.14.2-200.fc20.x86_64
2. Turn machine on

Actual results:
Dim screen

Expected results:
Bright screen

Additional info:
Machine is Dell inspiron 1420 using intel graphics

Comment 1 Paul DeStefano 2014-05-05 18:05:10 UTC
can you adjust the brightness using fn-keys?  After installing 3.14.2-200 my brightness control is completely broken.  I also have intel integrated graphics card.

Comment 2 Patrick 2014-05-07 05:43:40 UTC
(In reply to Paul DeStefano from comment #1)
> can you adjust the brightness using fn-keys?  After installing 3.14.2-200 my
> brightness control is completely broken.  I also have intel integrated
> graphics card.

With function key or xbacklight, I'm told things are changing and checking the numbers it thinks it changed, i.e. after xbacklight -set 100, xbacklight -get reports 100.  It's just that the  brightness either doesn't change from dim, or perhaps a barely perceptible change.  In either case the machine isn't usable at all with this kernel.

Comment 3 Paul DeStefano 2014-05-07 21:04:52 UTC
Okay, that sounds close to my situation.  Although, there no perceptable change in brightness regardless of the xbacklight/fn-key adjustments.  No change at all.

I have the Atom integrated video.

00:02.0 VGA compatible controller: Intel Corporation Atom Processor D4xx/D5xx/N4xx/N5xx Integrated Graphics Controller

So, is it just Intel graphics or other cards, too?

Comment 4 Paul DeStefano 2014-05-08 00:34:58 UTC
Looks like 3.14 was a backlight fix for some other people, but it broke the backlight for us.  Bug 903136 specifies a new kernel parameter, but I tried it and it doesn't work.  So frustrating.

Comment 5 Josh Boyer 2014-05-08 11:10:55 UTC
There's a patch that broke backlight for XPS machines.  It's being reverted upstream and should hit stable at some point.  It may or may not fix your issue.  I'll try to get a scratch build done with it today.

Comment 6 Patrick 2014-05-11 14:30:58 UTC
After upgrade to kernel 3.14.3-200.fc20.x86_64 the problem remains.  Hope for the next one.  I should figure out how to keep the working kernel before a yum upgrade scrolls it out.

Comment 7 Karolis Pocius 2014-05-14 04:56:26 UTC
After playing with various workarounds, I found this one to work on my Dell XPS m1330 with Intel® 965GM graphics

When I make suggested changes and reboot my laptop, the brightness remains at the lowest setting, but then I can adjust it to whatever I want.

Comment 8 Christopher Tubbs 2014-05-14 12:43:19 UTC
I also see the same problem on an Inspiron 1420, Intel 965GM graphics. The last kernel that worked for me was kernel-3.13.10-200.fc20.x86_64

I can confirm the workaround in comment #7 works for me on kernel-3.14.3-200.fc20.x86_64, as long as I'm willing to adjust the brightness after every reboot. This is not an ideal solution.

Let me know if I can help test any potential fixes.

Comment 9 Paul DeStefano 2014-05-14 19:39:08 UTC
comment #7 worked for me too.  So happy.

Now, were is the Fedora page for Kernel>Debugging>Backlight Issues ??

Comment 10 Christopher Tubbs 2014-05-17 03:03:12 UTC
Confirmed this issue persists in kernel-3.14.4-200.fc20.x86_64, but so does the workaround in comment #7.

Comment 11 Patrick 2014-05-17 13:48:28 UTC
I just wanted to note that with the workaround, I'm able to get the backlight turned up a little more than I was normally able to.  The screen is definately brighter at 100% than it usually is.

Comment 12 Soeren Kalesse 2014-05-18 10:33:45 UTC
Just for completeness, I am also able to verify what Karolis had reported: 

1) kernel-3.14.4-200.fc20.i686 still has the problem.
2) The proposed workaround is working. Meaning, create a file:


Section "Device"
    Identifier  "Intel Graphics"
    Driver      "intel"
    Option      "AccelMethod"     "sna"
    Option      "Backlight"       "intel_backlight" # use your backlight that works here
    BusID       "PCI:0:2:0"

Then add acpi_backlight=vendor to the kernel's boot parameters. 

Brightness now becomes adjustable as soon as X11 is started.

Comment 13 Billy Smith 2014-06-01 20:36:38 UTC
Here is a new wrinkle. I have the same problem as the others above on a Dell Latitude D630 with Intel 965GM kernel-3.14.2-200.fc20.x86-64. Function keys bring up the "brightness icon" and show the "status bar beneath it changing, but there is no change in actual brightness. Screen stubbornly remains dim to point of being almost unreadable. It is at maximum brightness during the
vendor's "splash" just before the boot menu comes up and during the countdown to boot. Goes unalterably dim immediately upon initiation of the boot.

Tried the fix mentioned in the last comment above: the machine would not boot. Screen went black and disk activity light stopped flashing. Had to power down to make next attempts. Tried to boot with the last kernel just prior to the update that gave me kernel-3.14; same result. I had to use the installation disc to bring up Fedora Live and delete the file I had just created. Machine then booted normally into kernel-3.14.

Comment 14 Billy Smith 2014-06-01 20:38:25 UTC
Addendum to last comment: after I rescued the machine and booted with kernel-3.14, the problem persisted. I still don't have a fix.

Comment 15 Billy Smith 2014-06-01 20:50:28 UTC
Tried one more time. The fix worked this time, but I had to quickly use the function brightness keys to bring the intensity of the display up early in the boot process. This is clumsy, but it worked at least this one time.

Comment 16 Karolis Pocius 2014-06-06 21:23:06 UTC
The issue persists in 3.14.5-200, but the workaround in comment #7 is still good.

Comment 17 Christian 2014-06-09 03:17:59 UTC
I've just updated to kernel 3.14.5-200.fc20.x86_64 and have the same problem. The workaround in comment #7 is good, but I must to adjust the brightness on every start of the system.

My notebook is a Dell 1420 with Mobile Intel® 965 Express Chipset.

How can I fix the brightness at the start?

Comment 18 Yevgeny Zaspitsky 2014-06-09 08:31:02 UTC
Lenovo T430s (I7-3520M CPU + Ivybridge Mobile graphics) with kernel 3.14.5-200.fc20.x86_64 - starts with lowest britness setting (the screen can't be read).

Comment 19 Karolis Pocius 2014-06-15 19:00:20 UTC
Looks like it's finally fixed in 3.14.7-200. For me at least.

Comment 20 Christian 2014-06-15 19:20:21 UTC
I confirm what Karolis Pocius says. It's fixed in 3.14.7-200. But I still one doubt. What could happen if I delete the added patch/fix file: /usr/share/X11/xorg.conf.d/80-backlight.conf.

Best regards.

Comment 21 Karolis Pocius 2014-06-15 19:23:16 UTC
I removed that workaround before rebooting and commenting here. It works without it, so it's safe to remove.

Comment 22 Josh Boyer 2014-06-16 12:51:26 UTC

Comment 23 Paul DeStefano 2014-07-02 21:05:28 UTC
FYI, this is still broken in my machine with Intel graphics.  Without Xorg configuration for Intel backlight, kernel 3.14.8 has no backlight adjustment.

VGA compatible controller: Intel Corporation Atom Processor D4xx/D5xx/N4xx/N5xx Integrated Graphics Controller

Kernel driver in use: i915

I will open a new ticket.

Comment 24 Hans de Goede 2015-01-09 13:25:20 UTC
Hi All,

A couple of months ago I've started working throuh all the backlight bugs in Fedora, at that time this one was already closed. But there are a lot of reporters here, and only some have confirmed that the latest kernel fixes there issue.

If there are still people here who have any backlight issues, or only can get their backlight to work with a workaround, rather then having it work out of the box, please file a new bug against component kernel *and* put me in the Cc.



Note You need to log in before you can comment on or make changes to this bug.