Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at
Bug 1133315 - Update to latest GParted in EL5 and EL6
Summary: Update to latest GParted in EL5 and EL6
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: gparted
Version: el6
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: Mukundan Ragavan
QA Contact: Fedora Extras Quality Assurance
Depends On:
Blocks: CVE-2014-7208
TreeView+ depends on / blocked
Reported: 2014-08-24 14:32 UTC by Mike Fleetwood
Modified: 2014-12-21 20:30 UTC (History)
2 users (show)

Fixed In Version: gparted-0.19.1-3.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2014-12-11 06:27:07 UTC
Type: Bug

Attachments (Terms of Use)
gparted.spec for GParted 0.19.1 on EL6 (deleted)
2014-11-10 18:33 UTC, Mike Fleetwood
no flags Details
gparted.spec and patches for GParted 0.19.1 on EL5 (deleted)
2014-11-10 18:35 UTC, Mike Fleetwood
no flags Details

Description Mike Fleetwood 2014-08-24 14:32:01 UTC
Please update to the latest GParted, version 0.19.1, in EL5 and EL6.

Since GParted 0.4.8 and 0.6.0, included in EL5 and EL6 respectively,
there have been many data corruption and crashing fixes appled to

I believe that this is inline with the EPEL policy which allows upstream
upgrades in these cases.  The policy says:
    Only updates that fix important bugs (say: data-corruption, security
    problems, really annoying bugs)

Here is the list of just these types of fixes I can identify from the
GParted NEWS ( and attached
Release Notes:

GParted 0.5.1
- Avoid crashes by ignoring devices with sector size > 512 bytes

- Fix crash moving partition when size is a multiple of 16 MiB

- Fix issue moving logical partition overwritting EBR (Gnome#623630)

- Prevent partition table creation if partitions are active
- Prevent swapon and mount if partition is in operation queue

- Fix crash at start with glibmm-ERROR (Ubuntu#609477,Ubuntu#617885)
- Fix crash moving more than one logical partition right (Gnome#628863)

- Fix GParted crashes with assertion (head_size <= 63) (Ubuntu#545911)

- Ensure space for EBR when resizing Extended partition (Gnome#664050)
- Ensure Align to MiB does not overlap following partition

- Fix crash when pressing Esc in dialogs with number entry

- Fix logical partition grow overlaps extended partition end

- Avoid crash in GParted when moving or copying partitions

- Avoid another crash in GParted when moving or copying partitions

- Fix crash if click apply before pending operations fully displayed

- Fix busy detection for Linux Software RAID and extended partitions

- Prevent crash when creating new partition on disk with loop label

- Refactor OperationDetail to address random crash behavior

- Prevent crash caused by cross thread write after free in _OnReadable()

Current GParted will build perfectly on EL6.

A small patch will be required on EL5.  Change the script
so that intltool 0.35.0 is considered acceptable:

diff --git a/ b/
index 246e942..5ab71b2 100644
--- a/
+++ b/
@@ -31,7 +31,7 @@ AC_SUBST([GETTEXT_PACKAGE])

Then re-generate the configure script from

Mike Fleetwood (GParted Developer)

Comment 1 Mukundan Ragavan 2014-08-25 22:27:39 UTC
How "easy" will back porting these fixes be? I don't think I can bump the major version on EL. I will check the updates policy again.

Comment 2 Mike Fleetwood 2014-08-26 13:46:18 UTC
(In reply to Mukundan Ragavan from comment #1)
> How "easy" will back porting these fixes be? I don't think I can bump the
> major version on EL. I will check the updates policy again.

Hi Mukundan,

I haven't tried to backport the above mentions fixes, but I suspect that
after the first few it will become difficult and then impossible because
of the other changes in GParted.

(As I'm sure you've worked out) the above list of fixed data corruptions
and crashes it about justifying upgrading to the latest upstream GParted
under the EPEL policy referenced above.


Comment 3 Mukundan Ragavan 2014-08-26 16:38:01 UTC
Hi Mike, 

I most certainly agree with you on the importance of pushing the newer version as an update. Let me check on the mailing list and verify dependencies before I push any updates - particularly to EL-5. :)

Comment 4 Mike Fleetwood 2014-09-20 13:33:35 UTC
Hi Mukundan,

Any news on this.

Comment 5 Mukundan Ragavan 2014-09-20 15:13:07 UTC
My apologies. I completely forgot about this. Let me set the ball rolling today.

Comment 6 Mukundan Ragavan 2014-10-17 01:42:58 UTC
Hey Mike, quick question - Will updating to the latest Gparted on EL-5 and EL-6 result in breakage of scripts, etc?

Will the end user experience be very different?

I have used Gparted in EL6 and Fedora, I do not remember anything "surprising" me, but EL-5, I have not used.

Your thoughts?

Comment 7 Mike Fleetwood 2014-10-17 13:13:38 UTC
Hi Mukundan,

There will be no breakages from updating to the latest GParted on EL-5
and EL-6.
  1) No other packages depenend on the GParted package.  It only
     provides the GParted GUI program and the related help Manual,
     icons, command line manual page, etc.
  2) /usr/sbin/gparted is a shell script wrapper used to disable file
     system automounting only while GParted is running.  This is written
     in a backwardly compatible way, maintaining support for older
     methods: hal-lock and devkit-disks, while adding support for the
     newer methods: udisks and systemctl.

The end user experience will be the same.
  1) The UI in GParted 0.19.1 is the same as it was back in 0.4.8, and
     even earlier.
  2) GParted >= 0.6.0 by default creates partitions aligned to 1 MiB
     where as earlier releases default to cylinder alignment.  This is
     just a combo box to select the required alignment in the Create New
     Partition dialog.  Very small difference for compared to
     GParted 0.4.8 on EL-5.


Comment 8 Mike Fleetwood 2014-11-10 18:33:49 UTC
Created attachment 955923 [details]
gparted.spec for GParted 0.19.1 on EL6

Hi Mukundan,

Here is the updated gparted.spec file for GParted 0.19.1 on EL6.
Fetched from the GParted package repo and minimally updated.

Successfully built an RPM on my CentOS 6.6 box from this.

Comment 9 Mike Fleetwood 2014-11-10 18:35:42 UTC
Created attachment 955924 [details]
gparted.spec and patches for GParted 0.19.1 on EL5

Here is the updated gparted.spec and patches for GParted 0.19.1 on EL5.
Fetched from the GParted package repo and minimally updated.

Description of patches from the spec file:

# Patch0: gparted-el5-intltool.patch
# Required to compile GParted on EL5 with intltool 0.35.0.

# Patch1: gparted-el5-ext3-default.patch
# Recommended.  Use ext3 as the default new file system rather than ext4
# as ext4 support was added later in optional package e4fsprogs.

# Patch2: gparted-738706-e4fsprogs.patch
# Recommended.  Support ext4 tools from e4fsprogs package.  Upstreamed
# as GNOME#738706 in GParted > 0.20.0.

I really would appreciate you releasing GParted 0.19.1 for EL5 and EL6.


Comment 10 Mike Fleetwood 2014-11-10 18:38:17 UTC
Doh.  Missed a bit.
Successfully built an RPM on my CentOS 5.11 box from the above.

Comment 11 Mukundan Ragavan 2014-11-11 00:23:01 UTC
Since there was no big issues raised on epel-devel, I had planned to do this past week but could not. I should have it done this week.

Thanks a lot for the patches. You have done most of my work!

Comment 12 Mukundan Ragavan 2014-11-18 01:34:05 UTC
Just an update ... 0.19.1 does not build on EL-6. :(

I will look at this soon.

Comment 13 Mike Fleetwood 2014-11-18 09:50:58 UTC
Error fragment:
    ./configure: line 15931: intltool-update: command not found
    checking for intltool >= 0.35.5...  found
    configure: error: Your intltool is too old.  You need intltool
    0.35.5 or later.
    error: Bad exit status from /var/tmp/rpm-tmp.IGqnHC (%build)

First two lines seem a little contradictory; intltool-update command not
found and intltool >= 0.35.5 found.  Anyway, EPEL 6 comes with
intltool 0.41.0 so I assume that the buildroot environment isn't
including it by default.  Recommend adding intltool to the BuildRequires
for the EL6 spec file.  (Was previously added to the F15 and later spec
files).  Expect to have to add it to the EL5 spec file too.


Comment 14 Fedora Update System 2014-11-19 03:23:10 UTC
gparted-0.19.1-1.el6 has been submitted as an update for Fedora EPEL 6.

Comment 15 Fedora Update System 2014-11-19 07:50:56 UTC
Package gparted-0.19.1-1.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing gparted-0.19.1-1.el6'
as soon as you are able to.
Please go to the following url:
then log in and leave karma (feedback).

Comment 16 Mike Fleetwood 2014-11-22 10:54:04 UTC
Hi Mukundan,

Just in case you haven't seen my feedback in Bodhi.  There is a cosmetic
issue: Package is version 0.19.1-1.el6, but the changelog is up to


Comment 17 Mukundan Ragavan 2014-11-22 16:43:28 UTC
Hi Mike, 

I saw that. When I do EL-5 update today or tomorrow, I will fix that as well! I will probably push a newer update and rescind this one. :)

Comment 18 Fedora Update System 2014-11-25 01:33:35 UTC
gparted-0.19.1-3.el6 has been submitted as an update for Fedora EPEL 6.

Comment 19 Mukundan Ragavan 2014-11-25 01:35:07 UTC
Well, that's fixed! Now EL-5 remains! :)

Comment 20 Mukundan Ragavan 2014-12-02 02:52:13 UTC
Rats! I will do this tomorrow! :(

Comment 21 Mukundan Ragavan 2014-12-09 00:46:29 UTC
There seems to be some problem with building on EPEL-5 that I am trying to figure out.

mock builds have been failing for a few days now. 

For example,

Comment 22 Mike Fleetwood 2014-12-09 19:33:11 UTC
Hi Mukundan,

Never used mock but this looks strange.  Package name trying to be built
(including fc21)
yet the build logs appear to show it building on el5 as the build root
being constructed contains lots of packages named el5.

Sorry I can't be of more help,

Comment 23 Mukundan Ragavan 2014-12-10 02:20:06 UTC
Hi Mike, the src.rpm does not matter. It just reflects what system the source rpm was built on.

I just wanted to give an update since I have not responded here. I will try to see what's really going on. No worries.

Comment 24 Fedora Update System 2014-12-11 06:27:07 UTC
gparted-0.19.1-3.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 25 Mukundan Ragavan 2014-12-12 00:46:47 UTC
Just a note - EL5 is not pushed yet.

Comment 26 Mukundan Ragavan 2014-12-21 20:30:54 UTC
(In reply to Mukundan Ragavan from comment #25)
> Just a note - EL5 is not pushed yet.

gparted on EL-5 is being retired due to broken deps. I think this can be considered closed.

Note You need to log in before you can comment on or make changes to this bug.