Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1153800 - calxeda highbank won't boot on 3.16 kernel
Summary: calxeda highbank won't boot on 3.16 kernel
Keywords:
Status: CLOSED DUPLICATE of bug 1139762
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 20
Hardware: armv7hl
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-16 19:50 UTC by Jeff Bastian
Modified: 2014-10-16 20:31 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-16 20:31:13 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
boot log of 3.16 kernel (deleted)
2014-10-16 19:55 UTC, Jeff Bastian
no flags Details
boot log of 3.11 kernel (deleted)
2014-10-16 19:58 UTC, Jeff Bastian
no flags Details

Description Jeff Bastian 2014-10-16 19:50:16 UTC
Description of problem:
The Fedora 20 3.16.4-200.fc20.armv7hl fails to boot on Calxeda Highbank systems.

Starting kernel ... 
...
[    0.000000] Linux version 3.16.4-200.fc20.armv7hl (mockbuild.fedoraproject.org) (gcc version 4.8.3 20140911 (Red Hat 4.8.3-7) (GCC) ) #1 SMP Mon Oct 6 14:23:34 UTC 2014 
...
[    0.000000] ------------[ cut here ]------------ 
[    0.000000] WARNING: CPU: 0 PID: 0 at arch/arm/mach-highbank/highbank.c:60 highbank_l2c310_write_sec+0x4c/0x64() 
[    0.000000] Highbank L2C310: ignoring write to reg 0x104 
[    0.000000] Modules linked in: 
[    0.000000] CPU: 0 PID: 0 Comm: swapper/0 Not tainted 3.16.4-200.fc20.armv7hl #1 
[    0.000000] [<c0218310>] (unwind_backtrace) from [<c021270c>] (show_stack+0x18/0x1c) 
[    0.000000] [<c021270c>] (show_stack) from [<c0870e6c>] (dump_stack+0x70/0x8c) 
[    0.000000] [<c0870e6c>] (dump_stack) from [<c0250ae0>] (warn_slowpath_common+0x6c/0x90) 
[    0.000000] [<c0250ae0>] (warn_slowpath_common) from [<c0250b38>] (warn_slowpath_fmt+0x34/0x44) 
[    0.000000] [<c0250b38>] (warn_slowpath_fmt) from [<c022990c>] (highbank_l2c310_write_sec+0x4c/0x64) 
[    0.000000] [<c022990c>] (highbank_l2c310_write_sec) from [<c02230e8>] (l2c_write_sec+0x34/0x44) 
[    0.000000] [<c02230e8>] (l2c_write_sec) from [<c022314c>] (l2c_enable+0x24/0xa4) 
[    0.000000] [<c022314c>] (l2c_enable) from [<c0bcc7f4>] (l2c310_enable+0x188/0x1f0) 
[    0.000000] [<c0bcc7f4>] (l2c310_enable) from [<c0bcc5e8>] (__l2c_init+0x14c/0x1d0) 
[    0.000000] [<c0bcc5e8>] (__l2c_init) from [<c0bccccc>] (l2x0_of_init+0x16c/0x19c) 
[    0.000000] [<c0bccccc>] (l2x0_of_init) from [<c0bc7b58>] (init_IRQ+0x58/0x78) 
[    0.000000] [<c0bc7b58>] (init_IRQ) from [<c0bc5a10>] (start_kernel+0x200/0x3a8) 
[    0.000000] [<c0bc5a10>] (start_kernel) from [<00208074>] (0x208074) 
[    0.000000] ---[ end trace 3406ff24bd97382e ]--- 
...

[    1.370234] VFS: Cannot open root device "UUID=5ac79003-01c6-4685-9ccc-d20d361147bf" or unknown-block(0,0): error -6 
[    1.380762] Please append a correct "root=" boot option; here are the available partitions: 
[    1.389113] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0) 
[    1.397371] CPU: 0 PID: 1 Comm: swapper/0 Tainted: G        W     3.16.4-200.fc20.armv7hl #1 
[    1.405814] [<c0218310>] (unwind_backtrace) from [<c021270c>] (show_stack+0x18/0x1c) 
[    1.413555] [<c021270c>] (show_stack) from [<c0870e6c>] (dump_stack+0x70/0x8c) 
[    1.420774] [<c0870e6c>] (dump_stack) from [<c086d8fc>] (panic+0x8c/0x208) 
[    1.427645] [<c086d8fc>] (panic) from [<c0bc6144>] (mount_block_root+0x238/0x274) 
[    1.435125] [<c0bc6144>] (mount_block_root) from [<c0bc630c>] (prepare_namespace+0x128/0x188) 
[    1.443644] [<c0bc630c>] (prepare_namespace) from [<c0bc5db8>] (kernel_init_freeable+0x200/0x24c) 
[    1.452515] [<c0bc5db8>] (kernel_init_freeable) from [<c086bedc>] (kernel_init+0x10/0xec) 
[    1.460689] [<c086bedc>] (kernel_init) from [<c020eb98>] (ret_from_fork+0x14/0x20) 
[    1.468251] CPU1: stopping 
[    1.470952] CPU: 1 PID: 0 Comm: swapper/1 Tainted: G        W     3.16.4-200.fc20.armv7hl #1 
[    1.479387] [<c0218310>] (unwind_backtrace) from [<c021270c>] (show_stack+0x18/0x1c) 
[    1.487124] [<c021270c>] (show_stack) from [<c0870e6c>] (dump_stack+0x70/0x8c) 
[    1.494340] [<c0870e6c>] (dump_stack) from [<c0215d68>] (handle_IPI+0xd4/0x170) 
[    1.501643] [<c0215d68>] (handle_IPI) from [<c020891c>] (gic_handle_irq+0x68/0x70) 
[    1.509210] [<c020891c>] (gic_handle_irq) from [<c0877500>] (__irq_svc+0x40/0x54) 
[    1.516683] Exception stack(0xeb0e1f98 to 0xeb0e1fe0) 
[    1.521725] 1f80:                                                       ffffffed 00000000 
[    1.529894] 1fa0: 000005a6 c0222da0 00000000 eb0e0000 c0c970a8 c0880a30 00000000 eb0e0000 
[    1.538061] 1fc0: ffffffed 00000000 00000000 eb0e1fe0 c020f77c c020f780 60000113 ffffffff 
[    1.546235] [<c0877500>] (__irq_svc) from [<c020f780>] (arch_cpu_idle+0x34/0x40) 
[    1.553630] [<c020f780>] (arch_cpu_idle) from [<c028c4d4>] (cpu_startup_entry+0x1a4/0x324) 
[    1.561889] [<c028c4d4>] (cpu_startup_entry) from [<002089c4>] (0x2089c4) 
[    1.568667] CPU2: stopping 
[    1.571369] CPU: 2 PID: 0 Comm: swapper/2 Tainted: G        W     3.16.4-200.fc20.armv7hl #1 
[    1.579804] [<c0218310>] (unwind_backtrace) from [<c021270c>] (show_stack+0x18/0x1c) 
[    1.587541] [<c021270c>] (show_stack) from [<c0870e6c>] (dump_stack+0x70/0x8c) 
[    1.594758] [<c0870e6c>] (dump_stack) from [<c0215d68>] (handle_IPI+0xd4/0x170) 
[    1.602060] [<c0215d68>] (handle_IPI) from [<c020891c>] (gic_handle_irq+0x68/0x70) 
[    1.609623] [<c020891c>] (gic_handle_irq) from [<c0877500>] (__irq_svc+0x40/0x54) 
[    1.617094] Exception stack(0xeb0e3f98 to 0xeb0e3fe0) 
[    1.622135] 3f80:                                                       ffffffed 00000000 
[    1.630305] 3fa0: 000005f6 c0222da0 00000000 eb0e2000 c0c970a8 c0880a30 00000000 eb0e2000 
[    1.638473] 3fc0: ffffffed 00000000 00000000 eb0e3fe0 c020f77c c020f780 60000113 ffffffff 
[    1.646645] [<c0877500>] (__irq_svc) from [<c020f780>] (arch_cpu_idle+0x34/0x40) 
[    1.654035] [<c020f780>] (arch_cpu_idle) from [<c028c4d4>] (cpu_startup_entry+0x1a4/0x324) 
[    1.662292] [<c028c4d4>] (cpu_startup_entry) from [<002089c4>] (0x2089c4) 
[    1.669069] CPU3: stopping 
[    1.671770] CPU: 3 PID: 0 Comm: swapper/3 Tainted: G        W     3.16.4-200.fc20.armv7hl #1 
[    1.680205] [<c0218310>] (unwind_backtrace) from [<c021270c>] (show_stack+0x18/0x1c) 
[    1.687941] [<c021270c>] (show_stack) from [<c0870e6c>] (dump_stack+0x70/0x8c) 
[    1.695156] [<c0870e6c>] (dump_stack) from [<c0215d68>] (handle_IPI+0xd4/0x170) 
[    1.702458] [<c0215d68>] (handle_IPI) from [<c020891c>] (gic_handle_irq+0x68/0x70) 
[    1.710021] [<c020891c>] (gic_handle_irq) from [<c0877500>] (__irq_svc+0x40/0x54) 
[    1.717493] Exception stack(0xeb0e5f98 to 0xeb0e5fe0) 
[    1.722534] 5f80:                                                       ffffffed 00000000 
[    1.730703] 5fa0: 0000063c c0222da0 00000000 eb0e4000 c0c970a8 c0880a30 00000000 eb0e4000 
[    1.738871] 5fc0: ffffffed 00000000 00000000 eb0e5fe0 c020f77c c020f780 60000113 ffffffff 
[    1.747043] [<c0877500>] (__irq_svc) from [<c020f780>] (arch_cpu_idle+0x34/0x40) 
[    1.754434] [<c020f780>] (arch_cpu_idle) from [<c028c4d4>] (cpu_startup_entry+0x1a4/0x324) 
[    1.762690] [<c028c4d4>] (cpu_startup_entry) from [<002089c4>] (0x2089c4) 
[    1.769472] ---[ end Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0) 


Version-Release number of selected component (if applicable):
kernel-3.16.4-200.fc20.armv7hl

How reproducible:
every time

Steps to Reproduce:
1. install Fedora 20 GOLD with kernel-3.11.10-301.fc20.armv7hl
2. yum update dracut
3. yum update kernel
4. reboot

Actual results:
kernel WARNING followed shortly after by a panic when it cannot find the root filesystem

Expected results:
normal boot

Additional info:
Apparently the Fedora Updates mirrors are not all in sync.  Sometimes my system yum updates to the 3.15.10-201.fc20.armv7hl kernel which works fine.

Comment 1 Jeff Bastian 2014-10-16 19:55:11 UTC
Created attachment 947732 [details]
boot log of 3.16 kernel

Comment 2 Jeff Bastian 2014-10-16 19:58:39 UTC
Created attachment 947733 [details]
boot log of 3.11 kernel

For comparison, a boot log from the working 3.11 kernel (up to where systemd takes over)

Comment 3 Peter Robinson 2014-10-16 20:06:31 UTC
It's fixed in the 3.17 kernel with:

http://pkgs.fedoraproject.org/cgit/kernel.git/tree/arm-highbank-l2-reverts.patch

Comment 4 Jeff Bastian 2014-10-16 20:31:13 UTC
Thanks!  Sorry for the duplicate.

*** This bug has been marked as a duplicate of bug 1139762 ***


Note You need to log in before you can comment on or make changes to this bug.