Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1156632 - Build hamster-time-tracker for EPEL
Summary: Build hamster-time-tracker for EPEL
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: hamster-time-tracker
Version: rawhide
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
Assignee: Raphael Groner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1206945 (view as bug list)
Depends On: 1177390
Blocks: 1201124 1208459
TreeView+ depends on / blocked
 
Reported: 2014-10-24 20:33 UTC by Chris St. Pierre
Modified: 2015-07-14 16:42 UTC (History)
5 users (show)

Fixed In Version: xfce4-hamster-plugin-1.6.1-1.el7
Doc Type: Enhancement
Doc Text:
Clone Of:
: 1208459 (view as bug list)
Environment:
Last Closed: 2015-07-14 16:42:53 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1046077 0 low CLOSED Not possible to start time tracking with hamster 2022-05-16 11:32:56 UTC

Internal Links: 1046077

Description Chris St. Pierre 2014-10-24 20:33:57 UTC
Description of problem:

The hamster-time-tracker SRPM rebuilds cleanly on EL 7. It'd be totally dope if it was added to EPEL. I'd be happy to take on "maintenance" of the EPEL build, if such is necessary.

Version-Release number of selected component (if applicable):

1.04-3

Comment 1 Ankur Sinha (FranciscoD) 2014-11-23 20:17:25 UTC
Hi Chris,

Can you please apply as a co-maintainer and maintain EL? I haven't an EL machine and therefore don't want to maintain the branch - I won't be able to test packages.

Thanks,
Ankur

Comment 2 Jaroslav Reznik 2015-03-03 17:04:36 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22

Comment 3 Raphael Groner 2015-03-29 22:09:02 UTC
Please build for EPEL7, see bug #1206945.

Comment 4 Raphael Groner 2015-03-29 22:09:38 UTC
*** Bug 1206945 has been marked as a duplicate of this bug. ***

Comment 5 Raphael Groner 2015-03-29 22:11:45 UTC
Priority set to high cause there's some demand to have it as a dependency for a needed package in EPEL7 (xfce4-hamster-plugin).

Comment 6 Ankur Sinha (FranciscoD) 2015-03-30 10:00:42 UTC
Raphael,

As I'd mentioned to Chris, I haven't an EL machine and therefore don't want to maintain the branch - I won't be able to test packages. Please apply for the EL branches if you can maintain the package.

Thanks,
Ankur

Comment 7 Ankur Sinha (FranciscoD) 2015-03-30 10:15:10 UTC
Looks like new branches need to be requested. Doing it now.

Comment 8 Raphael Groner 2015-03-30 10:17:39 UTC
Hi Ankur,
I could co-maintain this package, if you may like.

Comment 9 Ankur Sinha (FranciscoD) 2015-03-30 10:18:28 UTC
Sure. I've requested branches and given you ownership of them.
Please see bug https://bugzilla.redhat.com/show_bug.cgi?id=1156632

I hope I've done it right!

Comment 10 Fedora Update System 2015-03-30 20:51:36 UTC
hamster-time-tracker-1.04-4.el7 has been submitted as an update for Fedora EPEL 7.
https://admin.fedoraproject.org/updates/hamster-time-tracker-1.04-4.el7

Comment 11 Fedora Update System 2015-04-01 02:00:00 UTC
hamster-time-tracker-1.04-4.el7 has been pushed to the Fedora EPEL 7 testing repository.

Comment 12 Raphael Groner 2015-04-12 21:25:36 UTC
Not functional currently, cause the dependency gnome-python2-libwnck as a subpackage of gnome-python2-desktop is missing in EPEL. Explanation for this requirement is in bug #1046077.

Comment 13 Fedora Update System 2015-04-22 17:27:25 UTC
hamster-time-tracker-1.04-5.el7 has been submitted as an update for Fedora EPEL 7.
https://admin.fedoraproject.org/updates/hamster-time-tracker-1.04-5.el7

Comment 14 Raphael Groner 2015-05-08 11:55:55 UTC
We agreed to build without libwnck for now, so the package won't have full featured functionality, see comment #12 and bug #1046077.

Comment 15 Fedora Update System 2015-05-08 13:50:49 UTC
xfce4-hamster-plugin-1.6.1-1.el7, hamster-time-tracker-1.04-5.el7 has been submitted as an update for Fedora EPEL 7.
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2015-1450/hamster-time-tracker-1.04-5.el7,xfce4-hamster-plugin-1.6.1-1.el7

Comment 16 Fedora Update System 2015-07-14 16:42:53 UTC
xfce4-hamster-plugin-1.6.1-1.el7, hamster-time-tracker-1.04-5.el7 has been pushed to the Fedora EPEL 7 stable repository.


Note You need to log in before you can comment on or make changes to this bug.