Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1172237 - Crash caused by object with no CKA_ID
Summary: Crash caused by object with no CKA_ID
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pkcs11-helper
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kalev Lember
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-12-09 16:46 UTC by David Woodhouse
Modified: 2015-02-22 06:05 UTC (History)
1 user (show)

Fixed In Version: pkcs11-helper-1.11-4.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-22 06:05:20 UTC
Type: Bug


Attachments (Terms of Use)

Description David Woodhouse 2014-12-09 16:46:49 UTC
$ openvpn --show-pkcs11-ids /usr/lib64/p11-kit-proxy.so 
openvpn: _pkcs11h-crypto-openssl.c:235: __pkcs11h_crypto_openssl_certificate_is_issuer: Assertion `cert_blob!=((void *)0)' failed.
Aborted (core dumped)


The crash is fixed by this commit upstream:
https://github.com/OpenSC/pkcs11-helper/commit/8d81cf6b46

Comment 1 David Woodhouse 2014-12-09 16:54:44 UTC
I've also filed bug 1172240 against p11-kit since this shouldn't have been happening anyway...

Comment 2 Fedora Update System 2014-12-10 15:49:32 UTC
pkcs11-helper-1.11-4.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/pkcs11-helper-1.11-4.fc21

Comment 3 Fedora Update System 2014-12-12 04:36:49 UTC
Package pkcs11-helper-1.11-4.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing pkcs11-helper-1.11-4.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-16794/pkcs11-helper-1.11-4.fc21
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2015-02-22 06:05:20 UTC
pkcs11-helper-1.11-4.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.