Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1177988 - ConfigError: Repository updates has no mirror or baseurl set.
Summary: ConfigError: Repository updates has no mirror or baseurl set.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 22
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Chris Lumens
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:542112183de363ffa9e1da5472d...
: 1177987 (view as bug list)
Depends On:
Blocks: F22BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2015-01-01 01:45 UTC by Adam Williamson
Modified: 2015-03-10 03:47 UTC (History)
6 users (show)

Fixed In Version: anaconda-22.14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-10 03:47:16 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
File: anaconda-tb (deleted)
2015-01-01 01:45 UTC, Adam Williamson
no flags Details
File: anaconda.log (deleted)
2015-01-01 01:45 UTC, Adam Williamson
no flags Details
File: dnf.log (deleted)
2015-01-01 01:45 UTC, Adam Williamson
no flags Details
File: environ (deleted)
2015-01-01 01:45 UTC, Adam Williamson
no flags Details
File: ks.cfg (deleted)
2015-01-01 01:45 UTC, Adam Williamson
no flags Details
File: lsblk_output (deleted)
2015-01-01 01:45 UTC, Adam Williamson
no flags Details
File: nmcli_dev_list (deleted)
2015-01-01 01:45 UTC, Adam Williamson
no flags Details
File: os_info (deleted)
2015-01-01 01:45 UTC, Adam Williamson
no flags Details
File: storage.log (deleted)
2015-01-01 01:45 UTC, Adam Williamson
no flags Details
File: syslog (deleted)
2015-01-01 01:45 UTC, Adam Williamson
no flags Details
File: ifcfg.log (deleted)
2015-01-01 01:45 UTC, Adam Williamson
no flags Details
File: packaging.log (deleted)
2015-01-01 01:45 UTC, Adam Williamson
no flags Details
File: program.log (deleted)
2015-01-01 01:45 UTC, Adam Williamson
no flags Details

Description Adam Williamson 2015-01-01 01:45:13 UTC
Description of problem:
per https://fedoraproject.org/wiki/Anaconda/Kickstart#repo :

"Note: If you want to enable one of the repos in /etc/anaconda.repos.d that is disabled by default (like "updates"), you should use --name=<repoid> but none of the other options. anaconda will look for a repo by this name automatically."

but if you run a current Rawhide install with a kickstart with this line:

repo --name=updates

it will fail, with a DNF error saying the repo has no URL or mirror list. If you run an install with the same kickstart and add 'inst.nodnf' to disable the DNF payload (and use yum payload instead), it works fine (enabling the 'updates' repository, as desired).

I think this is because dnfpayload.py _add_repo() is missing any equivalent of this bit from yumpayload.py 's _addYumRepo():

        # First, delete any pre-existing repo with the same name.
        # First, check for any pre-existing repo with the same name.
        with _yum_lock:
            if name in self._yum.repos.repos:
                if not baseurl and not mirrorlist:
                    # This is a repo we already have a config file in /etc/anaconda.repos.d,
                    # so we just need to enable it here.  See the kickstart docs for the repo
                    # command.
                    self.enableRepo(name)
                    obj = self._yum.repos.repos[name]
                    needsAdding = False
                else:
                    self._yum.repos.delete(name)

I'd guess that could be transferred over more or less verbatim.

This is a significant issue as it's highly likely people have kickstarts that rely on this behaviour (I certainly do).

Version-Release number of selected component:
anaconda-22.13-1

The following was filed automatically by anaconda:
anaconda 22.13-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/dnf/repodict.py", line 37, in add
    raise ConfigError(msg)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/dnfpayload.py", line 230, in _add_repo
    self._base.repos.add(repo)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/dnfpayload.py", line 727, in updateBaseRepo
    self._add_repo(ksrepo)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/__init__.py", line 1226, in _runThread
    payload.updateBaseRepo(fallback=fallback, checkmount=checkmount)
  File "/usr/lib64/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 227, in run
    threading.Thread.run(self, *args, **kwargs)
ConfigError: Repository updates has no mirror or baseurl set.

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-rawhide-x86_64 quiet inst.ks=https://www.happyassassin.net/ks/oc/oc8-httpd-mysql.ks
dnf.rpm.log:    Jan 01 01:43:53 INFO --- logging initialized ---
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.18.1-2.fc22.x86_64
product:        Fedora"
release:        Cannot get release name.
type:           anaconda
version:        Fedora

Comment 1 Adam Williamson 2015-01-01 01:45:15 UTC
Created attachment 974902 [details]
File: anaconda-tb

Comment 2 Adam Williamson 2015-01-01 01:45:16 UTC
Created attachment 974903 [details]
File: anaconda.log

Comment 3 Adam Williamson 2015-01-01 01:45:17 UTC
Created attachment 974904 [details]
File: dnf.log

Comment 4 Adam Williamson 2015-01-01 01:45:18 UTC
Created attachment 974905 [details]
File: environ

Comment 5 Adam Williamson 2015-01-01 01:45:19 UTC
Created attachment 974906 [details]
File: ks.cfg

Comment 6 Adam Williamson 2015-01-01 01:45:20 UTC
Created attachment 974907 [details]
File: lsblk_output

Comment 7 Adam Williamson 2015-01-01 01:45:21 UTC
Created attachment 974908 [details]
File: nmcli_dev_list

Comment 8 Adam Williamson 2015-01-01 01:45:22 UTC
Created attachment 974909 [details]
File: os_info

Comment 9 Adam Williamson 2015-01-01 01:45:23 UTC
Created attachment 974910 [details]
File: storage.log

Comment 10 Adam Williamson 2015-01-01 01:45:25 UTC
Created attachment 974911 [details]
File: syslog

Comment 11 Adam Williamson 2015-01-01 01:45:25 UTC
Created attachment 974912 [details]
File: ifcfg.log

Comment 12 Adam Williamson 2015-01-01 01:45:26 UTC
Created attachment 974913 [details]
File: packaging.log

Comment 13 Adam Williamson 2015-01-01 01:45:27 UTC
Created attachment 974914 [details]
File: program.log

Comment 14 DO NOT USE account not monitored (old adamwill) 2015-01-01 01:45:31 UTC
*** Bug 1177987 has been marked as a duplicate of this bug. ***

Comment 15 Adam Williamson 2015-01-01 01:47:17 UTC
I'm gonna propose this as a 22 Beta blocker per criterion https://fedoraproject.org/wiki/Fedora_22_Beta_Release_Criteria#Scripted_installation - "The installer must be able to complete a scripted installation which duplicates the default interactive installation as closely as possible." My argument being that updates/updates-testing are enabled by default in an interactive network install. The kickstart criteria kinda suck (still), but this 'feels' blocker-y to me.

Comment 16 Chris Lumens 2015-01-06 16:03:59 UTC
Yeah, looks like we just need to port f2def43c201e392d5475a763069f501043c91a24 to working with dnf.

Comment 17 Petr Schindler 2015-01-07 17:22:39 UTC
Discussed at today's blocker review meeting [1]. Accepted as a beta blocker. This bug violates the Beta criterion: The installer must be able to complete a scripted installation which duplicates the default interactive installation as closely as possible.

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2015-01-07/

Comment 18 Jaroslav Reznik 2015-03-03 17:17:23 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22

Comment 19 Adam Williamson 2015-03-10 03:47:16 UTC
This was fixed a while ago, confirmed in 22 Alpha RC3.


Note You need to log in before you can comment on or make changes to this bug.