Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1196654 - Default package set in Workstation netinst is wrong.
Summary: Default package set in Workstation netinst is wrong.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: distribution
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Václav Pavlín
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F22BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2015-02-26 13:12 UTC by Petr Schindler
Modified: 2015-04-17 11:12 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-16 16:46:14 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
screenshot of anaconda (deleted)
2015-04-16 14:10 UTC, Lukas Brabec
no flags Details
anaconda.log (deleted)
2015-04-16 14:10 UTC, Lukas Brabec
no flags Details
dnf.log (deleted)
2015-04-16 14:11 UTC, Lukas Brabec
no flags Details
hawkey.log (deleted)
2015-04-16 14:11 UTC, Lukas Brabec
no flags Details
packaging.log (deleted)
2015-04-16 14:12 UTC, Lukas Brabec
no flags Details
program.log (deleted)
2015-04-16 14:12 UTC, Lukas Brabec
no flags Details
syslog (deleted)
2015-04-16 14:12 UTC, Lukas Brabec
no flags Details

Description Petr Schindler 2015-02-26 13:12:03 UTC
Description of problem:
22 Alpha TC5 Workstation netinst uses Fedora Cloud Server as default software selection. It should use Workstation instead.

Version-Release number of selected component (if applicable):
Fedora-Workstation-netinst-x86_64-22_Alpha_TC5.iso

How reproducible:
Always

Steps to Reproduce:
1. boot workstation netinst, choose language

Actual results:
Fedora Cloud Server is chosen in software selection by default

Expected results:
Workstation package set should be used

Additional info:
I propose this as F22 Beta Blocker because it violates the beta criterion 'Default package set': When installing with a dedicated installer image for a specific Fedora flavor, the default package set must be the correct set for that flavor.

Comment 1 Dan Mossor [danofsatx] 2015-03-02 14:46:10 UTC
+1 BetaBlocker based on criteria cited.

Comment 2 Petr Schindler 2015-03-02 19:36:38 UTC
Discussed at today's blocker review meeting [1].

This bug was accepted as Beta Blocker - This bug is a clear violation of the beta criterion: "When installing with a dedicated installer image for a specific Fedora flavor, the default package set must be the correct set for that flavor."

http://meetbot.fedoraproject.org/fedora-blocker-review/2015-03-02/

Comment 3 Adam Williamson 2015-03-10 03:01:37 UTC
This is fixed in Alpha RC3 (gold). Default is Workstation. I think this was probably caused by 1196504.

Comment 4 Lukas Brabec 2015-04-16 14:09:09 UTC
I encountered this bug with F22 Beta RC3, when trying PXE boot.

Comment 5 Lukas Brabec 2015-04-16 14:10:20 UTC
Created attachment 1015237 [details]
screenshot of anaconda

minimal install is selected instead of workstation

Comment 6 Lukas Brabec 2015-04-16 14:10:51 UTC
Created attachment 1015238 [details]
anaconda.log

Comment 7 Lukas Brabec 2015-04-16 14:11:13 UTC
Created attachment 1015239 [details]
dnf.log

Comment 8 Lukas Brabec 2015-04-16 14:11:42 UTC
Created attachment 1015241 [details]
hawkey.log

Comment 9 Lukas Brabec 2015-04-16 14:12:05 UTC
Created attachment 1015242 [details]
packaging.log

Comment 10 Lukas Brabec 2015-04-16 14:12:29 UTC
Created attachment 1015243 [details]
program.log

Comment 11 Lukas Brabec 2015-04-16 14:12:49 UTC
Created attachment 1015244 [details]
syslog

Comment 12 Adam Williamson 2015-04-16 15:51:06 UTC
I've seen it sometimes in bare metal testing of various Beta images, but not consistently, and it rarely or never seems to happen in a VM - I just booted the x86_64 image in a VM and it's showing Workstation, for instance.

Unfortunately there always seemed to be something else that needed firefighting and I never found time to get to the bottom of it :(

I guess we need to know how common this is...

Comment 13 Kamil Páral 2015-04-16 16:32:06 UTC
I received Workstation package set by default 5 times out of 5 attempts, using a VM.

I believe the reason is that Lukas's laptop is affected by bug 1212009 and this seems to be a side-effect of having the network down during anaconda initialization. Testing...

Comment 14 Adam Williamson 2015-04-16 16:36:13 UTC
Ditto here: 5 VM boots, 5 metal boots (with network), all Workstation. With network cable disconnected, I get 'error setting up base repository', obviously. After connecting the cable and doing the 'set it to http://foo then set it back to Closest Mirror' trick on INSTALLATION SOURCE, I get 'Nothing selected' for SOFTWARE SELECTION. Which, eh, dunno if it should be called a 'bug' or not, but definitely not a blocker.

Comment 15 Adam Williamson 2015-04-16 16:46:14 UTC
So on a closer reading we noticed you said 'PXE boot', which makes this a completely different case.

I'm not sure if it's a 'bug' or not that this customization isn't applied to a PXE boot case, but I wouldn't personally vote it as a Beta blocker, and it doesn't make sense to re-open this bug for it, as it's a different case. Can you please file it separately? Thanks.

Comment 16 Adam Williamson 2015-04-16 19:58:07 UTC
FWIW I did test with PXE boot and 'inst.stage2=(path/to/Workstation)' and got Workstation as the default too.

Comment 17 Kamil Páral 2015-04-17 11:12:44 UTC
(In reply to awilliam from comment #16)
> FWIW I did test with PXE boot and 'inst.stage2=(path/to/Workstation)' and
> got Workstation as the default too.

Sorry for confusion, this was a issue with our local mirror. It did not contain product.img. This was an error on our end.


Note You need to log in before you can comment on or make changes to this bug.