Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1212535 - rolekit failed to deploy domain controller
Summary: rolekit failed to deploy domain controller
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: rolekit
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F22BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2015-04-16 15:12 UTC by Petr Schindler
Modified: 2015-04-16 18:22 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-16 16:09:13 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
output of journalctl -a (deleted)
2015-04-16 15:13 UTC, Petr Schindler
no flags Details

Description Petr Schindler 2015-04-16 15:12:45 UTC
Description of problem:
I followed test case: https://fedoraproject.org/wiki/QA:Testcase_Server_role_deploy
I installed F22 Server Beta RC3 with all defaults set.
After installation I followed steps from https://fedorahosted.org/rolekit/wiki/DomainController
In booted system I set hostname to ipa.example.com. Run /usr/sbin/rngd -r /dev/urandom, created settings.json file with suggested minimum.

Then I run 'rolectl deploy --settings-file=./settings.json domaincontroller'

After a while the process failed with message: "Error: COMMAND_FAILED: 256"

In journal I found ERROR messages (see attached journal nearly at the end there is whole output) which says:
ERROR: ipa         : DEBUG    The ipa-server-install command failed, exception: SystemExit: Invalid hostname 'ipa', must be f
ully-qualified.
ERROR:
ERROR: Invalid hostname 'ipa', must be fully-qualified.

Which is strange because hostname is set to ipa.example.com

Version-Release number of selected component (if applicable):
rolekit-0.3.2-1.fc22.noarch

How reproducible:
I tried it three time and it happened all the time. Yesterday it worked with RC2


Additional info:
I propose this as a beta blocker because it violates beta criterion: "The core functional requirements for all Featured Server Roles must be met, without any workarounds being necessary."

Comment 1 Petr Schindler 2015-04-16 15:13:16 UTC
Created attachment 1015267 [details]
output of journalctl -a

Comment 2 Stephen Gallagher 2015-04-16 15:40:55 UTC
How precisely did you set the hostname? Did you use 'hostnamectl set-hostname ipa.example.com'?

Comment 3 Stephen Gallagher 2015-04-16 16:09:13 UTC
I just booted a VM, installed Server Beta RC3 taking all of the defaults (including the default hostname).

When it booted up, I ran 'hostnamectl set-hostname domaincontroller.brc3.ipa' and then 'rolectl deploy --settings-file=dc.json domaincontroller' (with a settings file containing only admin_password.

The domain controller installed successfully. I cannot reproduce this issue. My best guess is that whatever mechanism you used to set the hostname did not set it correctly. The appropriate way to do so is with hostnamectl or via cockpit.


Note You need to log in before you can comment on or make changes to this bug.