Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1214462 - [abrt] gnome-shell: meta_wayland_surface_configure_notify(): gnome-shell killed by SIGSEGV
Summary: [abrt] gnome-shell: meta_wayland_surface_configure_notify(): gnome-shell kill...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: mutter
Version: 24
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Florian Müllner
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:35ad9089544d9e56d15c5dee58d...
: 1249311 1273934 1293479 1295843 1327835 1331833 (view as bug list)
Depends On:
Blocks: WaylandRelated
TreeView+ depends on / blocked
 
Reported: 2015-04-22 18:38 UTC by Luya Tshimbalanga
Modified: 2016-08-31 22:12 UTC (History)
18 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-31 22:12:32 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
File: backtrace (deleted)
2015-04-22 18:39 UTC, Luya Tshimbalanga
no flags Details
File: cgroup (deleted)
2015-04-22 18:39 UTC, Luya Tshimbalanga
no flags Details
File: core_backtrace (deleted)
2015-04-22 18:39 UTC, Luya Tshimbalanga
no flags Details
File: dso_list (deleted)
2015-04-22 18:39 UTC, Luya Tshimbalanga
no flags Details
File: environ (deleted)
2015-04-22 18:39 UTC, Luya Tshimbalanga
no flags Details
File: limits (deleted)
2015-04-22 18:39 UTC, Luya Tshimbalanga
no flags Details
File: maps (deleted)
2015-04-22 18:39 UTC, Luya Tshimbalanga
no flags Details
File: mountinfo (deleted)
2015-04-22 18:39 UTC, Luya Tshimbalanga
no flags Details
File: namespaces (deleted)
2015-04-22 18:39 UTC, Luya Tshimbalanga
no flags Details
File: open_fds (deleted)
2015-04-22 18:39 UTC, Luya Tshimbalanga
no flags Details
File: proc_pid_status (deleted)
2015-04-22 18:39 UTC, Luya Tshimbalanga
no flags Details
File: var_log_messages (deleted)
2015-04-22 18:39 UTC, Luya Tshimbalanga
no flags Details
First change/remove window and then set surface to NULL (deleted)
2015-07-02 10:12 UTC, mchalupa
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
GNOME Bugzilla 751847 0 None None None Never

Description Luya Tshimbalanga 2015-04-22 18:38:57 UTC
Description of problem:
Starting the session

Version-Release number of selected component:
gnome-shell-3.16.1-1.fc22

Additional info:
reporter:       libreport-2.5.1
backtrace_rating: 4
cmdline:        /usr/bin/gnome-shell --wayland --display-server
crash_function: meta_wayland_surface_configure_notify
executable:     /usr/bin/gnome-shell
global_pid:     2258
kernel:         4.0.0-1.fc22.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 meta_wayland_surface_configure_notify at wayland/meta-wayland-surface.c:1929
 #1 meta_window_wayland_move_resize_internal at wayland/window-wayland.c:225
 #2 meta_window_move_resize_internal at core/window.c:3697
 #3 meta_window_move_resize_frame at core/window.c:3810
 #4 unmaximize_window_before_freeing at core/window.c:2959
 #5 meta_window_unmanage at core/window.c:1361
 #6 meta_display_unmanage_windows_for_screen at core/display.c:2671
 #7 meta_screen_free at core/screen.c:796
 #8 meta_display_close at core/display.c:1114
 #9 meta_finalize at core/main.c:277

Comment 1 Luya Tshimbalanga 2015-04-22 18:39:00 UTC
Created attachment 1017550 [details]
File: backtrace

Comment 2 Luya Tshimbalanga 2015-04-22 18:39:00 UTC
Created attachment 1017551 [details]
File: cgroup

Comment 3 Luya Tshimbalanga 2015-04-22 18:39:01 UTC
Created attachment 1017552 [details]
File: core_backtrace

Comment 4 Luya Tshimbalanga 2015-04-22 18:39:02 UTC
Created attachment 1017553 [details]
File: dso_list

Comment 5 Luya Tshimbalanga 2015-04-22 18:39:03 UTC
Created attachment 1017554 [details]
File: environ

Comment 6 Luya Tshimbalanga 2015-04-22 18:39:03 UTC
Created attachment 1017555 [details]
File: limits

Comment 7 Luya Tshimbalanga 2015-04-22 18:39:06 UTC
Created attachment 1017556 [details]
File: maps

Comment 8 Luya Tshimbalanga 2015-04-22 18:39:06 UTC
Created attachment 1017557 [details]
File: mountinfo

Comment 9 Luya Tshimbalanga 2015-04-22 18:39:07 UTC
Created attachment 1017558 [details]
File: namespaces

Comment 10 Luya Tshimbalanga 2015-04-22 18:39:08 UTC
Created attachment 1017559 [details]
File: open_fds

Comment 11 Luya Tshimbalanga 2015-04-22 18:39:08 UTC
Created attachment 1017560 [details]
File: proc_pid_status

Comment 12 Luya Tshimbalanga 2015-04-22 18:39:09 UTC
Created attachment 1017561 [details]
File: var_log_messages

Comment 13 Olivier Fourdan 2015-07-02 08:05:04 UTC
The crash occurs in mutter code, not gnome-shell so moving to mutter.

It's a null-pointer dereference because surface is NULL when it reaches meta_wayland_surface_configure_notify()

Comment 14 mchalupa 2015-07-02 10:12:01 UTC
Created attachment 1045449 [details]
First change/remove window and then set surface to NULL

Comment 15 mchalupa 2015-07-16 08:15:00 UTC
Upstream bug:
https://bugzilla.gnome.org/show_bug.cgi?id=751847

Comment 16 Owen Taylor 2015-09-28 16:19:57 UTC
*** Bug 1249311 has been marked as a duplicate of this bug. ***

Comment 17 mchalupa 2015-11-30 13:49:57 UTC
*** Bug 1273934 has been marked as a duplicate of this bug. ***

Comment 18 mchalupa 2016-02-12 10:40:06 UTC
*** Bug 1295843 has been marked as a duplicate of this bug. ***

Comment 19 mchalupa 2016-02-19 07:22:08 UTC
*** Bug 1293479 has been marked as a duplicate of this bug. ***

Comment 20 Jan Kurik 2016-02-24 13:23:18 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase

Comment 21 mchalupa 2016-04-22 13:51:12 UTC
*** Bug 1327835 has been marked as a duplicate of this bug. ***

Comment 22 mchalupa 2016-05-05 10:21:00 UTC
*** Bug 1331833 has been marked as a duplicate of this bug. ***

Comment 23 JP Jung 2016-06-08 18:19:55 UTC
Similar problem has been detected:

Logging into my session, got the crash message, no particular action.

reporter:       libreport-2.7.1
backtrace_rating: 3
cmdline:        /usr/bin/gnome-shell
crash_function: meta_wayland_surface_configure_notify
executable:     /usr/bin/gnome-shell
global_pid:     19128
kernel:         4.5.5-300.fc24.x86_64
package:        gnome-shell-3.20.2-1.fc24
pkg_fingerprint: 73BD E983 81B4 6521
pkg_vendor:     Fedora Project
reason:         gnome-shell killed by SIGSEGV
reproducible:   Not sure how to reproduce the problem
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 24 robert fairbrother 2016-06-25 16:54:00 UTC
Similar problem has been detected:

there was no sound in kodi so i logged off ans in again. i was on facebook with torbrowser

reporter:       libreport-2.6.4
backtrace_rating: 3
cmdline:        /usr/bin/gnome-shell --wayland --display-server
crash_function: meta_wayland_surface_configure_notify
executable:     /usr/bin/gnome-shell
global_pid:     11485
kernel:         4.5.7-200.fc23.i686
package:        gnome-shell-3.18.5-1.fc23
reason:         gnome-shell killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 25 Jonas Ådahl 2016-08-18 08:29:02 UTC
The bug was fixed upstream (in 3.21.2), so can we close this?


Note You need to log in before you can comment on or make changes to this bug.