Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1219430 - MDRaidError: No name found for the node 'md126p1'
Summary: MDRaidError: No name found for the node 'md126p1'
Keywords:
Status: CLOSED DUPLICATE of bug 1160424
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 22
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:c6983a606c18e4f698485da4a86...
Depends On:
Blocks: F22FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2015-05-07 10:30 UTC by Petr Schindler
Modified: 2015-05-11 16:31 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-11 16:31:53 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
File: anaconda-tb (692.12 KB, text/plain)
2015-05-07 10:30 UTC, Petr Schindler
no flags Details
File: anaconda.log (9.08 KB, text/plain)
2015-05-07 10:30 UTC, Petr Schindler
no flags Details
File: environ (571 bytes, text/plain)
2015-05-07 10:30 UTC, Petr Schindler
no flags Details
File: journalctl (352.57 KB, text/plain)
2015-05-07 10:30 UTC, Petr Schindler
no flags Details
File: lsblk_output (8.20 KB, text/plain)
2015-05-07 10:30 UTC, Petr Schindler
no flags Details
File: nmcli_dev_list (1.47 KB, text/plain)
2015-05-07 10:30 UTC, Petr Schindler
no flags Details
File: os_info (463 bytes, text/plain)
2015-05-07 10:30 UTC, Petr Schindler
no flags Details
File: program.log (58.28 KB, text/plain)
2015-05-07 10:30 UTC, Petr Schindler
no flags Details
File: storage.log (235.02 KB, text/plain)
2015-05-07 10:30 UTC, Petr Schindler
no flags Details
File: ifcfg.log (2.11 KB, text/plain)
2015-05-07 10:30 UTC, Petr Schindler
no flags Details

Description Petr Schindler 2015-05-07 10:30:20 UTC
Description of problem:
This crash occured on Final TC2 Live Workstation right after anaconda started. There is firmware raid on this machine (three disks are used in raid0).

Version-Release number of selected component:
anaconda-core-22.20.11-1.fc22.x86_64

The following was filed automatically by anaconda:
anaconda 22.20.11-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/gi/overrides/BlockDev.py", line 384, in wrapped
    raise transform[1](msg)
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 908, in addUdevPartitionDevice
    name = blockdev.md.name_from_node(name)
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 1224, in addUdevDevice
    device = self.addUdevPartitionDevice(info)
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 2193, in _populate
    self.addUdevDevice(dev)
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 2127, in populate
    self._populate()
  File "/usr/lib/python2.7/site-packages/blivet/blivet.py", line 277, in reset
    self.devicetree.populate(cleanupOnly=cleanupOnly)
  File "/usr/lib/python2.7/site-packages/blivet/osinstall.py", line 1116, in storageInitialize
    storage.reset()
  File "/usr/lib64/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 244, in run
    threading.Thread.run(self, *args, **kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 115, in wait
    self.raise_if_error(name)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/__init__.py", line 1210, in _runThread
    threadMgr.wait(THREAD_STORAGE)
  File "/usr/lib64/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 244, in run
    threading.Thread.run(self, *args, **kwargs)
MDRaidError: No name found for the node 'md126p1'

Additional info:
cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=/isolinux/vmlinuz0 root=live:LABEL=Fedora-Live-WS-x86_64-22-T2 ro rd.live.image quiet rhgb rd.live.check
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.0.1-300.fc22.x86_64
other involved packages: python-blivet-1.0.8-1.fc22.noarch, python-libs-2.7.9-6.fc22.x86_64, libblockdev-0.12-1.fc22.x86_64
product:        Fedora
release:        Fedora release 22 (Twenty Two)
type:           anaconda
version:        22

Comment 1 Petr Schindler 2015-05-07 10:30:25 UTC
Created attachment 1023039 [details]
File: anaconda-tb

Comment 2 Petr Schindler 2015-05-07 10:30:27 UTC
Created attachment 1023040 [details]
File: anaconda.log

Comment 3 Petr Schindler 2015-05-07 10:30:28 UTC
Created attachment 1023041 [details]
File: environ

Comment 4 Petr Schindler 2015-05-07 10:30:31 UTC
Created attachment 1023042 [details]
File: journalctl

Comment 5 Petr Schindler 2015-05-07 10:30:33 UTC
Created attachment 1023043 [details]
File: lsblk_output

Comment 6 Petr Schindler 2015-05-07 10:30:34 UTC
Created attachment 1023044 [details]
File: nmcli_dev_list

Comment 7 Petr Schindler 2015-05-07 10:30:35 UTC
Created attachment 1023045 [details]
File: os_info

Comment 8 Petr Schindler 2015-05-07 10:30:37 UTC
Created attachment 1023046 [details]
File: program.log

Comment 9 Petr Schindler 2015-05-07 10:30:40 UTC
Created attachment 1023047 [details]
File: storage.log

Comment 10 Petr Schindler 2015-05-07 10:30:41 UTC
Created attachment 1023048 [details]
File: ifcfg.log

Comment 11 Petr Schindler 2015-05-07 10:51:13 UTC
I propose this as Final blocker. It violates criterion: "The installer must be able to detect and install to hardware or firmware RAID storage devices." And maybe more proper alpha criterion: "The installer must run when launched normally from the release-blocking images."

Comment 12 Adam Williamson 2015-05-11 16:31:53 UTC

*** This bug has been marked as a duplicate of bug 1160424 ***


Note You need to log in before you can comment on or make changes to this bug.