Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at
Bug 1222011 - [UX] missing download progressbar
Summary: [UX] missing download progressbar
Status: CLOSED DUPLICATE of bug 1161950
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 22
Hardware: Unspecified
OS: Unspecified
Target Milestone: ---
Assignee: Michal Luscon
QA Contact: Fedora Extras Quality Assurance
Depends On:
TreeView+ depends on / blocked
Reported: 2015-05-15 13:10 UTC by Elad Alfassa
Modified: 2015-07-22 12:48 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2015-07-22 12:48:55 UTC
Type: Bug

Attachments (Terms of Use)

Description Elad Alfassa 2015-05-15 13:10:50 UTC
If I try to install a package from a URL, dnf just hangs. It used to work fine with yum.

To reproduce, simply type the following command:
dnf install

It will hang forever.

Comment 1 Honza Silhan 2015-05-18 12:11:41 UTC
I can't reproduce it. With your package I have unsatisfied dependencies (package was downloaded fine and then the depsolver reports error). With different package without dependencies it was installed properly. Do you have multiple instances of DNF running? Can you still reproduce it? The other packages not specified by URL can be installed?

Comment 2 Elad Alfassa 2015-05-18 12:17:27 UTC
I did wget to download the package and then dnf install ./firefox-38.0-4.fc22.x86_64.rpm and it worked.

Your questions about dependencies don't seem to be relevant because dnf hangs before it even resolves dependencies...

[root@rincewind ~]# dnf -v -d 9 install
cachedir: /var/cache/dnf/x86_64/22
Loaded plugins: kickstart, noroot, needs-restarting, protected_packages, generate_completion_cache, reposync, builddep, migrate, download, copr, playground, config-manager, Query, debuginfo-install
DNF version: 1.0.0
repo: using cache for: updates-testing
repo: using cache for: google-talkplugin
not found deltainfo for: google-talkplugin
not found updateinfo for: google-talkplugin
repo: using cache for: fedora
not found deltainfo for: Fedora 22 - x86_64
not found updateinfo for: Fedora 22 - x86_64
repo: using cache for: adobe-linux-x86_64
not found deltainfo for: Adobe Systems Incorporated
not found updateinfo for: Adobe Systems Incorporated
repo: using cache for: updates
not found updateinfo for: Fedora 22 - x86_64 - Updates
updates-testing: using metadata from Mon May 18 14:27:05 2015.
google-talkplugin: using metadata from Sun May 17 11:07:20 2015.
fedora: using metadata from Sun May 17 11:19:52 2015.
adobe-linux-x86_64: using metadata from Sun May 17 11:20:15 2015.
updates: using metadata from Mon May 18 14:27:07 2015.
Last metadata expiration check performed 0:49:04 ago on Mon May 18 14:27:07 2015.

And then it hangs. There are no multiple copies of dnf running or anything like this.

dnf 1.0.0
  Installed: dnf-0:1.0.0-1.fc22.noarch at 2015-05-06 07:19
  Built    : Fedora Project at 2015-05-02 13:00

  Installed: rpm-0: at 2015-04-17 12:27
  Built    : Fedora Project at 2015-04-15 09:21

Comment 3 Parag Nemade 2015-05-18 13:17:01 UTC
+1 to what Elad said above. I am having the same problem and able to reproduce this successfully. Please ask if needed any further input.

Comment 4 Parag Nemade 2015-05-18 13:51:00 UTC
Looks like I was a bit impatient while testing this bug. I tried for 3 minutes only. Now tried till it gives something and I got the dependency resolution to installation prompt. That took 5-7 minutes. I then said no and executed same command but it again stopped at same step and then package appeared for installation after 5 minutes. 

Once resolved and cancelled transaction, repeating should be quick right? like within a minute to install the packages. 

Not sure if this is a real bug....

Comment 5 Michal Luscon 2015-05-18 15:44:34 UTC
It looks like the only issue here is missing download progress bar.

Comment 6 Elad Alfassa 2015-05-18 15:47:18 UTC
(In reply to Michal Luscon from comment #5)
> It looks like the only issue here is missing download progress bar.

This would mean dnf is much slower than wget when downloading a file... downloading this with wget took less than half a minute... so this sounds unlikely.

Comment 7 Michal Luscon 2015-05-18 15:53:45 UTC
Could you please then repeat the installation with LIBREPO_DEBUG variable set to 1?

Comment 8 Elad Alfassa 2015-05-18 15:57:18 UTC
Is this a configuration variable or an environment variable? I tried it as environment variable and the output was the same...

Comment 9 Michal Luscon 2015-05-18 16:01:54 UTC
You can set it by "export LIBREPO_DEBUG=1".

Comment 10 Elad Alfassa 2015-05-18 16:05:52 UTC
You were right, it is downloading, according to this debug output. I guess the reason I thought it was frozen was because it didn't react to control-c and didn't display any graphical indication.

Comment 11 Radek Holy 2015-07-22 12:48:37 UTC
IIUIC, this is a duplicate of the bug 1161950.

Comment 12 Radek Holy 2015-07-22 12:48:55 UTC

*** This bug has been marked as a duplicate of bug 1161950 ***

Note You need to log in before you can comment on or make changes to this bug.