Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1225118 - %autosetup macro erroneously includes the line that follows it
Summary: %autosetup macro erroneously includes the line that follows it
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rpm
Version: 7.3
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Florian Festi
QA Contact: Karel Srot
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-26 15:39 UTC by Tadej Janež
Modified: 2015-11-19 11:58 UTC (History)
3 users (show)

Fixed In Version: rpm-4.11.3-16.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-19 11:58:42 UTC
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)
Failed build.log for package bup (1.35 KB, application/x-gzip)
2015-05-26 15:39 UTC, Tadej Janež
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2138 0 normal SHIPPED_LIVE rpm bug fix and enhancement update 2015-11-19 10:39:52 UTC

Description Tadej Janež 2015-05-26 15:39:40 UTC
Created attachment 1030005 [details]
Failed build.log for package bup

Description of problem:
I'm using the %autosetup macro to automatically apply patches included in the SPEC file: https://github.com/tjanez/bup-package/blob/b195a10a7840ae756b07d0955333b726451887b6/bup.spec#L76

When building my package for EPEL 7 (and Fedora 20), the build step fails since %autosetup also tries to include the line that follows it in the SPEC file (https://github.com/tjanez/bup-package/blob/b195a10a7840ae756b07d0955333b726451887b6/bup.spec#L77) when applying the patches:

+ /usr/bin/git commit -q -a -m 0005-Remove-support-for-par2-due-to-issues-with-the-versi.patch --author 'rpm-build <rpm-build>cp' /builddir/build/SOURCES/README.Fedora .
fatal: Paths with -a does not make sense.

For the complete build log, see the attached build.log.

How reproducible:
Always

Actual results:
%autosetup macro feeds the line that follows it in the SPEC file to its patch management program (git).

Expected results:
%autosetup macro shouldn't feed the line that follows it in the SPEC file to its patch management program (git).

Additional info:
The same SPEC file (or SRPM) builds fine on Fedora 21+ (see: https://copr-be.cloud.fedoraproject.org/results/tadej/bup/)

I found a work-around for this bug: If I insert an empty line after the %autosetup macro, it builds fine.

Comment 2 Florian Festi 2015-07-07 15:49:45 UTC
Fixed upstream a while ago as 1bdcd0500865efd3566efd7f951228f69b58e755
See also #1045723

Comment 10 errata-xmlrpc 2015-11-19 11:58:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2138.html


Note You need to log in before you can comment on or make changes to this bug.