Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1231736 - git-core is strangely split from git
Summary: git-core is strangely split from git
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: git
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Stodulka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1232464 1232715 1233377 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-15 10:24 UTC by Roman Kagan
Modified: 2015-06-23 09:11 UTC (History)
12 users (show)

Fixed In Version: git-2.4.3-3.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-23 09:11:27 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1233377 0 unspecified CLOSED file conflicts between git-2.4.3-2.fc22 and git-core-2.4.3-1.fc22 2022-05-16 11:32:56 UTC

Internal Links: 1233377

Description Roman Kagan 2015-06-15 10:24:03 UTC
Description of problem:

Fedora git package recently introduced git-core subpackage which is required by git.  OTOH the contents of both packages overlaps significantly, with most files provided by both packages, and docs duplicated in the corresponding doc directories.
Besides, the declared purpose of the split which, according to changelog, was to isolate git-core from perl dependencies, isn't achieved.


Version-Release number of selected component (if applicable):

git-2.4.3-1.fc22.x86_64
apparently introduced in 2.4.2-2.

Proof:

files in git only:
# LC_ALL=C comm -23 <(rpm -q git -l | LC_ALL=C sort) \
    <(rpm -q git-core -l | sed 's@\(/usr/share/doc/git\)-core@\1@' | LC_ALL=C sort) | wc -l
17

files in git-core:
# LC_ALL=C comm -13 <(rpm -q git -l | LC_ALL=C sort) \
    <(rpm -q git-core -l | sed 's@\(/usr/share/doc/git\)-core@\1@' | LC_ALL=C sort) | wc -l
548

files in both git and git-core:
# LC_ALL=C comm -12 <(rpm -q git -l | LC_ALL=C sort) \
    <(rpm -q git-core -l | sed 's@\(/usr/share/doc/git\)-core@\1@' | LC_ALL=C sort) | wc -l
752

git requires git-core:
# rpm -q git -R |fgrep git
git-core = 2.4.3-1.fc22

perl dependencies in git-core:
# rpm -q git-core -R |fgrep perl
/usr/bin/perl
perl(File::Basename)
perl(File::Find)
perl(File::Spec)
perl(Getopt::Long)
perl(strict)


I must admit that the whole -core split doesn't look justified, at least in its current state.

Comment 1 Petr Stodulka 2015-06-15 11:11:39 UTC
Hi Roman,
in version git-2.4.3-1 it was split wrong but it's old version. I got it and fix it since git-2.4.3-2. The older git shouldn't be built earlier and should be checked before this. However, no one else (I guess) check any changes and new builds were done for rebase of Perl and Git too.

Can you please check latest version, where git-core is split to git-core and git-core-doc? There it should be ok already.

Comment 2 Petr Stodulka 2015-06-15 11:47:09 UTC
Why is this commit in F22?!!!! I really push it only to rawhide and I see here my commit on both branches without any info about merge! Who do that?!!!

Comment 3 Petr Stodulka 2015-06-15 12:38:29 UTC
git-core will be obsoleted and provided by git again. This split can't be done in F22 due to some other packages which are dependent on git binary.

Comment 4 Fedora Update System 2015-06-15 13:41:14 UTC
git-2.4.3-2.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/git-2.4.3-2.fc22

Comment 5 Bruno Wolff III 2015-06-16 16:33:07 UTC
The obsoletes was done incorrecty.
git-core <= 2.4.3-1 will not obsolete git-core-2.4.3-1.f22 as 1.f22 > 1 .
You either need <= 2.4.3 or < 2.4.3-2 .

Comment 6 Gwyn Ciesla 2015-06-17 01:59:57 UTC
(In reply to pstodulk from comment #2)
> Why is this commit in F22?!!!! I really push it only to rawhide and I see
> here my commit on both branches without any info about merge! Who do that?!!!

It came with when I updated to 2.4.3.  I'm only updating 2.4.4 in rawhide at this time.  It wasn't aware that the git-core split was only intended for rawhide, it upgraded on my system without issue.

Comment 7 Petr Stodulka 2015-06-17 06:37:58 UTC
*** Bug 1232464 has been marked as a duplicate of this bug. ***

Comment 8 Petr Stodulka 2015-06-17 06:47:44 UTC
Jon: sigh... Yes it is. Do you read bugzillas for git? There is written that's planned since F23 [0].

Otherwise, packages in released fedora should never be rebased if there is not good reason for that. And anything like new subpackages and so, shouldn't be done hidden without any comments of changes in bodhi.

[0] https://bugzilla.redhat.com/show_bug.cgi?id=1161251

Comment 9 Petr Stodulka 2015-06-17 06:50:40 UTC
Bruno: Thanks for feedback. I apologize that I didn't test it due to missing F22 virtual machine. I installed it for testing now, so next build should be ok.

Comment 10 Gwyn Ciesla 2015-06-17 11:14:57 UTC
I don't, I'll check in the future.  I didn't see anything about it in the changelog so it didn't occur to me.  Do you plan to backport 2.4.4 to f22 once the Provides have been sorted out?

Comment 11 Petr Stodulka 2015-06-17 11:40:33 UTC
That's ok. Everyone does mistakes. I don't plan any other rebases in f22 for git. v2.4.3 should be kept in F22 during lifecycle.

Comment 12 Petr Stodulka 2015-06-18 07:23:55 UTC
*** Bug 1232715 has been marked as a duplicate of this bug. ***

Comment 13 Radek Holy 2015-06-19 08:20:22 UTC
*** Bug 1233377 has been marked as a duplicate of this bug. ***

Comment 14 Fedora Update System 2015-06-21 00:23:47 UTC
Package git-2.4.3-3.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing git-2.4.3-3.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-10067/git-2.4.3-3.fc22
then log in and leave karma (feedback).

Comment 15 Fedora Update System 2015-06-23 09:11:27 UTC
git-2.4.3-3.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.