Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1250268 - boost 1.58 uses wrong CFLAGS on aarch64 and hence is FTBFS
Summary: boost 1.58 uses wrong CFLAGS on aarch64 and hence is FTBFS
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: boost
Version: rawhide
Hardware: aarch64
OS: Unspecified
urgent
urgent
Target Milestone: ---
Assignee: Jonathan Wakely
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: ARM64, F-ExcludeArch-aarch64
TreeView+ depends on / blocked
 
Reported: 2015-08-04 23:12 UTC by Peter Robinson
Modified: 2015-08-05 16:45 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-05 16:45:50 UTC
Type: Bug


Attachments (Terms of Use)

Description Peter Robinson 2015-08-04 23:12:39 UTC
http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=3114086

The key with this error is "unrecognized command line option '-m64'" but that tells me that boost isn't actually using the proper distro CFLAG options because if it was it was it would not fail as the distro flags automatically provide the optimal flags for each architecture

gcc.compile.c++ serial/boost/bin.v2/libs/atomic/build/gcc-5.1.1/release/debug-symbols-on/pch-off/python-2.7/threading-multi/lockpool.o
    "g++"  -g -O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -fno-strict-aliasing -pthread -fPIC -m64  -DBOOST_ALL_NO_LIB=1 -DBOOST_ATOMIC_DYN_LINK=1 -DBOOST_ATOMIC_SOURCE -DNDEBUG  -I"." -c -o "serial/boost/bin.v2/libs/atomic/build/gcc-5.1.1/release/debug-symbols-on/pch-off/python-2.7/threading-multi/lockpool.o" "libs/atomic/src/lockpool.cpp"
cc1plus: error: unrecognized command line option '-m64'

Comment 1 Jonathan Wakely 2015-08-05 12:38:24 UTC
This should be fixed already in boost-1.58.0-4.fc24, could you try another build please?

Comment 2 Jonathan Wakely 2015-08-05 14:40:50 UTC
The problem is not that boost isn't using the distro CFLAGS, it is using them, but that Boost's own build system adds additional flags to the compiler commands, and for GCC it always adds either -m32 or -m64. The latest versions in f23 and rawhide has a patch to prevent that being added.

Comment 3 Peter Robinson 2015-08-05 14:49:31 UTC
OK, koji-shadow builds in order so I'm going to have to spend time to override that process

Comment 4 Peter Robinson 2015-08-05 16:45:50 UTC
OK, built now


Note You need to log in before you can comment on or make changes to this bug.