Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1251422 - Invalid -march=native for gcc on ppc/s390
Summary: Invalid -march=native for gcc on ppc/s390
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: atanks
Version: 22
Hardware: ppc64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Gwyn Ciesla
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: ZedoraTracker PPCTracker ARM64, F-ExcludeArch-aarch64 F-ExcludeArch-ppc64le, PPC64LETracker
TreeView+ depends on / blocked
 
Reported: 2015-08-07 09:35 UTC by Rafael Fonseca
Modified: 2015-10-11 16:03 UTC (History)
2 users (show)

Fixed In Version: atanks-6.3-3.fc23
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-10-11 16:03:27 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
patch + spec changeset (deleted)
2015-09-24 09:51 UTC, Marcin Juszkiewicz
no flags Details | Diff

Description Rafael Fonseca 2015-08-07 09:35:33 UTC
Description of problem: atanks fails to build on ppc and s390 because '-march=native' is not a valid flag for gcc on these platforms.


Version-Release number of selected component (if applicable): 6.3-1


How reproducible: try to koji-build atanks on ppc64/s390x


Actual results: g++ fails with the following errors:

PPC: # make
Compiling obj/network.o
/usr/lib64/ccache/g++ -DDATA_DIR=\"/usr/share/games/atanks\" -DLINUX -DVERSION=\"6.3\" -DNETWORK -I/usr/include -march=native -Wall -Wextra -Wpedantic -std=c++11 -pthread -O2 -o obj/network.o -c src/network.cpp
g++: error: unrecognized command line option ‘-march=native’
Makefile:284: recipe for target 'obj/network.o' failed
make: *** [obj/network.o] Error 1

S390x: # g++ -march=native
g++: error: unrecognized argument in option ‘-march=native’
g++: note: valid arguments to ‘-march=’ are: g5 g6 z10 z196 z9-109 z9-ec z900 z990 zEC12
g++: fatal error: no input files
compilation terminated.

Comment 1 Marcin Juszkiewicz 2015-09-24 09:50:47 UTC
also on aarch64

Comment 2 Marcin Juszkiewicz 2015-09-24 09:51:53 UTC
Created attachment 1076426 [details]
patch + spec changeset

This fixes issue.

Comment 3 Marcin Juszkiewicz 2015-10-01 11:15:20 UTC
pushed to rawhide

Comment 4 Fedora Update System 2015-10-08 10:07:30 UTC
atanks-6.3-3.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-69de455c28

Comment 5 Fedora Update System 2015-10-09 13:56:03 UTC
atanks-6.3-3.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update atanks'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-69de455c28

Comment 6 Fedora Update System 2015-10-11 16:03:26 UTC
atanks-6.3-3.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.