Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at
Bug 1282254 - r8169 randomly drops ethernet connection
Summary: r8169 randomly drops ethernet connection
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 23
Hardware: x86_64
OS: Linux
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
Depends On:
TreeView+ depends on / blocked
Reported: 2015-11-15 19:50 UTC by verslyap
Modified: 2020-06-09 02:16 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2016-10-26 16:47:22 UTC
Type: Bug
verslyap: needinfo-

Attachments (Terms of Use)

Description verslyap 2015-11-15 19:50:04 UTC
Description of problem:
When using the wired Ethernet network connection on my rtl8111/8168/8411 ethernet, the connection will randomly drop.  When I check the interface with ifconfig, it shows that it still has an ip address, etc.

The connection comes back when I disable and renable it in Network Manager, but only momentarily.

Version-Release number of selected component (if applicable):
Fedora 23

How reproducible:
Every time

Steps to Reproduce:
1. Boot into Fedora 23 with rtl8111/8168/8411 ethernet device
2. Start to use network

Actual results:
Being able to communicate with other devices on internet and local network

Expected results:
No such communication

Additional info:
It looks like there are a number of other bugs with this device from older versions of Fedora.

Let me know if you need me to run any output from my computer

Comment 1 verslyap 2015-11-16 03:03:31 UTC
Some more information.  I stopped NetworkManager and still had the issue.  Had to do an ifconfig down then up to get it to work again, but it only worked temporarily.

I downloaded the rpms for the rawhide kernel, and that didn't correct anything either.

Comment 2 Christian Stadelmann 2015-11-26 19:21:27 UTC
Same here, same hardware. Happens especially often on suspend+resume, but not limited to that. Sometimes the kernel seems to recover itself after some 10…30 seconds, sometimes it doesn't. Happens ca. once per 10 hours running fedora and ca. each second time I suspend (to ram). This is no recent regression but has been there for about 3 months.

# rmmod r8169
# modprobe r8169
helps as a workaround too.

In dmesg I see this error message, can you confirm seeing it?

ACPI: \_SB_.PCI0.SBRG.ASOC: Device cannot be configured due to a frequency mismatch

Nothing of obvious interest there in dmesg and journal except from this line.

I am running a 4.2.6-300.fc23.x86_64 kernel.

$ lspci -vv -k
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 06)
	Subsystem: ASUSTeK Computer Inc. P8P67 and other motherboards
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx+
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0, Cache Line Size: 32 bytes
	Interrupt: pin A routed to IRQ 31
	Region 0: I/O ports at d800 [size=256]
	Region 2: Memory at f6fff000 (64-bit, prefetchable) [size=4K]
	Region 4: Memory at f6ff8000 (64-bit, prefetchable) [size=16K]
	Expansion ROM at f7ee0000 [disabled] [size=128K]
	Capabilities: <access denied>
	Kernel driver in use: r8169
	Kernel modules: r8169

Also, on every boot these messages are printed by kernel (see dmesg and journal):

[   12.334073] ACPI Warning: SystemIO range 0x0000000000000828-0x000000000000082F conflicts with OpRegion 0x0000000000000800-0x000000000000084F (\PMRG) (20150619/utaddress-254)
[   12.334081] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[   12.334085] ACPI Warning: SystemIO range 0x0000000000000540-0x000000000000054F conflicts with OpRegion 0x0000000000000500-0x000000000000054F (\_SB_.PCI0.SBRG.ASOC.GPS1) (20150619/utaddress-254)
[   12.334089] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[   12.334091] ACPI Warning: SystemIO range 0x0000000000000530-0x000000000000053F conflicts with OpRegion 0x0000000000000500-0x000000000000053F (\GPS0) (20150619/utaddress-254)
[   12.334094] ACPI Warning: SystemIO range 0x0000000000000530-0x000000000000053F conflicts with OpRegion 0x0000000000000500-0x000000000000054F (\_SB_.PCI0.SBRG.ASOC.GPS1) (20150619/utaddress-254)
[   12.334098] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[   12.334099] ACPI Warning: SystemIO range 0x0000000000000500-0x000000000000052F conflicts with OpRegion 0x0000000000000500-0x000000000000053F (\GPS0) (20150619/utaddress-254)
[   12.334102] ACPI Warning: SystemIO range 0x0000000000000500-0x000000000000052F conflicts with OpRegion 0x0000000000000500-0x000000000000054F (\_SB_.PCI0.SBRG.ASOC.GPS1) (20150619/utaddress-254)
[   12.334106] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[   12.334107] lpc_ich: Resource conflict(s) found affecting gpio_ich
[   12.392070] ACPI Warning: SystemIO range 0x0000000000000400-0x000000000000041F conflicts with OpRegion 0x0000000000000400-0x000000000000040F (\SMRG) (20150619/utaddress-254)
[   12.392078] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver

Comment 3 verslyap 2015-12-07 01:26:05 UTC
I was able to get regular ethernet service without it dropping out.  The issue is probably the result of a bug in the linux kernel, as other OSes work fine, but it's probably a result as another piece of hardware on my network.

I use a dd-wrt v24sp2 router configured as a client bridge.  This is the most recent version of dd-wrt that my router can run, but it has a known issue where it doesn't forward multicasts.  When I did a workaround for this issue, this nic doesn't drop it's connect at random anymore.

Now, my NAS and windows box worked just fine when connected to the bridge, so I think Fedora 23 isn't handling something correctly, but it may be the result of this other issue.

Comment 4 Christian Stadelmann 2015-12-07 15:37:27 UTC
I don't have a dd-wrt but an AVM Fritz!Box with its latest software available. Both share some code basis.

The AVM Fritz!OS has not recently been updated. It looks like this is an issue specific to the linux kernel. I have rarely seen this issue for months but very often only since some weeks. Looking at there some recent changes to the kernel module.

There has been a sleep-related code fix some weeks ago:

Maybe you could try to bisect. I can't do that right now.

Comment 5 Christian Stadelmann 2016-03-25 13:00:45 UTC
Probably a duplicate of bug #1312006

Comment 6 Laura Abbott 2016-09-23 19:31:25 UTC
*********** MASS BUG UPDATE **************
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 23 kernel bugs.
Fedora 23 has now been rebased to 4.7.4-100.fc23.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
If you have moved on to Fedora 24 or 25, and are still experiencing this issue, please change the version to Fedora 24 or 25.
If you experience different issues, please open a new bug report for those.

Comment 7 Laura Abbott 2016-10-26 16:47:22 UTC
*********** MASS BUG UPDATE **************
This bug is being closed with INSUFFICIENT_DATA as there has not been a response in 4 weeks. If you are still experiencing this issue, please reopen and attach the relevant data from the latest kernel you are running and any data that might have been requested previously.

Note You need to log in before you can comment on or make changes to this bug.