Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1292876 - [abrt] nautilus: wl_proxy_marshal_array_constructor(): nautilus killed by SIGABRT
Summary: [abrt] nautilus: wl_proxy_marshal_array_constructor(): nautilus killed by SIG...
Keywords:
Status: CLOSED DUPLICATE of bug 1288287
Alias: None
Product: Fedora
Classification: Fedora
Component: file-roller
Version: 23
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:5b824e2bcde3a4c1bf5fe759d97...
Depends On:
Blocks: WaylandRelated
TreeView+ depends on / blocked
 
Reported: 2015-12-18 15:55 UTC by Christian Stadelmann
Modified: 2016-09-01 02:03 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-01 02:03:14 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
File: backtrace (deleted)
2015-12-18 15:55 UTC, Christian Stadelmann
no flags Details
File: core_backtrace (deleted)
2015-12-18 15:55 UTC, Christian Stadelmann
no flags Details
File: dso_list (deleted)
2015-12-18 15:55 UTC, Christian Stadelmann
no flags Details
File: limits (deleted)
2015-12-18 15:55 UTC, Christian Stadelmann
no flags Details
File: maps (deleted)
2015-12-18 15:55 UTC, Christian Stadelmann
no flags Details
File: namespaces (deleted)
2015-12-18 15:55 UTC, Christian Stadelmann
no flags Details
File: open_fds (deleted)
2015-12-18 15:55 UTC, Christian Stadelmann
no flags Details
File: proc_pid_status (deleted)
2015-12-18 15:55 UTC, Christian Stadelmann
no flags Details


Links
System ID Private Priority Status Summary Last Updated
GNOME Bugzilla 763298 0 None None None 2016-03-08 09:41:07 UTC

Description Christian Stadelmann 2015-12-18 15:55:12 UTC
Version-Release number of selected component:
nautilus-3.18.3-1.fc23

Additional info:
reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        /usr/bin/nautilus --gapplication-service
crash_function: wl_proxy_marshal_array_constructor
executable:     /usr/bin/nautilus
kernel:         4.2.7-300.fc23.x86_64
runlevel:       N 5
type:           CCpp

Truncated backtrace:
Thread no. 1 (6 frames)
 #2 wl_proxy_marshal_array_constructor at src/wayland-client.c:602
 #3 wl_proxy_marshal at src/wayland-client.c:648
 #4 _gdk_wayland_window_drag_begin at /usr/include/wayland-client-protocol.h:999
 #6 gtk_drag_begin_internal at gtkdnd.c:2467
 #7 gtk_drag_begin_with_coordinates at gtkdnd.c:2637
 #8 on_motion_notify_event at gtkplacessidebar.c:1521

Comment 1 Christian Stadelmann 2015-12-18 15:55:17 UTC
Created attachment 1107206 [details]
File: backtrace

Comment 2 Christian Stadelmann 2015-12-18 15:55:19 UTC
Created attachment 1107207 [details]
File: core_backtrace

Comment 3 Christian Stadelmann 2015-12-18 15:55:21 UTC
Created attachment 1107208 [details]
File: dso_list

Comment 4 Christian Stadelmann 2015-12-18 15:55:22 UTC
Created attachment 1107209 [details]
File: limits

Comment 5 Christian Stadelmann 2015-12-18 15:55:24 UTC
Created attachment 1107210 [details]
File: maps

Comment 6 Christian Stadelmann 2015-12-18 15:55:26 UTC
Created attachment 1107211 [details]
File: namespaces

Comment 7 Christian Stadelmann 2015-12-18 15:55:27 UTC
Created attachment 1107212 [details]
File: open_fds

Comment 8 Christian Stadelmann 2015-12-18 15:55:28 UTC
Created attachment 1107213 [details]
File: proc_pid_status

Comment 9 Christian Stadelmann 2016-01-26 14:09:04 UTC
Another user experienced a similar problem:

This issue seems to be reproduced following these steps:
0. use a gnome/wayland session (I don't know whether that is required)
1. open nautilus
2. open an archive with file-roller
3. drag and drop a folder from file-roller into nautilus

What happens:
Nothing. 

What should happen:
copy files

When closing nautilus or file-roller very quickly after 3., nautilus crashes, which lead to this bug report.

reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        /usr/bin/nautilus --gapplication-service
crash_function: wl_proxy_marshal_array_constructor
executable:     /usr/bin/nautilus
kernel:         4.3.4-300.fc23.x86_64
package:        nautilus-3.18.4-1.fc23
reason:         nautilus killed by SIGABRT
runlevel:       N 5
type:           CCpp

Comment 10 Matthias Clasen 2016-09-01 02:03:14 UTC

*** This bug has been marked as a duplicate of bug 1288287 ***


Note You need to log in before you can comment on or make changes to this bug.