Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1316816 - OSError: Unable to create group : status=3
Summary: OSError: Unable to create group : status=3
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 24
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: David Shea
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:f346d3462ef37a4a6c1b200ea74...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-11 08:25 UTC by Daniel Mach
Modified: 2016-05-05 18:50 UTC (History)
7 users (show)

Fixed In Version: anaconda-24.13.3-1 anaconda-24.13.3-1.fc24
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-04-06 14:06:22 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
File: anaconda-tb (3.21 MB, text/plain)
2016-03-11 08:25 UTC, Daniel Mach
no flags Details
File: anaconda.log (205.72 KB, text/plain)
2016-03-11 08:25 UTC, Daniel Mach
no flags Details
File: dnf.log (3.18 KB, text/plain)
2016-03-11 08:25 UTC, Daniel Mach
no flags Details
File: dnf.rpm.log (36.72 KB, text/plain)
2016-03-11 08:25 UTC, Daniel Mach
no flags Details
File: environ (459 bytes, text/plain)
2016-03-11 08:25 UTC, Daniel Mach
no flags Details
File: lsblk_output (1.49 KB, text/plain)
2016-03-11 08:25 UTC, Daniel Mach
no flags Details
File: lvm.log (1.19 MB, text/plain)
2016-03-11 08:25 UTC, Daniel Mach
no flags Details
File: nmcli_dev_list (1.82 KB, text/plain)
2016-03-11 08:26 UTC, Daniel Mach
no flags Details
File: os_info (449 bytes, text/plain)
2016-03-11 08:26 UTC, Daniel Mach
no flags Details
File: storage.log (155.79 KB, text/plain)
2016-03-11 08:26 UTC, Daniel Mach
no flags Details
File: syslog (1.32 MB, text/plain)
2016-03-11 08:26 UTC, Daniel Mach
no flags Details
File: ifcfg.log (1.87 KB, text/plain)
2016-03-11 08:26 UTC, Daniel Mach
no flags Details
File: packaging.log (45.23 KB, text/plain)
2016-03-11 08:26 UTC, Daniel Mach
no flags Details
File: program.log (111.23 KB, application/octet-stream)
2016-03-11 08:26 UTC, Daniel Mach
no flags Details

Description Daniel Mach 2016-03-11 08:25:24 UTC
Version-Release number of selected component:
anaconda-24.13-1

The following was filed automatically by anaconda:
anaconda 24.13-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python3.5/site-packages/pyanaconda/users.py", line 231, in createGroup
    raise OSError("Unable to create group %s: status=%s" % (group_name, status))
  File "/usr/lib64/python3.5/site-packages/pyanaconda/users.py", line 306, in createUser
    self.createGroup(group_name, gid=gid, root=root)
  File "/usr/lib64/python3.5/site-packages/pyanaconda/kickstart.py", line 1755, in execute
    if not users.createUser(usr.name, **kwargs):
  File "/usr/lib64/python3.5/site-packages/pyanaconda/install.py", line 96, in doConfiguration
    ksdata.user.execute(storage, ksdata, instClass, u)
  File "/usr/lib64/python3.5/threading.py", line 862, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib64/python3.5/site-packages/pyanaconda/threads.py", line 253, in run
    threading.Thread.run(self, *args, **kwargs)
OSError: Unable to create group : status=3

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/bin/python3  /sbin/anaconda
cmdline_file:   inst.repo=nfs:nfs.englab.brq.redhat.com:/pub/fedora/linux/development/24/Everything/x86_64/os/ initrd=Fedora/24/latest/x86_64/initrd.img BOOT_IMAGE=Fedora/24/latest/x86_64/vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.5.0-0.rc7.git0.2.fc24.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        24

Comment 1 Daniel Mach 2016-03-11 08:25:43 UTC
Created attachment 1135139 [details]
File: anaconda-tb

Comment 2 Daniel Mach 2016-03-11 08:25:46 UTC
Created attachment 1135140 [details]
File: anaconda.log

Comment 3 Daniel Mach 2016-03-11 08:25:47 UTC
Created attachment 1135141 [details]
File: dnf.log

Comment 4 Daniel Mach 2016-03-11 08:25:49 UTC
Created attachment 1135142 [details]
File: dnf.rpm.log

Comment 5 Daniel Mach 2016-03-11 08:25:50 UTC
Created attachment 1135143 [details]
File: environ

Comment 6 Daniel Mach 2016-03-11 08:25:52 UTC
Created attachment 1135144 [details]
File: lsblk_output

Comment 7 Daniel Mach 2016-03-11 08:25:58 UTC
Created attachment 1135145 [details]
File: lvm.log

Comment 8 Daniel Mach 2016-03-11 08:26:00 UTC
Created attachment 1135146 [details]
File: nmcli_dev_list

Comment 9 Daniel Mach 2016-03-11 08:26:01 UTC
Created attachment 1135147 [details]
File: os_info

Comment 10 Daniel Mach 2016-03-11 08:26:04 UTC
Created attachment 1135148 [details]
File: storage.log

Comment 11 Daniel Mach 2016-03-11 08:26:12 UTC
Created attachment 1135149 [details]
File: syslog

Comment 12 Daniel Mach 2016-03-11 08:26:13 UTC
Created attachment 1135150 [details]
File: ifcfg.log

Comment 13 Daniel Mach 2016-03-11 08:26:16 UTC
Created attachment 1135151 [details]
File: packaging.log

Comment 14 Daniel Mach 2016-03-11 08:26:18 UTC
Created attachment 1135152 [details]
File: program.log

Comment 15 David Shea 2016-03-23 20:41:27 UTC
What steps did you take to hit this error? Specifically, what actions did you take in the user spoke?

Comment 16 Daniel Mach 2016-03-24 09:05:42 UTC
I think I only opened the user spoke and closed it without making any changes.
I don't remember exactly.

Comment 17 David Shea 2016-03-24 13:43:13 UTC
I see. This is reproducible by opening the advanced settings dialog and not entering anything in the groups field.

Comment 19 Mike McCune 2016-03-28 22:31:02 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune with any questions

Comment 20 trr 2016-03-30 10:56:47 UTC
Similar problem has been detected:

During installing fedora 24 alpha on "Creaing user" step.

addons:         com_redhat_kdump
cmdline:        /usr/bin/python3  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-WS-dvd-x86_64-24 quiet
hashmarkername: anaconda
kernel:         4.5.0-0.rc7.git0.2.fc24.x86_64
package:        anaconda-24.13-1
product:        Fedora
reason:         OSError: Unable to create group : status=3
release:        Cannot get release name.
version:        24

Comment 21 Fedora Update System 2016-04-04 21:25:23 UTC
anaconda-24.13.3-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-cd26edfec7

Comment 22 Fedora Update System 2016-04-05 19:21:59 UTC
anaconda-24.13.3-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-cd26edfec7

Comment 23 Fedora Update System 2016-04-06 14:06:01 UTC
anaconda-24.13.3-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 24 Yury Remishevsky 2016-05-05 18:50:46 UTC
*** Bug 1333536 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.