Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at
Bug 1318615 - gnome-initial-setup crashes after choosing a language
Summary: gnome-initial-setup crashes after choosing a language
Status: CLOSED DUPLICATE of bug 1350873
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-initial-setup
Version: 24
Hardware: Unspecified
OS: Unspecified
Target Milestone: ---
Assignee: Rui Matos
QA Contact: Fedora Extras Quality Assurance
Whiteboard: RejectedBlocker AcceptedFreezeException
Depends On:
Blocks: F24AlphaFreezeException
TreeView+ depends on / blocked
Reported: 2016-03-17 11:12 UTC by Petr Schindler
Modified: 2016-06-28 15:32 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2016-06-28 15:32:53 UTC
Type: Bug

Attachments (Terms of Use)
output of journalctl -f during the crash (8.49 KB, text/plain)
2016-03-17 11:13 UTC, Petr Schindler
no flags Details

System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1350873 0 unspecified CLOSED [abrt] gnome-initial-setup: g_time_zone_ref(): gnome-initial-setup killed by SIGSEGV 2022-05-16 11:32:56 UTC

Internal Links: 1350873

Description Petr Schindler 2016-03-17 11:12:30 UTC
Description of problem:
Probably due to the changes in locales in Fedora the g-i-s crashes when I choose language. The language I chose is selected after restart.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install system from livecd (I installed it in Czech language) and don't create an user in anaconda
2. Boot the installed system to gnome-initial-setup
3. Choose some language

Actual results:
g-i-s crashes

Expected results:
language changed and g-i-s still works

Additional info:
I propose this as an alpha blocker as it violates the criterion: "A system installed with a release-blocking desktop must boot to a log in screen where it is possible to log in to a working desktop using a user account created during installation or a 'first boot' utility."

The g-i-s works when user doesn't change language. User can even change the keyboard without crashig g-i-s.

Comment 1 Petr Schindler 2016-03-17 11:13:15 UTC
Created attachment 1137347 [details]
output of journalctl -f during the crash

Comment 2 Adam Williamson 2016-03-18 00:57:40 UTC
Discussed at 2016-03-17 Go/No-Go meeting, acting as a blocker review meeting: . Rejected as an Alpha blocker; we agreed this is a conditional violation of the criteria but too narrow to qualify as an Alpha blocker, it requires you to both not create a user in anaconda *and* change the language in g-i-s, we thought for an Alpha, that's too narrow.

By an oversight we didn't consider it for FE status, but I'm nominating it for that now. It could also be re-proposed as a blocker for a later milestone if a fix doesn't show up soon.

Comment 3 Michael Catanzaro 2016-03-18 02:06:39 UTC
Could someone post a backtrace please?

Comment 4 Adam Williamson 2016-03-18 05:16:27 UTC
Hum, I tried to reproduce this as described, but could not...sorry. Maybe Petr can.

Comment 5 Mike FABIAN 2016-03-18 15:04:06 UTC
(In reply to Adam Williamson from comment #4)
> Hum, I tried to reproduce this as described, but could not...sorry. Maybe
> Petr can.

I could not reproduce it either.

I used Fedora-Workstation-Live-x86_64-24_Alpha-5.iso, installed
in Japanese, did *not* create a user in Anaconda (I entered the root
password in Anaconda), and then selected German in gnome-initial-setup.

No crash.

Comment 6 Mike FABIAN 2016-03-18 15:09:18 UTC
It is strange that 

glibc-langpack-en-2.23.1-5.fc24.x86_64 *and* glibc-all-langpacks-2.23.1-5.fc24.x86_64

are installed. If glibc-all-langpacks is installed, then glibc-langpack-en
is redundant. And why glibc-langpack-en, why not glibc-langpack-ja if
the installation was done in Japanese?

Comment 7 Adam Williamson 2016-03-18 15:22:24 UTC
Probably because we added something somewhere to make sure glibc-langpack-en is pulled in for anaconda, I'm guessing.

Comment 8 Michael Catanzaro 2016-03-18 18:37:32 UTC
Using NEEDINFO to request a backtrace (you might need to use 'sudo abrt-cli' to get it)

Comment 9 Kamil Páral 2016-03-21 16:53:19 UTC
Discussed at today's blocker review meeting [1]. Voted as AcceptedFreezeException (Alpha) - though this one seems a bit vague at present, there's certainly a potential serious issue here, so we accept it as FE and if a clearly reproducible case is found and fixed, we will look at taking the fix


Comment 10 Petr Schindler 2016-06-28 14:48:57 UTC
I reproduced this with final release. I clicked on few languages in g-i-s and it crashed. I tried to reproduce after restart and it happened again (spanish -> german -> english -> crash)

I reported this with abrt-cli - bug 1350873

Comment 11 Michael Catanzaro 2016-06-28 15:32:53 UTC

*** This bug has been marked as a duplicate of bug 1350873 ***

Note You need to log in before you can comment on or make changes to this bug.