Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1322099 - gi.overrides.BlockDev.LVMError: Failed to call the 'PvScan' method on the '/com/redhat/lvmdbus1/Manager' object: GDBus.Error:org.freedesktop.DBus.Python.dbus.exceptions.DBusException: ('com.redhat.lvmdbus1.Manager', 'Device path (/dev/mapper/luks-85646...
Summary: gi.overrides.BlockDev.LVMError: Failed to call the 'PvScan' method on the '/c...
Keywords:
Status: CLOSED DUPLICATE of bug 1321085
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:b8e11dfd3df0ee61c9fd1312c91...
Depends On:
Blocks: F25BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2016-03-29 19:40 UTC by Adam Williamson
Modified: 2016-03-29 20:32 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-29 19:46:40 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
File: anaconda-tb (deleted)
2016-03-29 19:40 UTC, Adam Williamson
no flags Details
File: anaconda.log (deleted)
2016-03-29 19:40 UTC, Adam Williamson
no flags Details
File: dnf.log (deleted)
2016-03-29 19:40 UTC, Adam Williamson
no flags Details
File: environ (deleted)
2016-03-29 19:40 UTC, Adam Williamson
no flags Details
File: lsblk_output (deleted)
2016-03-29 19:40 UTC, Adam Williamson
no flags Details
File: nmcli_dev_list (deleted)
2016-03-29 19:40 UTC, Adam Williamson
no flags Details
File: os_info (deleted)
2016-03-29 19:41 UTC, Adam Williamson
no flags Details
File: program.log (deleted)
2016-03-29 19:41 UTC, Adam Williamson
no flags Details
File: storage.log (deleted)
2016-03-29 19:41 UTC, Adam Williamson
no flags Details
File: syslog (deleted)
2016-03-29 19:41 UTC, Adam Williamson
no flags Details
File: ifcfg.log (deleted)
2016-03-29 19:41 UTC, Adam Williamson
no flags Details
File: packaging.log (deleted)
2016-03-29 19:41 UTC, Adam Williamson
no flags Details

Description Adam Williamson 2016-03-29 19:40:48 UTC
Description of problem:
This crash occurs during LVM volume creation on current Rawhide installs when encryption is enabled. All openQA tests which use encryption have failed for the last two Rawhide composes with this crash.

Version-Release number of selected component:
anaconda-25.4-1

The following was filed automatically by anaconda:
anaconda 25.4-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python3.5/site-packages/gi/overrides/BlockDev.py", line 420, in wrapped
    raise transform[1](msg)
  File "/usr/lib/python3.5/site-packages/blivet/formats/lvmpv.py", line 121, in _create
    blockdev.lvm.pvscan(self.device)
  File "/usr/lib/python3.5/site-packages/blivet/formats/__init__.py", line 388, in create
    self._create(**kwargs)
  File "/usr/lib/python3.5/site-packages/blivet/deviceaction.py", line 590, in execute
    options=self.device.formatArgs)
  File "/usr/lib/python3.5/site-packages/blivet/actionlist.py", line 280, in process
    action.execute(callbacks)
  File "/usr/lib/python3.5/site-packages/blivet/devicetree.py", line 381, in processActions
    callbacks=callbacks)
  File "/usr/lib/python3.5/site-packages/blivet/blivet.py", line 164, in doIt
    self.devicetree.processActions(callbacks=callbacks)
  File "/usr/lib/python3.5/site-packages/blivet/osinstall.py", line 1096, in turnOnFilesystems
    storage.doIt(callbacks)
  File "/usr/lib64/python3.5/site-packages/pyanaconda/install.py", line 201, in doInstall
    turnOnFilesystems(storage, mountOnly=flags.flags.dirInstall, callbacks=callbacks_reg)
  File "/usr/lib64/python3.5/threading.py", line 862, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib64/python3.5/site-packages/pyanaconda/threads.py", line 253, in run
    threading.Thread.run(self, *args, **kwargs)
gi.overrides.BlockDev.LVMError: Failed to call the 'PvScan' method on the '/com/redhat/lvmdbus1/Manager' object: GDBus.Error:org.freedesktop.DBus.Python.dbus.exceptions.DBusException: ('com.redhat.lvmdbus1.Manager', 'Device path (/dev/mapper/luks-856462b6-ab9f-4ace-ba3b-c135b643b512) has invalid characters, allowable (abcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ0123456789#+.:=@_\\/%)')

Additional info:
addons:         com_redhat_docker, com_redhat_kdump
cmdline:        /usr/bin/python3  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-E-dvd-x86_64-rawh quiet
dnf.rpm.log:    Mar 29 19:30:18 INFO --- logging initialized ---
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.6.0-0.rc1.git0.1.fc25.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        rawhide

Comment 1 Adam Williamson 2016-03-29 19:40:53 UTC
Created attachment 1141410 [details]
File: anaconda-tb

Comment 2 Adam Williamson 2016-03-29 19:40:55 UTC
Created attachment 1141411 [details]
File: anaconda.log

Comment 3 Adam Williamson 2016-03-29 19:40:56 UTC
Created attachment 1141412 [details]
File: dnf.log

Comment 4 Adam Williamson 2016-03-29 19:40:57 UTC
Created attachment 1141413 [details]
File: environ

Comment 5 Adam Williamson 2016-03-29 19:40:58 UTC
Created attachment 1141414 [details]
File: lsblk_output

Comment 6 Adam Williamson 2016-03-29 19:40:58 UTC
Created attachment 1141415 [details]
File: nmcli_dev_list

Comment 7 Adam Williamson 2016-03-29 19:41:00 UTC
Created attachment 1141416 [details]
File: os_info

Comment 8 Adam Williamson 2016-03-29 19:41:01 UTC
Created attachment 1141417 [details]
File: program.log

Comment 9 Adam Williamson 2016-03-29 19:41:03 UTC
Created attachment 1141418 [details]
File: storage.log

Comment 10 Adam Williamson 2016-03-29 19:41:04 UTC
Created attachment 1141419 [details]
File: syslog

Comment 11 Adam Williamson 2016-03-29 19:41:05 UTC
Created attachment 1141420 [details]
File: ifcfg.log

Comment 12 Adam Williamson 2016-03-29 19:41:06 UTC
Created attachment 1141421 [details]
File: packaging.log

Comment 13 Adam Williamson 2016-03-29 19:43:56 UTC
Not sure if this affects F24 yet. For now, nominating as an F25 Beta blocker, per criterion "When using the guided partitioning flow, the installer must be able to: ... Complete an installation using any combination of disk configuration options it allows the user to select"

Comment 14 David Shea 2016-03-29 19:46:40 UTC

*** This bug has been marked as a duplicate of bug 1321085 ***


Note You need to log in before you can comment on or make changes to this bug.