Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1327169 - nameserver is not set during installation on s390x
Summary: nameserver is not set during installation on s390x
Keywords:
Status: CLOSED DUPLICATE of bug 1327204
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 24
Hardware: s390x
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Lubomir Rintel
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: ZedoraTracker
TreeView+ depends on / blocked
 
Reported: 2016-04-14 11:41 UTC by Jan Stodola
Modified: 2016-05-10 12:09 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-10 12:09:18 UTC
Type: Bug


Attachments (Terms of Use)
journalctl (182.99 KB, text/plain)
2016-04-14 11:42 UTC, Jan Stodola
no flags Details
/tmp/ifcfg.log (2.85 KB, text/plain)
2016-04-14 11:43 UTC, Jan Stodola
no flags Details

Description Jan Stodola 2016-04-14 11:41:32 UTC
Description of problem:
When installing Fedora 24 on s390x, nameserver is not set in /etc/resolv.conf in the installation environment:

[anaconda root@test ~]# ls -l /etc/resolv.conf 
lrwxrwxrwx. 1 root root 35 Apr 14 09:34 /etc/resolv.conf -> /var/run/NetworkManager/resolv.conf
[anaconda root@test ~]# cat /var/run/NetworkManager/resolv.conf
# Generated by NetworkManager
search redhat.com
[anaconda root@test ~]#

[anaconda root@test ~]# cat /proc/cmdline 
stage2=http://server.redhat.com/jstodola/f24_5 ro ramdisk_size=40000 cio_ignore=all,!condev rd.dasd=0.0.3124 rd.dasd=0.0.3724 rd.dasd=0.0.3524 rd.dasd=0.0.3024 rd.dasd=0.0.3424 rd.dasd=0.0.3324 rd.dasd=0.0.3624 rd.dasd=0.0.3224 rd.znet=qeth,0.0.0a00,0.0.0a01,0.0.0a02,layer2=1,portno=0 ip=10.16.105.195::10.16.111.254:21:test.redhat.com:enca00:none nameserver=10.16.36.29 BOOT_IMAGE=0
[anaconda root@test ~]#

Some notes:
* static IPv4 configuration was used
* nameserver is set in dracut's environment correctly (before switching to the installation env)
* not able to reproduce on x86_64
* the installation images were created locally by lorax-24.17-1.fc24, since there are no official F24 composes for s390x yet.

Version-Release number of selected component (if applicable):
NetworkManager-1.2.0-0.8.rc1.fc24
anaconda-24.13.3-1.fc24

How reproducible:
always on s390x

Steps to Reproduce:
1. start installation of F24 on s390x
2. let anaconda to download the repository metadata or check if nameservers are set

Actual results:
nameservers are not set

Expected results:
nameservers are set

Comment 1 Jan Stodola 2016-04-14 11:42:19 UTC
Created attachment 1147210 [details]
journalctl

Comment 2 Jan Stodola 2016-04-14 11:43:17 UTC
Created attachment 1147211 [details]
/tmp/ifcfg.log

Comment 3 Jan Stodola 2016-04-14 12:46:54 UTC
It might be related to bug bug 1327204 - Two network connections reported by nmcli during installation on s390x

Comment 4 Jan Stodola 2016-05-10 12:09:18 UTC
This issue gets fixed after applying patch from bug 1327204, so I'm closing this bug as a duplicate.

*** This bug has been marked as a duplicate of bug 1327204 ***


Note You need to log in before you can comment on or make changes to this bug.