Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1344141 - 'text' theme broken on Rawhide(?) means no decryption prompt shown on minimal encrypted install
Summary: 'text' theme broken on Rawhide(?) means no decryption prompt shown on minimal...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: plymouth
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1172740 (view as bug list)
Depends On:
Blocks: ARM64, F-ExcludeArch-aarch64
TreeView+ depends on / blocked
 
Reported: 2016-06-08 20:59 UTC by Adam Williamson
Modified: 2016-06-24 23:49 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-24 23:49:55 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1103393 0 medium CLOSED plymouth takes LUKS password only from VT, not serial console 2021-02-22 00:41:40 UTC

Internal Links: 1103393

Description Adam Williamson 2016-06-08 20:59:31 UTC
If you do an encrypted install of current Rawhide with a minimal package set ('Minimal' or 'custom operating system'), then boot the installed system, you see no passphrase entry prompt. If you hit 'esc', you do see one. You also get one - a graphical one - if you install a graphical plymouth theme (i.e. `dnf install plymouth-system-theme`) and rebuild the initramfs.

It seems the cause of this is likely that the 'text' theme (which is the only one available on a minimal install - no graphical theme is installed) is broken.

In F24 this works properly; you see a passphrase entry prompt.

This is breaking openQA encrypted install tests on Rawhide, e.g. https://openqa.stg.fedoraproject.org/tests/23111 .

Comment 1 Adam Williamson 2016-06-16 19:14:44 UTC
Things have changed a bit in the last few days but it still doesn't work. Now, with plymouth active, you do see a prompt, but it doesn't seem to work - typing the passphrase and hitting enter does nothing, the screen does not change at all.

If you drop 'rhgb quiet' from the boot params, you see a prompt mixed in with all the boot messages, and it works (typing the passphrase and hitting enter results in a successful boot).

Comment 2 Adam Williamson 2016-06-16 19:17:15 UTC
ray knows what's going on here (he first fixed the prompt not displaying at all, but then it turned out there's a crash after it displays, and he's only just fixed that). hopefully a working build will show up soon.

https://cgit.freedesktop.org/plymouth/commit/?id=2c7147ad098c07a3399edcef4c115e1ac728df3e (first fix)
https://cgit.freedesktop.org/plymouth/commit/?id=fd66c6903047b57bc71100549d4e15eea9deded4 (second fix)

Comment 3 Peter Robinson 2016-06-18 09:13:16 UTC
*** Bug 1172740 has been marked as a duplicate of this bug. ***

Comment 4 Adam Williamson 2016-06-19 01:22:59 UTC
Laszlo, I don't think this is related to your bug. This was a new thing that only showed up in Rawhide. The same did not happen with F24.

Comment 5 Laszlo Ersek 2016-06-19 19:13:43 UTC
Bug 1172740 -- reported on 2014-Dec-10 -- got closed as a duplicate of this bug (see bug 1172740 comment 26).

And bug 1103393 had been linked with bug 1172740 as "See Also" (see bug 1172740 comment 11 and bug 1172740 comment 12).

Therefore we have

  bug 1344141 <---dupe---> bug 1172740 <---see also---> bug 1103393

If both of those actions were correct, then a direct "See Also" between bug 1103393 and this bug (= 1344141) is also appropriate, transitively.

Bug 1103393 has not received much attention thus far, despite the repeated confirmations from different users, from F20 through F23. I added the direct "See Also" because I wanted bug 1103393 to reference a sibling bug that was open, and not closed (even as a duplicate of an open bug).

Comment 6 Adam Williamson 2016-06-24 23:49:55 UTC
well, anyhow, the one I reported is resolved now, the encrypted install test in openQA is passing:

https://openqa.stg.fedoraproject.org/tests/25777

the fix was in:

http://koji.fedoraproject.org/koji/buildinfo?buildID=773561

so closing.


Note You need to log in before you can comment on or make changes to this bug.