Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1344211 - gnome-shell crashes after some minutes
Summary: gnome-shell crashes after some minutes
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell
Version: 24
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-09 08:02 UTC by manuel
Modified: 2016-07-29 07:21 UTC (History)
6 users (show)

Fixed In Version: gnome-shell-3.20.3-1.fc24
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-29 07:21:35 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
Possible journalctl entries of crash (deleted)
2016-06-09 08:02 UTC, manuel
no flags Details
Journalctl output desktop crash (deleted)
2016-06-27 11:49 UTC, leo hermans
no flags Details


Links
System ID Private Priority Status Summary Last Updated
GNOME Bugzilla 764898 0 None None None 2016-06-09 08:02:08 UTC

Description manuel 2016-06-09 08:02:08 UTC
Created attachment 1166193 [details]
Possible journalctl entries of crash

Description of problem:

After starting a new Gnome session, ~ 5 minutes later the session crashes and the TTY appears. The Gnome session itself is still running and one could switch back to it by Alt-F2. After restarting Gnome (Alt-F2 -> “r”) everything’s back to normal and the crash does not appear again. So perhaps only new sessions are affected.

Bug might be already fixed upstream. See
https://bugzilla.gnome.org/show_bug.cgi?id=764898

According to the above mentioned bug report, only Hardware with Nvidia Graphics controller + nvidia kernel modules are affected.

Version-Release number of selected component (if applicable):

3.20.2

How reproducible:

Steps to Reproduce:
1. Start a new Gnome session.
2. Wait for some minutes.

Actual results:

Session crashes and TTY is shown.

Expected results:

Gnome session stays up and running.

Additional info:

Fedora 24 beta
Graphics card: Nvidia GeForce GTX 750 Ti
Kmod nvidia version 358.16
Kernel version 4.5.5-300.fc24.x86_64

The crash did not appear under Fedora 23.

Comment 1 Paul Lazaga 2016-06-26 18:49:13 UTC
(In reply to manuel from comment #0)
> Created attachment 1166193 [details]
> Possible journalctl entries of crash
> 
> Description of problem:
> 
> After starting a new Gnome session, ~ 5 minutes later the session crashes
> and the TTY appears. The Gnome session itself is still running and one could
> switch back to it by Alt-F2. After restarting Gnome (Alt-F2 -> “r”)
> everything’s back to normal and the crash does not appear again. So perhaps
> only new sessions are affected.
> 
> Bug might be already fixed upstream. See
> https://bugzilla.gnome.org/show_bug.cgi?id=764898
> 
> According to the above mentioned bug report, only Hardware with Nvidia
> Graphics controller + nvidia kernel modules are affected.
> 
> Version-Release number of selected component (if applicable):
> 
> 3.20.2
> 
> How reproducible:
> 
> Steps to Reproduce:
> 1. Start a new Gnome session.
> 2. Wait for some minutes.
> 
> Actual results:
> 
> Session crashes and TTY is shown.
> 
> Expected results:
> 
> Gnome session stays up and running.
> 
> Additional info:
> 
> Fedora 24 beta
> Graphics card: Nvidia GeForce GTX 750 Ti
> Kmod nvidia version 358.16
> Kernel version 4.5.5-300.fc24.x86_64
> 
> The crash did not appear under Fedora 23.

I am seeing this behavior as well.

Fedora 24
Graphics Nvidia GeForce GTX 550 Ti
Driver 367.27-2.fc24
Kernel 4.5.7-300.fc24
gnome-shell 3.20.2-1.fc24

Comment 2 leo hermans 2016-06-27 11:47:27 UTC
Experiencing the same problem. After 5 minutes the desktop disappears and TTY is showing. Alt-F2 does restore the desktop but I have to refresh the background most of the time because it is distorted. 
I enclose the journalctl output of the sec the desktop fails. Looks like nVidia problem to me.


Fedora 24
Graphics: GeForce GTX 960/PCIe/SSE2
NVidia: version 367.27  (buildmeister@swio-display-x64-rhel04-12)
Kernel: 4.5.7-300.fc24.x86_64
Gnome: Version 3.20.2

Comment 3 leo hermans 2016-06-27 11:49:46 UTC
Created attachment 1172861 [details]
Journalctl output desktop crash

Comment 4 Fedora Update System 2016-06-29 00:03:56 UTC
mutter-3.20.3-1.fc24 gnome-shell-3.20.3-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-fb66c6e22c

Comment 5 Fedora Update System 2016-06-29 22:55:52 UTC
gnome-shell-3.20.3-1.fc24, mutter-3.20.3-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-fb66c6e22c

Comment 6 Fedora Update System 2016-06-30 21:23:05 UTC
gnome-shell-3.20.3-1.fc24, mutter-3.20.3-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 7 manuel 2016-07-29 07:21:35 UTC
Since upgrading to gnome-shell-3.20.3-1.fc24 the bug did not appear again.


Note You need to log in before you can comment on or make changes to this bug.