Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at
Bug 1350144 - seamonkey crashes soon after start-up, but cannot create core file
Summary: seamonkey crashes soon after start-up, but cannot create core file
Alias: None
Product: Fedora
Classification: Fedora
Component: seamonkey
Version: 24
Hardware: i686
OS: Linux
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
: 1352236 1353886 (view as bug list)
Depends On:
TreeView+ depends on / blocked
Reported: 2016-06-26 03:02 UTC by John E. Harbold
Modified: 2016-07-10 05:53 UTC (History)
6 users (show)

Fixed In Version: seamonkey-2.40-5.fc24
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Last Closed: 2016-07-10 05:53:48 UTC
Type: Bug

Attachments (Terms of Use)
Crash information from journalctl -f (552 bytes, text/plain)
2016-06-26 03:02 UTC, John E. Harbold
no flags Details

Description John E. Harbold 2016-06-26 03:02:10 UTC
Created attachment 1172413 [details]
Crash information from journalctl -f

Description of problem:

I tried to start seamonkey, but, soon after start-up, it crashes, but no core file is create.  I set ulimit for core files to unlimited.

Version-Release number of selected component (if applicable):


How reproducible:

Every time I try to start seamonkey.

Steps to Reproduce:
1. Select seamonkey.
2. After few tens of seconds, it crashes.

Actual results:

Expected results:

Additional info:

From journalctl -f:

Jun 25 19:49:00 localhost.localdomain audit[15848]: ANOM_ABEND auid=4294967295 uid=1000 gid=1000 ses=4294967295 subj=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 pid=15848 comm="seamonkey" exe="/usr/lib/seamonkey/seamonkey" sig=11
Jun 25 19:49:00 localhost.localdomain abrt-hook-ccpp[15904]: Process 15848 (seamonkey) of user 1000 killed by SIGSEGV - dumping core
Jun 25 19:49:08 localhost.localdomain abrt-hook-ccpp[15904]: Failed to create core_backtrace: dwfl_getthread_frames failed: No DWARF information found

Comment 1 Dmitry Butskoy 2016-07-03 13:51:57 UTC
*** Bug 1352236 has been marked as a duplicate of this bug. ***

Comment 2 Fedora Update System 2016-07-03 17:02:11 UTC
seamonkey-2.40-4.fc24 has been submitted as an update to Fedora 24.

Comment 3 Yves L'ECUYER 2016-07-04 18:59:16 UTC
After Fedora 23 to Fedora 24 upgrade, in x86_64 release, I cannot use any more the mailer part of seamonkey. With my current account, as soon as I try to open the mailer, seamonkey crashes

If I remove my $HOME/.mozilla/seamonkey directory, I can open it, but at the end of creation of a new mail account, mozilla crashes again 

Other functionalities: web browser or cJohn E. Harboldomposer seams to work normally

Contrary to the problem mentioned aboveby John E. Harbold, I do not observe any crash, as long as I just use WEB browser!

In the link above
I cannot sea any downloadable rpm, so how can I try ???

But on the same link, an anonymous has already let a message:
"seamonkey-2.40-4.fc24.x86_64 still crashes in mailer part" !!!!

So the bug I observed seams always there. I say seams: I cannot try myself because there is no downloadable link for this update !!!!

Comment 4 Yves L'ECUYER 2016-07-04 19:12:11 UTC
OK I download the update from
But unfortunately, I confirm the observation by the anonymous on the link above, that seamonkey crashes as soon as seamonkey mailer is open, when You have already an account!

Comment 5 Dmitry Butskoy 2016-07-04 19:44:27 UTC
Does the problem exist if you downgrade to the F23's package of seamonkey? (Both cases, including clean profile).

Comment 6 Yves L'ECUYER 2016-07-04 20:54:11 UTC
I downgrade with your suggested package, from the link above:

but its not so obvious, because :
# dnf downgrade seamonkey-2.40-2.fc23.x86_64.rpm

refuse to install it because dependence is not installed
(currently only from libvpx-1.5.0-4.fc24.x86_64 is installed)

2) so I force it with:
# dnf remove seamonkey
# rpm -ivh seamonkey-2.40-2.fc23.x86_64.rpm --nodeps

3) Then, of course, after I launch seamonkey
it stops complaining about lacking
        $ seamonkey
        XPCOMGlueLoad error for file /usr/lib64/seamonkey/ cannot open shared object file: No such file or directory
        Couldn't load XPCOM.

4) So I try to install libvpx-1.4.0-6.fc24.x86_64.rpm
downloaded from :
to have this lacking lib:
# rpm -ivh libvpx-1.4.0-6.fc24.x86_64.rpm --excludedocs --force

5) I can use seamonkey normally under Fedora 24 !! AND especially seamonkey mail to read all my personnal mail, with my profile under $HOME/.mozilla/seamonkey/    

THANKS for the suggestion, 
it's better than the intermediate solution I used since 2 day: A virtual machine Fedora 23 running in VirtualBox, just to continue to read my mails !!!!

6) I tried also a clean profile :
-> close seamonkey 
-> rename $HOME/.mozilla/seamonkey in $HOME/.mozilla/seamonkey.ref
-> Then restart seamonkey and open seamonkey mailer
    I created a new mail account , AND fortunately NO CRASH at the end 
    of creation !
    I was able to use this new account normally to read my mails ,
    from my provider.
So expecting the definitive solution, I will live like that !

Comment 7 Fedora Update System 2016-07-05 00:13:53 UTC
seamonkey-2.40-5.fc24 has been submitted as an update to Fedora 24.

Comment 8 Yves L'ECUYER 2016-07-05 07:51:38 UTC
I removed the package seamonkey-2.40-2.fc23.x86_64.rpm described in comment 6,
# dnf remove seamonkey

then also the package libvpx-1.4.0-6.fc24.x86_64.rpm
# rpm -e libvpx-1.4.0-6.fc24 --nodeps
(I do that because with dnf remove, I have the message:
# dnf remove libvpx-1.4.0-6.fc24
Dependencies resolved.
 Package              Arch          Version                Repository      Size
 avidemux             x86_64        2.6.12-1.fc23          @System         18 k
 avidemux-cli         x86_64        2.6.12-1.fc23          @System        2.1 M
 avidemux-help        noarch        2.6.12-1.fc23          @System        1.4 M
 avidemux-i18n        noarch        2.6.12-1.fc23          @System        1.7 M
 avidemux-libs        x86_64        2.6.12-1.fc23          @System         13 M
 avidemux-qt          x86_64        2.6.12-1.fc23          @System        3.9 M
 libvpx               x86_64        1.4.0-6.fc24           @System        1.6 M

Transaction Summary
Remove  7 Packages

Installed size: 23 M
Is this ok [y/N]: n
and i don't want that avidemux fc23 is removed. I removed libvpx-1.4.0-6.fc24 to be sure that there is no dependencies with /usr/lib64/

NOW I installed the suggested package seamonkey-2.40-5.fc24, with null pointer optimization disabled for gcc6, from:

AND OK it's working, with no crash from seamonkey mail !!!
Thanks to Dmitry Butskoy

Comment 9 Fedora Update System 2016-07-05 08:52:19 UTC
seamonkey-2.40-5.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See for
instructions on how to install test updates.
You can provide feedback for this update here:

Comment 10 John E. Harbold 2016-07-05 23:02:10 UTC
I have downloaded seamonkey-2.40-5.fc24 and installed it along with the debug info.
I could then start seamonkey with both browser and mail client.
I'm adding this comment using seamonkey.


Who says this bug (1350144) is done?

Comment 11 Dmitry Butskoy 2016-07-08 10:50:27 UTC
*** Bug 1353886 has been marked as a duplicate of this bug. ***

Comment 12 David 2016-07-08 11:23:05 UTC
I've install seamonkey 2.40-5.fc24 from testing and it's working fine, Thanks for fixing it :)

Comment 13 Fedora Update System 2016-07-10 05:53:45 UTC
seamonkey-2.40-5.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.