Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1370261 - catalina.out is no longer in use, but still gets rotated
Summary: catalina.out is no longer in use, but still gets rotated
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: tomcat
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Coty Sutherland
QA Contact: tomcat-qe
URL:
Whiteboard:
Depends On:
Blocks: 1370262
TreeView+ depends on / blocked
 
Reported: 2016-08-25 18:27 UTC by Coty Sutherland
Modified: 2020-03-31 13:57 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1370262 (view as bug list)
Environment:
Last Closed: 2020-03-31 13:57:26 UTC
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)

Description Coty Sutherland 2016-08-25 18:27:21 UTC
Description of problem:
After the update from systemv to systemd for tomcat the service no longer writes console output to catalina.out. Instead, all of the console output is just written to stdout, which is received by the journal (and can be reviewed with `journalctl -u tomcat`. This means that nothing is redirected to catalina.out like systemv did, and therefore it's always empty. Additionally, there is a logrotate script included in the package that rotates the empty file weekly.

Version-Release number of selected component (if applicable):
tomcat-7.0.69-10.el7.noarch

How reproducible:
Always.

Steps to Reproduce:
1. `yum install tomcat` to get the package installed (note that it installs an empty catalina.out file in /var/log/tomcat)
2. `service tomcat start && service tomcat stop` to get some logging
3. Observe that /var/log/tomcat/catalina.out remains empty while another file (catalina.$(date).log) is populated with the logging. You can also see the stdout by using `journalctl -u tomcat`.

Actual results:
The tomcat processes stdout is no longer redirected to catalina.out, but instead received by the journal.

Expected results:
This is expected behavior, but the bug is being filed to cleanup the catalina.out file and logrotate script that rotates it.

Additional info:
The file and script can be deleted because tomcat handles it's on file rotation by default.

Comment 2 Coty Sutherland 2016-09-14 13:48:00 UTC
Instead of deleting the scripts, I'm going to move them into the JSVC subpackage since they can still be used there.

Comment 3 Coty Sutherland 2020-03-31 13:57:19 UTC
I reported this issue quite a while ago and there has been no customer interest in fixing it (no attached cases). The fix would likely just be moving the logrotate config to the jsvc package, so it doesn't hurt anything to stay as is.

Comment 4 RHEL Program Management 2020-03-31 13:57:26 UTC
Development Management has reviewed and declined this request. You may appeal this decision by using your Red Hat support channels, who will make certain  the issue receives the proper prioritization with product and development management.

https://www.redhat.com/support/process/production/#howto


Note You need to log in before you can comment on or make changes to this bug.