Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1371310 - ytree segfaults
Summary: ytree segfaults
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ytree
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Minto Joseph
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-29 21:40 UTC by Ali Akcaagac
Modified: 2016-12-11 23:50 UTC (History)
1 user (show)

Fixed In Version: ytree-1.99pl1-1.fc25 ytree-1.99pl1-1.fc24 ytree-1.99pl1-1.fc23
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-11 19:26:42 UTC
Type: Bug


Attachments (Terms of Use)
ytree crash picture (128.82 KB, image/png)
2016-08-30 08:56 UTC, Ali Akcaagac
no flags Details
ytree crash full backtrace (1.98 version) (4.99 KB, text/plain)
2016-08-30 08:57 UTC, Ali Akcaagac
no flags Details

Description Ali Akcaagac 2016-08-29 21:40:01 UTC
ytree on Fedora 24 x86_64 segfaults if you press CTRL+F two times.

How to reproduce:

1) dnf install ytree
2) start ytree
3) press CTRL+F
4) the view changes into dirmode (I think)
5) press CTRL+F again

segfault!

Comment 1 Ali Akcaagac 2016-08-30 08:55:41 UTC
I also detected that ytree 1.97-9 (Fedora 24) shows the Path: incorrectly inside ytree (top left corner). As you can see in the picture (attachment) the Path: shows like this /mmmoommmoo/mooo/m:ooo/m... which looks like a pinter issue to me.

So I went to the main webpage of ytree and downloaded 1.98 and compiled this on my own. The 1.98 version shows correct Path: at the top left corner. Sadly it has the same segfault issue like 1.97-9 (Fedora 24).

I captured both ytree versions inside pictures and generated a full backtrace of the *upstream* 1.98 version (compiled by my own). I will also report the issues to the *upstream* maintainer and point to this bugreport here.

Btw: ytree in color looks much better :)

Comment 2 Ali Akcaagac 2016-08-30 08:56:14 UTC
Created attachment 1195767 [details]
ytree crash picture

Comment 3 Ali Akcaagac 2016-08-30 08:57:08 UTC
Created attachment 1195768 [details]
ytree crash full backtrace (1.98 version)

CFLAGS="-O0 -g"

Comment 4 Ali Akcaagac 2016-09-04 18:18:40 UTC
I'd like to inform, that upstream has released a new version, that takes care of all known issues so far. I would like to ask for an updated rpm package.

http://www.han.de/~werner/ytree.html
http://www.han.de/~werner/ytree-1.99pl1.tar.gz

Comment 5 Fedora Update System 2016-12-02 02:49:37 UTC
ytree-1.99pl1-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-17bea83fe5

Comment 6 Fedora Update System 2016-12-02 02:49:49 UTC
ytree-1.99pl1-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-337c540167

Comment 7 Fedora Update System 2016-12-02 02:49:56 UTC
ytree-1.99pl1-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-1bed6fbeac

Comment 8 Fedora Update System 2016-12-03 04:29:33 UTC
ytree-1.99pl1-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-1bed6fbeac

Comment 9 Fedora Update System 2016-12-03 04:36:49 UTC
ytree-1.99pl1-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-337c540167

Comment 10 Fedora Update System 2016-12-03 05:42:00 UTC
ytree-1.99pl1-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-17bea83fe5

Comment 11 Fedora Update System 2016-12-11 19:26:42 UTC
ytree-1.99pl1-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2016-12-11 21:53:49 UTC
ytree-1.99pl1-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2016-12-11 23:50:54 UTC
ytree-1.99pl1-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.