Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1384671 - system-config-language does not work under Wayland
Summary: system-config-language does not work under Wayland
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-language
Version: 27
Hardware: All
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Parag Nemade
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1732630 (view as bug list)
Depends On:
Blocks: WaylandRelated
TreeView+ depends on / blocked
 
Reported: 2016-10-13 19:38 UTC by Giulio 'juliuxpigface'
Modified: 2019-07-24 03:50 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-06 13:50:47 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Giulio 'juliuxpigface' 2016-10-13 19:38:28 UTC
Description of problem:

system-config-language can't be launched on a Gnome+Wayland session.
Here's the output I get when launching system-config-language from terminal:

$ system-config-language 
No protocol specified
Unable to init server: Could not connect: Connection refused
No protocol specified
Unable to init server: Impossibile connettersi: Connection refused
No protocol specified
Unable to init server: Impossibile connettersi: Connection refused

(system-config-language.py:5558): Gtk-WARNING **: cannot open display: :0


Version-Release number of selected component (if applicable):
system-config-language-3.4.0-1.fc25.noarch

How reproducible:
Always

Steps to Reproduce:
1.Open system-config-language


Actual results:
The tool crashes.

Expected results:
Ideally, the tool should work under wayland too

Additional info:
I set "severity" to low, since Gnome uses different tools in order to change system's language.

Comment 1 Giulio 'juliuxpigface' 2016-10-13 20:34:06 UTC
I can confirm the issue isn't reproducible on Gnome+Xorg. Setting this to block the "Wayland-related" tracker.

Comment 2 Christian Stadelmann 2016-10-13 21:12:57 UTC
Probably related to:

Bug #1274451 - sudo with graphical apps doesn't work on wayland 

Bug #1284222 - Application wont start on Gnome Wayland

Comment 3 Parag Nemade 2016-10-19 06:31:21 UTC
so I tested the workaround suggested in bug#1274451 which is working fine.

Execute this first 
xhost +si:localuser:root

and then run this application.

Comment 4 Parag Nemade 2017-09-28 03:49:28 UTC
I still have not got time to look how can this application be started under wayland without any extra settings.

Comment 5 Parag Nemade 2018-04-06 13:50:47 UTC
Well, I am inclined to close this as WONTFIX based on the resolution provided for bug#1274451

Comment 6 Parag Nemade 2019-07-24 03:50:52 UTC
*** Bug 1732630 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.