Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1385385 - Writer: Crash when editing form
Summary: Writer: Crash when editing form
Keywords:
Status: CLOSED DUPLICATE of bug 1390610
Alias: None
Product: Fedora
Classification: Fedora
Component: libreoffice
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-16 17:17 UTC by Christian Stadelmann
Modified: 2016-11-10 15:22 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-10 15:22:08 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
Backtrace created following https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#GNU.2FLinux:_How_to_get_a_backtrace (deleted)
2016-10-16 17:17 UTC, Christian Stadelmann
no flags Details

Description Christian Stadelmann 2016-10-16 17:17:43 UTC
Created attachment 1211019 [details]
Backtrace created following https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#GNU.2FLinux:_How_to_get_a_backtrace

Version-Release number of selected component (if applicable):
libreoffice-gtk3-5.2.2.2-3.fc25.x86_64
gtk3-3.22.1-2.fc25.x86_64

How reproducible:
Often, but not always

Steps to Reproduce:
1. Open a Writer document
2. add a text field form
3. double-click on form to open dialog for changing form properties

Actual results:
When opening or closing this dialog, LibreOffice often crashes

Expected results:
No crash

Comment 1 Christian Stadelmann 2016-10-16 18:08:26 UTC
Sometimes LibreOffice crashes when moving the forms dialog too.

Sometimes the forms dialog doesn't get keyboard focus so that it is impossible to type in it. Mouse focus works fine though.

Comment 2 David Tardon 2016-10-17 07:26:54 UTC
Steps to reproduce:
1. Create a Writer document.
2. Insert any form control.
3. Open either control or form properties dialog.
4. Move the dialog window.

This always results in a crash here. The crash is gtk3-only.

Comment 3 Caolan McNamara 2016-11-10 15:22:08 UTC

*** This bug has been marked as a duplicate of bug 1390610 ***


Note You need to log in before you can comment on or make changes to this bug.