Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1388761 - [GTK3] [Wayland] Slides Pane gets wrong size for its separate window in LibreOffice Impress
Summary: [GTK3] [Wayland] Slides Pane gets wrong size for its separate window in Libre...
Keywords:
Status: CLOSED DUPLICATE of bug 1390610
Alias: None
Product: Fedora
Classification: Fedora
Component: libreoffice
Version: 25
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-26 06:39 UTC by Anass Ahmed
Modified: 2016-11-08 13:33 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-08 13:33:30 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
Screenshot of Slides Pane window with the misplaced popover. (deleted)
2016-10-26 06:49 UTC, Anass Ahmed
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Document Foundation 103510 0 None None None 2016-10-26 06:39:16 UTC

Description Anass Ahmed 2016-10-26 06:39:17 UTC
Description of problem:
I use LibreOffice 5.2 on Fedora 25 (Wayland + GTK3) and I have a problem that stayed from 5.1 on Fedora 24. I've mistakenly undocked the slides pane in Impress, but I couldn't return it back because the window got wrong size that doesn't show the contents of the window, but only the title. When I try to drag the tilebar, Impress crashes.

There's also a misplaced popover (tooltip) outside of the window pointing to a slide.

Sometimes when I hide the slides pane, and show it back (from the View menu), it gets docked back to its place in the main window, but when I close Impress and open it back, I lose it again.

Version-Release number of selected component (if applicable):
libreoffice-impress-5.2.3.1-1.fc25.x86_64
libreoffice-opensymbol-fonts-5.2.3.1-1.fc25.noarch
libreoffice-ure-5.2.3.1-1.fc25.x86_64
libreoffice-graphicfilter-5.2.3.1-1.fc25.x86_64
libreoffice-pyuno-5.2.3.1-1.fc25.x86_64
libreoffice-5.2.3.1-1.fc25.x86_64
libreoffice-langpack-en-5.2.3.1-1.fc25.x86_64
libreoffice-base-5.2.3.1-1.fc25.x86_64
libreoffice-core-5.2.3.1-1.fc25.x86_64
libreoffice-gtk2-5.2.3.1-1.fc25.x86_64
libreoffice-emailmerge-5.2.3.1-1.fc25.x86_64
libreoffice-x11-5.2.3.1-1.fc25.x86_64
libreoffice-gtk3-5.2.3.1-1.fc25.x86_64
libreoffice-writer-5.2.3.1-1.fc25.x86_64
libreoffice-pdfimport-5.2.3.1-1.fc25.x86_64
libreoffice-draw-5.2.3.1-1.fc25.x86_64
libreoffice-data-5.2.3.1-1.fc25.noarch
libreoffice-calc-5.2.3.1-1.fc25.x86_64
libreoffice-ogltrans-5.2.3.1-1.fc25.x86_64
libreoffice-math-5.2.3.1-1.fc25.x86_64
libreoffice-ure-common-5.2.3.1-1.fc25.noarch

How reproducible:
Always

Steps to Reproduce:
1. Open Impress.
2. Undock the slide pane.
3. Drag the titlebar of the Slides Pane window.

Actual results:
- Slides Pane window with no contents.
- Misplaced popover (tooltip) of a slide in Slides Pane.
- Dragging its titlebar crashes Impress.

Expected results:
- Slides Pane window gets the right size to show its contents.
- The popover appears right beside its slide thumbnail.
- Dragging titlebar doesn't crash Impress.

Additional info:

Comment 1 Anass Ahmed 2016-10-26 06:49:50 UTC
Created attachment 1214189 [details]
Screenshot of Slides Pane window with the misplaced popover.

See the top left corner for the Slides Pane window titlebar.

It's worth to mention that LibreOffice main window buttons/menus become unusable (sensitive but don't show menus) while the Slides Panes in this state.

Comment 2 Kamil Páral 2016-11-08 13:33:30 UTC

*** This bug has been marked as a duplicate of bug 1390610 ***


Note You need to log in before you can comment on or make changes to this bug.