Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1390006 - SELinux is preventing gutenprint52+us from using the 'wake_alarm' capabilities.
Summary: SELinux is preventing gutenprint52+us from using the 'wake_alarm' capabilities.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 24
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:363f689361791ab26103b0c6948...
: 1385769 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-30 17:37 UTC by Shaun Assam
Modified: 2016-11-19 17:28 UTC (History)
26 users (show)

Fixed In Version: selinux-policy-3.13.1-191.21.fc24
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-19 17:24:12 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Shaun Assam 2016-10-30 17:37:59 UTC
Description of problem:
- Installed package 'system-config-printer'
- Opened Printer Config program and clicked button to Add Printer
- SELinux Alert Browser opened with warning: 'SELinux is preventing gutenprint52+us from using the 'wake_alarm' capabilities.'
SELinux is preventing gutenprint52+us from using the 'wake_alarm' capabilities.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that gutenprint52+us should have the wake_alarm capability by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'gutenprint52+us' --raw | audit2allow -M my-gutenprint52us
# semodule -X 300 -i my-gutenprint52us.pp

Additional Information:
Source Context                system_u:system_r:cupsd_t:s0-s0:c0.c1023
Target Context                system_u:system_r:cupsd_t:s0-s0:c0.c1023
Target Objects                Unknown [ capability2 ]
Source                        gutenprint52+us
Source Path                   gutenprint52+us
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-191.19.fc24.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.8.4-200.fc24.x86_64 #1 SMP Tue
                              Oct 25 13:06:04 UTC 2016 x86_64 x86_64
Alert Count                   4
First Seen                    2016-10-30 13:33:55 EDT
Last Seen                     2016-10-30 13:33:56 EDT
Local ID                      dcf77b21-7ffc-4a7f-a575-9c3960015244

Raw Audit Messages
type=AVC msg=audit(1477848836.525:361): avc:  denied  { wake_alarm } for  pid=6482 comm="hpfax" capability=35  scontext=system_u:system_r:cupsd_t:s0-s0:c0.c1023 tcontext=system_u:system_r:cupsd_t:s0-s0:c0.c1023 tclass=capability2 permissive=0


Hash: gutenprint52+us,cupsd_t,cupsd_t,capability2,wake_alarm

Version-Release number of selected component:
selinux-policy-3.13.1-191.19.fc24.noarch

Additional info:
reporter:       libreport-2.7.2
hashmarkername: setroubleshoot
kernel:         4.8.4-200.fc24.x86_64
type:           libreport

Potential duplicate: bug 1385769

Comment 1 Lukas Vrabec 2016-10-31 21:37:43 UTC
*** Bug 1385769 has been marked as a duplicate of this bug. ***

Comment 2 Saad 2016-11-03 10:34:41 UTC
Description of problem:
I plugged in an HP Laserjet 1320n printer and SELinux reported this AVC denial.

Version-Release number of selected component:
selinux-policy-3.13.1-191.19.fc24.noarch

Additional info:
reporter:       libreport-2.7.2
hashmarkername: setroubleshoot
kernel:         4.8.4-200.fc24.x86_64
type:           libreport

Comment 3 Raphael Groner 2016-11-03 21:55:59 UTC
Description of problem:
I get daily this error just after every new login but on this box only. 
It's not reproducible on another box, I assume a relation to specific configuration settings.

Version-Release number of selected component:
selinux-policy-3.13.1-191.19.fc24.noarch

Additional info:
reporter:       libreport-2.7.2
hashmarkername: setroubleshoot
kernel:         4.8.4-200.fc24.x86_64
type:           libreport

Comment 4 Edward 2016-11-05 15:07:44 UTC
Description of problem:
Was printing a test page (ink cartridge cleaning).


Additional info:
reporter:       libreport-2.7.2
hashmarkername: setroubleshoot
kernel:         4.8.4-200.fc24.x86_64
type:           libreport

Comment 5 Jan Černý 2016-11-06 18:41:30 UTC
Description of problem:
I tried to print an one-page text document from Libre Office Writer on HP LaserJet P1102.

Version-Release number of selected component:
selinux-policy-3.13.1-191.19.fc24.noarch

Additional info:
reporter:       libreport-2.7.2
hashmarkername: setroubleshoot
kernel:         4.8.4-200.fc24.x86_64
type:           libreport

Comment 6 danil rost 2016-11-07 14:23:22 UTC
Version-Release number of selected component:
selinux-policy-3.13.1-220.fc25.noarch

Additional info:
reporter:       libreport-2.8.0
hashmarkername: setroubleshoot
kernel:         4.8.6-300.fc25.x86_64
type:           libreport

Comment 7 Nikita Bige 2016-11-09 05:02:16 UTC
*** Bug 1393194 has been marked as a duplicate of this bug. ***

Comment 8 Fedora Update System 2016-11-09 16:31:30 UTC
selinux-policy-3.13.1-191.21.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-abb3ede5d5

Comment 9 István Varga 2016-11-09 20:40:17 UTC
Description of problem:
Printer has been connected to the machine on usb port

Version-Release number of selected component:
selinux-policy-3.13.1-191.19.fc24.noarch

Additional info:
reporter:       libreport-2.7.2
hashmarkername: setroubleshoot
kernel:         4.8.4-200.fc24.x86_64
type:           libreport

Comment 10 Luís Silva 2016-11-10 17:18:35 UTC
Description of problem:
Connect printer+scanner


Additional info:
reporter:       libreport-2.8.0
hashmarkername: setroubleshoot
kernel:         4.8.6-300.fc25.x86_64
type:           libreport

Comment 11 Shaun Assam 2016-11-10 22:51:12 UTC
- Removed printer from Print Settings.
- Added printer to ensure the error message still appeared; received the error message; removed printer.
- Downloaded selinux-policy-3.13.1-191.21.fc24 packages and performed upgrades; rebooted computer.
- Opened Print Settings and added HP Deskjet 2540 printer; checked SELinux Troubleshooter; no error messages.
- Test print successful; no SELinux errors.
- Updates resolved this issue.

Thank you.

Comment 12 Fedora Update System 2016-11-11 05:01:11 UTC
selinux-policy-3.13.1-191.21.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-abb3ede5d5

Comment 13 Michal Nowak 2016-11-12 15:37:07 UTC
Description of problem:
Turned on Samsung printer.

Version-Release number of selected component:
selinux-policy-3.13.1-191.20.fc24.noarch

Additional info:
reporter:       libreport-2.7.2
hashmarkername: setroubleshoot
kernel:         4.8.4-200.fc24.x86_64
type:           libreport

Comment 14 Raphael Groner 2016-11-12 17:02:11 UTC
(In reply to Fedora Update System from comment #12)
> selinux-policy-3.13.1-191.21.fc24 has been pushed to the Fedora 24 testing
> repository. If problems still persist, please make note of it in this bug
> report.
> See https://fedoraproject.org/wiki/QA:Updates_Testing for
> instructions on how to install test updates.
> You can provide feedback for this update here:
> https://bodhi.fedoraproject.org/updates/FEDORA-2016-abb3ede5d5

The error is gone on my system with this update applied.

Comment 15 Alessandro Machado 2016-11-14 14:45:04 UTC
*** Bug 1394838 has been marked as a duplicate of this bug. ***

Comment 16 lennart_reuther 2016-11-15 17:38:59 UTC
Description of problem:
Starting Scanner "Epson PID 0884" after opening SimpleScan

Version-Release number of selected component:
selinux-policy-3.13.1-222.fc25.noarch

Additional info:
reporter:       libreport-2.8.0
hashmarkername: setroubleshoot
kernel:         4.8.6-300.fc25.x86_64
type:           libreport

Comment 17 Dominik 'Rathann' Mierzejewski 2016-11-17 12:18:54 UTC
Description of problem:
Printed a document from atril and another from LibreOffice Writer. Printer was turned on with no paper and paper was subsequently supplied.

Version-Release number of selected component:
selinux-policy-3.13.1-191.20.fc24.noarch

Additional info:
reporter:       libreport-2.7.2
hashmarkername: setroubleshoot
kernel:         4.8.6-201.fc24.x86_64
type:           libreport

Comment 18 Fedora Update System 2016-11-19 17:24:12 UTC
selinux-policy-3.13.1-191.21.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.