Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1417092 - SIGSEGV caused by problematic frame: C [libfreeblpriv3.so+0x2077b]
Summary: SIGSEGV caused by problematic frame: C [libfreeblpriv3.so+0x2077b]
Keywords:
Status: CLOSED DUPLICATE of bug 1415137
Alias: None
Product: Fedora
Classification: Fedora
Component: java-1.8.0-openjdk
Version: 25
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Deepak Bhole
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-27 08:25 UTC by Giordano Battilana
Modified: 2017-01-27 15:46 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-27 11:37:51 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
JDK java.security.SignatureException error (deleted)
2017-01-27 08:25 UTC, Giordano Battilana
no flags Details
JDK SIGSEGV error (deleted)
2017-01-27 08:26 UTC, Giordano Battilana
no flags Details
Error report file generated by the SIGSEGV error (deleted)
2017-01-27 08:28 UTC, Giordano Battilana
no flags Details

Description Giordano Battilana 2017-01-27 08:25:27 UTC
Created attachment 1245052 [details]
JDK java.security.SignatureException error

Description of problem:

In the last 2 days (I suspect after some package upgrade) the OpenJDK has stopped working properly.

I cleared my ~/.gradle/ directory, except for the gradle.properties file with the properties:
org.gradle.daemon=true
org.gradle.jvmargs=-Xmx2048M

Now whenever I try to run gradle in one of my projects the JDK fails to start and outputs either a "java.security.SignatureException: Signature does not match." exception or a SIGSEGV exception.


Version-Release number of selected component (if applicable):

copy-jdk-configs.noarch                2.0-1.fc25               @updates        
java-1.8.0-openjdk.x86_64              1:1.8.0.111-5.b16.fc25   @updates        
java-1.8.0-openjdk-devel.x86_64        1:1.8.0.111-5.b16.fc25   @updates        
java-1.8.0-openjdk-headless.x86_64     1:1.8.0.111-5.b16.fc25   @updates 

How reproducible:
Happens all the time.


Steps to Reproduce:
1.Setup a gradle project on a Fedora 25 up-to-date installation
2.Clear .gradle/ directory, to make sure that the gradle wrapper has to download the gradle distribution
3. run from the project root ./gradlew build

Actual results:
One of the 2 errors attached to the bug report

Expected results:
Gradle compilation starts

Additional info:
I ran memtest86+ 5.01 and found no errors in the RAM
I ran SMART tests on the disk and the disk is in shape. 
If I set JAVA_HOME to a JDK downloaded from java.com the compilation works

Comment 1 Giordano Battilana 2017-01-27 08:26:42 UTC
Created attachment 1245053 [details]
JDK SIGSEGV error

Comment 2 Giordano Battilana 2017-01-27 08:28:34 UTC
Created attachment 1245054 [details]
Error report file generated by the SIGSEGV error

Comment 3 Severin Gehwolf 2017-01-27 11:37:51 UTC
This is a known issue. Please update to java-1.8.0-openjdk-1.8.0.121-1.b14.fc25 which seems is unfortunately stuck in bodhi:
https://bodhi.fedoraproject.org/updates/FEDORA-2017-4076cf8494

Try downloading the builds from koji and install them via dnf. Alternatively downgrade nss* packages to version 3.27.

*** This bug has been marked as a duplicate of bug 1415137 ***

Comment 4 Giordano Battilana 2017-01-27 15:46:42 UTC
I can confirm that the packages you pointed me to fixed the issue.
Thanks!


Note You need to log in before you can comment on or make changes to this bug.