Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1428554 - ecryptfs-utils: FTBFS in Fedora rawhide
Summary: ecryptfs-utils: FTBFS in Fedora rawhide
Keywords:
Status: CLOSED DUPLICATE of bug 1384023
Alias: None
Product: Fedora
Classification: Fedora
Component: ecryptfs-utils
Version: rawhide
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Michal Hlavinka
QA Contact: Fedora Extras Quality Assurance
URL: http://apps.fedoraproject.org/koschei...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-02 19:51 UTC by Raphael Groner
Modified: 2017-06-04 19:52 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-03 06:12:48 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
build.log (x86_64) (deleted)
2017-03-02 19:51 UTC, Raphael Groner
no flags Details

Description Raphael Groner 2017-03-02 19:51:04 UTC
Created attachment 1259316 [details]
build.log (x86_64)

Description of problem:
Package ecryptfs-utils fails to build from source in Fedora rawhide.

Version-Release number of selected component (if applicable):
111-2.fc25

Steps to Reproduce:
koji build --scratch f27 ecryptfs-utils-111-2.fc25.src.rpm

Additional info:
This package is tracked by Koschei. See:
http://apps.fedoraproject.org/koschei/package/ecryptfs-utils


Interesting part of build.log (x86_64):

ecryptfs_key_mod_pkcs11_helper.c: In function 'ecryptfs_pkcs11h_get_public_key':
ecryptfs_key_mod_pkcs11_helper.c:284:12: error: dereferencing pointer to incomplete type 'EVP_PKEY {aka struct evp_pkey_st}'
  if (pubkey->type != EVP_PKEY_RSA) {
            ^~
ecryptfs_key_mod_pkcs11_helper.c: In function 'ecryptfs_pkcs11h_get_key_sig':
ecryptfs_key_mod_pkcs11_helper.c:333:25: error: dereferencing pointer to incomplete type 'RSA {aka struct rsa_st}'
  nbits = BN_num_bits(rsa->n);
                         ^~
ecryptfs_key_mod_openssl.c: In function 'ecryptfs_openssl_generate_signature':
ecryptfs_key_mod_openssl.c:155:25: error: dereferencing pointer to incomplete type 'RSA {aka struct rsa_st}'
  nbits = BN_num_bits(key->n);
                         ^~
ecryptfs_key_mod_openssl.c: In function 'ecryptfs_openssl_read_key':
ecryptfs_key_mod_openssl.c:281:2: error: implicit declaration of function 'CRYPTO_malloc_init'; did you mean 'CRYPTO_malloc'? [-Werror=implicit-function-declaration]
  CRYPTO_malloc_init();
  ^~~~~~~~~~~~~~~~~~
  CRYPTO_malloc
ecryptfs_key_mod_openssl.c:318:2: error: 'ERR_remove_state' is deprecated [-Werror=deprecated-declarations]
  ERR_remove_state(0);
  ^~~~~~~~~~~~~~~~
In file included from /usr/include/openssl/opensslconf.h:42:0,
                 from /usr/include/openssl/x509_vfy.h:20,
                 from /usr/include/openssl/x509.h:309,
                 from /usr/include/openssl/pem.h:17,
                 from ecryptfs_key_mod_openssl.c:44:
/usr/include/openssl/err.h:247:1: note: declared here
 DEPRECATEDIN_1_0_0(void ERR_remove_state(unsigned long pid))
 ^
ecryptfs_key_mod_openssl.c: In function 'ecryptfs_openssl_generate_key':
ecryptfs_key_mod_openssl.c:355:2: error: 'RSA_generate_key' is deprecated [-Werror=deprecated-declarations]
  if ((rsa = RSA_generate_key(1024, 65537, NULL, NULL)) == NULL) {
  ^~
In file included from /usr/include/openssl/opensslconf.h:42:0,
                 from /usr/include/openssl/rsa.h:13,
                 from /usr/include/openssl/x509.h:31,
                 from /usr/include/openssl/pem.h:17,
                 from ecryptfs_key_mod_openssl.c:44:
/usr/include/openssl/rsa.h:193:1: note: declared here
 DEPRECATEDIN_0_9_8(RSA *RSA_generate_key(int bits, unsigned long e, void
 ^

Comment 1 Michal Hlavinka 2017-03-03 06:12:48 UTC

*** This bug has been marked as a duplicate of bug 1384023 ***


Note You need to log in before you can comment on or make changes to this bug.